Armed-Assault.de Twitter
Antwort
 
Themen-Optionen Ansicht
Alt 07.03.2013, 12:50   #21 (permalink)
His Awesomeness!
10 Jahre hx3
5000 Beiträge
 
Benutzerbild von flickflack
 
Registriert seit: 25.07.2006
Ort: Regnum Borussiae
Beiträge: 9.282
Standard

Ansonsten echt einfach mitm 32Bit Linux, oder Windows probieren, wenn da eh nur Arma und TS drauf laufen soll
flickflack ist offline   Mit Zitat antworten
Alt 07.03.2013, 13:06   #22 (permalink)
Newbie
 
Registriert seit: 01.03.2013
Ort: Bayern
Alter: 42
Beiträge: 26
Standard

Zitat:

Und wenns nur Probleme macht und ihr nicht so recht klarkommt, warum dann nicht einfach einen Windows-Server nehmen, oder mal 32Bit Linux installieren? Ich meine der Arma-Server ist eh 32Bit.


das is natürlich ein guter Einwand.
Ich versuch mal ein 32Bit Betriebssystem draufzuspielen...
Butterzeugs ist offline   Mit Zitat antworten
Alt 07.03.2013, 13:14   #23 (permalink)
His Awesomeness!
10 Jahre hx3
5000 Beiträge
 
Benutzerbild von flickflack
 
Registriert seit: 25.07.2006
Ort: Regnum Borussiae
Beiträge: 9.282
Standard

Es kann wie gesagt auch wirklich sein, dass deine Distro keine aktuelle LIB-Version anbietet. Er sülzt ja wegen GLIBCXX. Eventuell ein aktuelles Ubuntu probieren. Ist ja auch ein Debian unter der Haube.

Du könntest außerdem noch probieren, ob "sudo dist-upgrade" doch noch etwas neues liefert, falls sich die Paketquellen aktualisiert haben sollten. Danach bin ich mit meinem Latein am Ende.

Oder eben manuell neue LIB-Version (wie Psycho zeigt) saugen und direkt ins Verzeichnis pumpen. Achte aber auf die Architektur denn - und das veränderte Startskript ^^

Viel Glück!

P.S Wenn Du's geschafft hast, wird Dich ein Gefühl der Freude überwältigen, den Pinguin besiegt zu haben ^^

€: Vllt findeste noch etwas über diesen Query:

http://www.google.de/#hl=de&output=s...=1745&bih=1033

Zitat von http://www.linuxquestions.org/questions/slackware-14/usr-lib64-libstdc-so-6-version-%60glibcxx_3-4-15-not-found-919350/

GLIBCXX_3.4.15 is an object in libstdc++.so.6.0.16.
( libstdc++.so.6.0.15 ? ).
'libstdc++.so.6.0.16' is part of gcc-4.6.x .


Not very smart to compile a game with the "compiler of tomorrow".
Slackware current has gcc-4.5.3 .
OS' with 4.6 : Fedora 15-16 , Debian Wheezy and Sid.

Solution : Compile gcc-4.6.2 with --prefix=/usr/local/gcc462/,
copy libstdc++.so.6.0.16 to /usr/lib64/,
and make a new symlink libstdc++.so.6 to libstdc++.so.6.0.16

Or grap libstdc++.so.6.0.16 from "libstdc++6_4.6.2-7_amd64.deb"
http://ftp.de.debian.org/debian/pool....2-7_amd64.deb
The package can be unpacked with 'ar -x <package> && tar xvf data.tar.gz'.

BIS?
flickflack ist offline   Mit Zitat antworten
Alt 14.03.2013, 18:43   #24 (permalink)
Newbie
 
Registriert seit: 01.03.2013
Ort: Bayern
Alter: 42
Beiträge: 26
Standard

Sorry Leute aber des kann doch net sein das mir keiner helfen kann.
Gibt doch soviel Arma 2 Server.
Da muß doch einer dabeio sein der mir damit helfen kann.

Also nochmal...
Ich versuche auf meinem Root Arma 2 zum laufen zu bekommen.
Hier mal der aktuelle Log Einntrag:

Code:
WATCHDOG (20073): [Do 14. Mär 16:36:25 CET 2013] Starting server (port 2314)...
/opt/arma2/server: /usr/lib32/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/arma2/server)
WATCHDOG (20073): [Do 14. Mär 16:36:25 CET 2013] Server died, waiting to restart...
Hier mal meine GLIBC Versionen:

Code:
 strings /usr/lib/libstdc++.so.6 | grep GLIBC
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13
GLIBC_2.2.5
GLIBC_2.3
GLIBC_2.3.2
GLIBCXX_FORCE_NEW
GLIBCXX_DEBUG_MESSAGE_LENGTH
und hier mal paar Infos zum Server:

Code:
 gcc -v
Using built-in specs.
Target: x86_64-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Debian 4.4.5-8' --with-bugurl=file:///usr/share/doc/gcc-4.4/README.Bugs --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.4 --enable-shared --enable-multiarch --enable-linker-build-id --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.4 --libdir=/usr/lib --enable-nls --enable-clocale=gnu --enable-libstdcxx-debug --enable-objc-gc --with-arch-32=i586 --with-tune=generic --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu
Thread model: posix
gcc version 4.4.5 (Debian 4.4.5-8)
So, jetzt bitte eine brauchbare Lösung

Vielen Dank schonmal...
Butterzeugs ist offline   Mit Zitat antworten
Alt 08.08.2014, 13:24   #25 (permalink)
Newbie
 
Registriert seit: 08.08.2014
Beiträge: 1
Standard

Moinsen

Bitte entschuldige und bitte sei mir nicht böse ABER lesen sollte man können. Nich einfach überfliegen oder grobe Wörter die angezeigt werden aufschnappen.

Deine Fehlermeldung #1 sagt folgendes aus:

Code:
/opt/arma2/server: /usr/lib32/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/arma2/server)
hier gilt es, herauszufinden was wirklich wichtig ist - und das geht so:

- Pfade kann man erst einmal ignorieren
- "required by" Aussagen zunächst erst einmal auch ignorieren
- nun haben wir nur noch "GLIBCXX_3.4.15 not found"

Was du nun zum Vorteil schon getan hast, ist, dass du dir deine Versionen der "GLIBCXX" ausgeben hast lassen.

Genau hier sollte man wieder lesen - und zwar richtig!

Du schreibst, dass du folgende Versionen zur Verfügung hast:

Code:
[...]
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13
[...]
Wo zum Teufel sind denn die Versionen

Code:
GLIBCXX_3.4.14 und
GLIBCXX_3.4.15
?

Somit wirft der Arma-Server selbstverständlich die Folgefehlermeldung (welches eigentlich keine Fehlermeldung darstellt):

Code:
WATCHDOG (20073): [Do 14. März 16:36:25 CET 2013] Server died, waiting to restart...
Diese besagt einfach nur, dass die Ausführung des Servers nicht getätigt werden konnte, weil irgendwas noch nicht richtig konfiguriert wurde.
Er möchte neustarten kann es meist aber nicht.



Nach dem ich das nun alles erklärt habe, kommen wir endlich zur Lösung:

Schaue dir mal folgende Links an, dort kannst du die benötigten Softwarebestandteile nachinstallieren und den Server mit dem oben vonflickflackangegebenen Script problemlos starten.

Linux 1.62.95577 alpha - Page 7 (Originalthread von flickflack genannt)

Debian User Forums &bull; View topic - How do i install GLIBCXX_3.4.15 on Debian 6 ? (deine fehlende GLIBCXX_3.4.15 installieren)

c++ - How to fix: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found - Stack Overflow (hier ähnlich wie obiger Link)


Ich hoffe ich konnte helfen
Wie gesagt nicht böse nehmen, ist immerhin eine starke Hilfe, nun have fun xD
silez ist offline   Mit Zitat antworten
Alt 08.08.2014, 15:34   #26 (permalink)
10 Jahre hx3
500 Beiträge1000 Beiträge
 
Benutzerbild von Buliwyf
 
Registriert seit: 11.03.2005
Ort: HH
Alter: 48
Beiträge: 1.930
Standard

Wenn er nach 5 Monaten das immer noch nicht im Griff hat, dann sollte er besser ganz die Finger davon lassen..
__________________
Buliwyf ist offline   Mit Zitat antworten
Antwort


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
dedi. Server ArmA II Steam und ohne Steam St3ve Technische Fragen & Probleme 5 03.04.2012 16:42
Patch 1.60! Xeno Community 69 11.01.2012 13:41
1.60 rc Dieter66 Community 47 22.12.2011 16:49
Arma 2 Server Problem S@ndviper Multiplayer 14 15.11.2010 19:45
Biete ArmA 2 / AO Server + TS3 luemmel Die Litfaßsäule 2 03.07.2010 19:30


Kontakt - HX3.de - Archiv - Nach oben

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias



SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117