HX3 Foren

HX3 Foren (https://hx3.de/)
-   Mods & Addons (https://hx3.de/mods-addons-165/)
-   -   How To: Addons einbinden (https://hx3.de/mods-addons-165/how-addons-einbinden-17297/)

Iceman 06.07.2009 12:26

How To: Addons einbinden
 
Da die Frage (auch von mir) nun mehrmals in kurzer Zeit aufgetaucht ist - da wohl einige neu dabei sind und sich die Sache nicht schon seit OFP angeeignet haben - stelle ich hier ein kurzes How-To zur Verfügung, welches hoffentlich alle Fragen diesbezüglich beantwortet. Evt. kann man das sogar oben anhefte, zumindest für den Anfang, bis es jeder kapiert hat :)

  1. Als erstes überprüft ihr, in welcher Form das Addon vorhanden ist. Entweder es enthält viele einzelne Files (*.pbo, *.bisign,...) oder die Files sind in einem Ordner "Addons", welcher wiederum in einem Ordner "@Name" ist. Falls dem so ist, fahrt ihr bei Punkt 5 fort.
  2. Falls die Files noch nicht in entsprechenden Ordnern sind, erstellt ihr (vorerst egal wo) einen Ordner mit "@Name" wobei "Name" am besten eine Bezeichnung für's Addon ist, damit ihr die Übersicht behält.
  3. In dem oben erstellten Ordner, erstellt ihr wiederum einen Ordner mit dem Namen "Addons" (zwingend!).
  4. Die Files des Addons kopiert ihr nun in den erstellten Ordner "Addons"
  5. Als nächstes verschiebt ihr den Ordner mit dem "@" im Namen in den Hauptordner von ArmA2. Das sieht dann zum Beispiel so aus: http://s6.directupload.net/images/09...p/54257l3n.png
  6. Zum Schluss erstellt ihr eine Verknüpfung oder fügt eurer bereits erstellen Verknüpfung folgenden Parameter unter "Ziel:" nach (z.B.) "C:\ArmA2\arma2.exe" hinzu: -mod=@Name
  7. Fertig! ArmA2 muss natürlich über die Verknüpfung gestartet werden, damit das Addon geladen wird.
  8. Falls ihr mehrere Addons in verschiedenen @-Ordnern habt, wird das Ganze mit einem ";" unterteilt (vgl. folgenden Screenshot) :
http://s8.directupload.net/images/09...p/jr579ss8.png


Hoffe das klärt nun die meisten oder sogar alle Fragen :)

Blackfly 06.07.2009 14:40

Danke für die Mühe :-)

burns 06.07.2009 15:06

*pin* *prost*

CrysoN 06.07.2009 16:23

Hey super, sowas schon lange gesucht, thx.:daumen:

Conveen 06.07.2009 17:15

Danke und Key bleibt auch in dem Addons Ordner? Ich habe die immer in den Key Ordner reinkopiert. Allerdings kann ich kaum ein Server joinen weil der Key falsch sein soll.

Conveen 06.07.2009 17:35

"C:\Program Files\Bohemia Interactive\ArmA 2\arma2.exe" -mod=@vopsound_2.0 -nosplash -world=empty -cpucount=2 -mod=@HeliSounds

so ist es jetzt bei mir.

So der Ordner:

C:\Program Files\Bohemia Interactive\ArmA 2\@HeliSounds\Addons

In Addons sind die Helosoundfiles drinne.

brombeerwilly 06.07.2009 18:19

Ersetz es damit:
C:\Program Files\Bohemia Interactive\ArmA 2\arma2.exe" -mod=@vopsound_2.0;@HeliSounds -nosplash -world=empty -cpucount=2

Hiramas 07.07.2009 16:06

Grüße euch.

Ich habe das permanente Problem das mein ArmA keinen Modordner wie auch immer haben will.
Die Verknüpfung ist richtig, alles ist am richtigen Ort, aber nix geht.
Ich muss die Dateien direkt in den Addons Ordner packen damit ich die Mods aktiviert habe.

Warum?
Ich hab bisher keine Lösung finden können.

Iceman 07.07.2009 16:10

Dazu braucht man aber schon etwas mehr Infos...was geht nicht? Stürzt es ab? Startet es nicht? Und kannst du mal ein Screenshot vom Verzeichnis des Addons (nicht des "Haupt"-Addonordners) einfügen, inklusive Adresse (C:\...) ?

+ Screenshot der Eigenschaften der Verknüpfung (im Prinzip 2 Screenshots wie von mir gepostet) - das würde die Sache vorerst vereinfachen.

Hiramas 07.07.2009 16:17

Das spiel startet einfach ohne die Mods.
Alle anderen Befehle wie -nosplash gehen.

Ich weiß, das die korrekte Ordnerstruktur vorhanden ist (ArmA 2/@ModName/Addons)
Ich weiß das die Verknüpfung korrekt ist ( -mod=@ModName)

Iceman 07.07.2009 16:27

Dann kann ich auch nicht helfen, wenn alles korrekt ist ;)

brombeerwilly 07.07.2009 18:26

screenshots

Hiramas 07.07.2009 19:28

http://pickhost.eu/images/0002/2170/desktop.jpg

Hier n Screenshot mit dem "Ziel" und der Ordnerstruktur.
Hoffe das hilft.

CrysoN 07.07.2009 19:42

Ich würd mal sagen, da fehlt ein "Addons" Ordner, nach @VopSound_2.0, wo dann diese Daten reingehören...

Hiramas 07.07.2009 19:48

wahr, ist aber nicht das problem.
Das hab ich nur grade beim machen des screenshots verhaun.
Denkt euch den Addonordner einfach dazwischen.
Hab andere Ordner die korrekt gebaut sind.

wolang 07.07.2009 19:54

Probiert mal den Arma Launcher aus damit sollte es eigentlich klappen......


http://hx3.de/community-161/arma-ii-launcher-17110/

Hiramas 07.07.2009 20:00

super, danke.
Problem gelöst

renner1982 09.07.2009 13:01

Hallo!
Wo kommen die Keys rein?
Key Ordner von Arma2 oder auch in die Mod Ordner?
Ich hab sie bis jetzt alle in den Key Ordner gepackt!

Grüsse

burns 09.07.2009 13:09

.bisign = arma2\@mod123\addons
.bikey = arma2\Keys (nur für Server)

renner1982 09.07.2009 15:04

danke!


Alle Zeitangaben in WEZ +1. Es ist jetzt 08:36 Uhr.

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias


SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117