HX3 Foren

HX3 Foren (https://hx3.de/)
-   Mods & Addons (https://hx3.de/mods-addons-165/)
-   -   ACE2 MOD - Der Hilfe/FAQ Thread (https://hx3.de/mods-addons-165/ace2-mod-hilfe-faq-thread-18290/)

AntraxGF 11.12.2009 10:40

ACE2 MOD - Der Hilfe/FAQ Thread
 
Probleme mit der Installation vom neuen ACE2 Addon?

Ich hoffe hier kann Abhilfe geschafft werden.

Zunächst mal der Downloadlink des Updaters, der ACE2 dann auf eure Platte patcht. (z.Z. ca 1,3 GB)
http://dev-heaven.net/projects/list_fil ... ma-updater

Der Updater selbst hat 16 MB.

-Runterladen
-Installieren

Der SIX-Updater muss als Admin (in Windows) ausgeführt werden sonst klappts nicht!

INFO: Es schadet nicht den @CBA Ordner vor dem patch zu sichern, da ACE diesen updated und ggf. Keys hineinkopiert die auf anderen Servern nicht gestattet sind.

Nun gibts 2 Möglichkeiten den Updater "vorzubereiten".
Der erste ist der manuelle der hier: A.C.E. Advanced Combat Environment - Public Beta! - Bohemia Interactive Forums in 2 Videos erklärt wird.
Die zweite Möglichkeit ist, diese Datei: http://www.germany-fun.net/xm/six-updater.7z zu saugen und einfach in euren SiX-Updater Hauptordner zu kopieren, den Updater zu starten, option 2 wählen, Enter drücken und patchen lassen.

Danach geht ihr in euren Arma2 Ordner und öffnet die C:/Bohemia Interactive/Arma2/userconfig/Ace/ace_clientside_config.txt Da tragt ihr unter "class Identity" NICHT dem ersten das ist nur das Beispiel euren Namen ein. Also John Doe in exakt euren Ingamenamen ändern. Der Squad.xml Zusatz gehört NICHT zu eurem Ingamenamen.


Bei Fragen und Problemen postet hier einfach euer Anliegen rein.

FAQ:
1.Wo sind die Ace Ordner nach dem Patch?
-Die wurden automatisch in das Arma Hauptverzeichnis kopiert wo auch die anderen Addons (so vorhanden) rumflattern. Der Updater fügt die Ordner @ACE @ACEX @CBA hinzu oder patcht diese automatisch wenn sie schon da sind.

2.Was patcht der Six-Updater eigentlich?
-Der SiX-Updater patcht automatisch die neuste beta, den @CBA,@ACE und @ACEX Ordner. Das heißt wenn eine Ace Version anliegt einfach Updater starten und wie beim ersten mal 2 und Enter drücken. Alles wird automatisch auf neusten Stand gepatcht.

3.Wie starte ich mit ACE?
-Der Updater erstellt automatisch 2 Verknüpfungen im Arma Hauptverzeichnis die man ausführen kann. Oder man nimmt das beliebte Yoma Addontool und fügt es ein.

4.Wo Finde ich die ACE2 Keysettings?
-Hier: Keybindings for ACE2 - Bohemia Interactive Community

5.Der sagt dass irgendwelche Dateien inkompatibel sind zB im CBA Ordner
-Löscht den entsprechenden Ordner und patcht erneut.

6.Beim starten der ACE Verknüpfung mit beta bekomme ich "Error compiling pixel shader PSSSSMSpecular Alpa:1"
-Siehe hier http://community.bistudio.com/wiki/ArmA ... xel_shader

7.Ich bekomme die Fehlermeldung "This program seems to be already running............blablabla"
-Mach das was der Updater dir sagt, nämlich die sixupdater.pid im Hauptverzeichnis(vom Updater) löschen und neu patchen. Wenn die Datei nicht da ist, vergewissere dich, dass du den Updater auch wirklich im Admin Modus ausführst (Also unter Windoof als Admin angemeldet sein).

8.Kann man diese rsync Ordner getrost löschen?(aus Platzmangel evtl.)
-Unter keinen Umständen das nimmt dem Updater die Grundlage. Da drin sind die Dateien die der Updater mit den ACE Dateien abgleicht damit er weiß was er patchen muss!

9.Ich habe ein Problem das nicht im FAQ gelistet ist, komme nicht weiter und kein Schwein weiß eine Lösung. Was nun?
-Die letzte Instanz der Problemlösung ist immer das Vorhandene komplett zu löschen also den @CBA @ACE @ACEX Ordner raus. Sauge dir die neuste Updaterversion, kopiere die .yml Datei wieder in den Hauptordner des Updaters und patche (Ace wird dann komplett vom Server gesaugt da es ja nichtmehr da ist 1,x GB).

10. Ich joine auf dem Server und es kommt ein Fenster mit einem "PLING" das sagt die Versionen stimmen nicht überein. Kann so nicht spielen!
-ACE nötigt und dazu up to Date zu sein (und das ist auch gut so) schau dir das Fenster an. Wenn die Clientversion (das bist du) geringer ist als die Serverversion beende das Spiel und patche mit dem UPdater auf den neusten Stand. Wenn du eine neuere Version hast als der Server auf dem du spielen willst, musst du warten bis der Server von den Betreibern auf den neusten Stand gepatcht wurde oder suchst dir einen der Up-to-Date ist.

...
Bereits ein Paar individuelle Hilfestellungen zum Thread findet ihr unter www.germany-fun.net

Mfg AntraX

Supply2811 11.12.2009 14:04

Erstmal Danke für die Anleitung. Hat alles gut funktioniert. Nur ein Problem habe ich noch. Ich kann keine Gasmaske oder Brillen...etc. aufsetzen.

Ich habe die config von ACE so verändert das nun mein Name und das ganze Zeug dransteht...

so sieht es in ACE aus:

class Identity
{
face="Default";
glasses="None";
speaker="Male05";
squad="http://www.elektroman.net/jgbtl533/SquadXML/squad.xml";
pitch=0.98113644;
name = "Supply2811";
};

und so in Arma Normal:

class Identity
{
face="Default";
glasses="None";
speaker="Male05";
squad="http://www.elektroman.net/jgbtl533/SquadXML/squad.xml";
pitch=0.98113644;
};

Ich weiß echt nicht weiter :( Gibt es da Feinheiten die man beachten muß?

Biba92 11.12.2009 14:14

Stimmt soweit.
Hast du vielleicht nur das Example verändert ?
Zum Vergleich:
class Identity
{
face="Bobby P";
glasses="None";
speaker="Male01";
squad="http://newageguerilla.kilu.de/squad/squad.xml";
pitch=.98104227;
name = "Biba92";
};

AntraxGF 11.12.2009 14:35

Nochmal ganz pauschal:

/*//////////////////////////////////////////////
CONFIG SETTING FOR : ACE 2 MOD - Changeable glasses ingame
--------------------
FEATURES: Lets you choose different glasses
---------
TO ENABLE: Please ADD your Player Profile here + Your name
----------
EXAMPLE:
--------
class Identity
{
face="Default";
glasses="None";
speaker="Male01";
squad="http://www.squad.org/tag/squad2.xml";
pitch=1.0190428;
name = "John Doe";
<<---Nicht ändern ist nur das Beispiel!
};


//////////////////////////////////////////////*/
class Identity
{
face="Default";
glasses="None";
speaker="Male01";
squad="http://www.squad.org/tag/squad2.xml";
pitch=1.0190428;
name = "AntraX"; <<---Hier den Namen ändern

Supply2811 11.12.2009 15:13

Ich hab es jetzt nochmal probiert...Hab auch die richtigen Zeilen editiert aber es geht einfach nicht :( Ich hab keine Ahnung warum....

tekk1608 11.12.2009 15:41

Zitat:

Zitat von AntraxGF (Beitrag 283796)
Die zweite Möglichkeit ist, diese Datei: http://www.germany-fun.net/xm/six-updater.7z zu saugen und einfach in euren SiX-Updater Hauptordner zu kopieren, den Updater zu starten, option 2 wählen, Enter drücken und patchen lassen.

hier sollte man hinzufügen, das man NICHT die .7z kopieren muss, sondern den Inhalt.
Ansonsten super Anleitung.

tekk1608 11.12.2009 15:53

Zitat:

Zitat von AntraxGF (Beitrag 283796)
Danach geht ihr in euren Arma2 Ordner und öffnet die C:/Bohemia Interactive/Arma2/userconfig/Ace/ace_clientside_config.txt Da tragt ihr unter "class Identity" NICHT dem ersten das ist nur das Beispiel euren Namen ein. Also John Doe in exakt euren Ingamenamen ändern. Der Squad.xml Zusatz gehört NICHT zu eurem Ingamenamen.

Hier sollte man erwähnen, das der Order nicht unbeding direkt unter c:\ liegt, sondern dort wo man ArmA2 Installiert hat UND bei sind das keine txt sondern hpp dateien.

AntraxGF 11.12.2009 16:00

Vielen Dank fürs klugscheißen Tekk :D

Nein im ernst auch wenn ich es schon sehr dummihaft geschrieben hab erwarte ich doch einen Funken Eigeninitiative zu erkennen dass es um den Inhalt der 7z und dass C:/bla variieren kann ^^

Kanns nichtmehr editieren, also wer vom Team Lust hat...

Zu dem warum es den Thread hier gibt:

@Supply du hast auch sicher die config im ACE Ordner editiert? Also blabla/Arma 2/userconfig/ACE/ace_clientside_config?

Und du musst das Zeug auch im Backpack haben dat is klar ne? =)

Supply2811 11.12.2009 16:26

jo also ich hab es im Inventar...wo das Gps und so auch ist...aber ich werde es nochmal testen...ist bestimmt wieder was ganz einfaches was mich bekloppt macht *herrgotsnah*


UPDATE:

ES HAT FUNKTIONIERT :) Ich hab noch zusätzlich die config im normalen config Ordner im Arma2 Installationsverzeichniss ändern müssen und nicht nur die in @ACE

BW DDH 11.12.2009 22:12

äähhhm eine kleine Frage:

AnthraxGF, diu hast im ersten Thread geschrieben:
...
3.Wie starte ich mit ACE?

-Der Updater erstellt automatisch 2 Verknüpfungen im Arma Hauptverzeichnis die man ausführen kann. Oder man nimmt das beliebte Yoma Addontool und fügt es ein.
...

Meine über Six updater erstellte Verknüpfung "play Arma with beta... hat folgenden Inhalt
I:\Arma2\arma2.exe -noSplash -noFilePatching -mod=beta;@CBA;@ACE;@ACEX

Damit würde aber leider die Beta.exe nicht angesprochen, sondern nur die normale Arma2exe, da ja der Pfad I:\Arma2\beta\arma2.exe...heissen müsste.

=> Dann erscheint auch der "...Pixel...Fehler.
Könnt ihr das mal checken?
vielen Dank und viele Grüsse an alle Ace(r)

AntraxGF 12.12.2009 00:17

1. Ich bin kein ACE(r) ^^
2. Da sind 2 Verknüpfungen einer mit und einer ohne beta.

Es ist bekannt dass die mit Beta n fehler hat darum steht Frage und Antwort bereits im FAQ (Frage 7) mit Hilfelink.

Gruß AntraX

kuki 12.12.2009 01:45

bei mir gehn die CSW nicht richtig.Ist es weil ich keine rechte Windows Waste hab? Ich hab da so a komische Taste:zahn:.ich kann die Waffe schon aufstellen und so aber nicht Aufmunitioniern.

Gruß Kuki

AntraxGF 12.12.2009 12:32

Geh in dein ArmA Hauptverzeichnis /userconfig/Ace/ace_keys

Da kannst du deine Tasten selbst belegen. Einfach mit Texteditor öffnen. Wenn die Standarttaste nich geht nimm ne andere. Die Nummern der Tasten findest du ganz unten.

das Interaction menu ist dieses hier:

class ace_sys_interaction
{
class Interaction_Menu
{
key = 199; // pos1 <<--Taste
shift = 0; <<--0=keinShift +Taste| 1=Mit Shift
};

INNOCENT&CLUELESS 12.12.2009 13:41

Ich habe schon ACE, ACEX und CBA runtergeladen, aber nach durchlesen der "Installationsanleitung" entschieden es sein zu lassen. Ist doch alles ein Witz oder?

Desert 12.12.2009 13:58

Der Updater wird nur für die PublicBeta Phase benutzt da es auch mehrfache Updates pro Tag geben kann. Jedesmal das komplette Paket oder die komplette Datei hochzuladen und dem User zu erklären wohin er was wie zu entpacken hat ist sinnfrei. Der Updater hat seinen Sinn und ist die einzige vernünftige Möglichkeit da z.B. auch bei Änderungen an einer Datei nur die Änderungen geladen werden und nicht die komplette Datei, so werden aus mehreren (u.U. hunderten) MB wenige KB.

Wenn du die Public Beta nicht testen möchtest warte bis zum Release der Final.


P.S.: So schwer ist die Anleitung nun wirklich nicht. Versuch doch mal diese Anleitung, Schritt 2 kann großzügig übersprungen werden: http://dev-heaven.net/wiki/six-arma-updater/Quickstart Die funktioniert problemlos. Den Updater selbst findest du hier: http://dev-heaven.net/projects/list_...x-arma-updater

Goodboy 12.12.2009 14:03

Hallo!
Habe da ein kleines Problem. Habe gerade mittels Six-Updater auf Version 0.1.186 geupdated, also 2 gewählt und ihn mal machen lassen. In der zweiten shell bekomme ich eine Meldung die ich nicht verstehe.

Processing:
=beta
Warning: Folder already exist but seems incompatible. No installing
=@CBA
Warning: Folder already exist but seems incompatible. No installing

Ich war der Meinung der Six-Updater updated den Beta-Patch und die CBA!?
Hat vielleicht jemand eine Idee was ich falsch gemacht haben könnte?

Gruß Goodboy

Desert 12.12.2009 14:05

Ja aber er updatet die entsprechenden Mods wohl nicht wenn du die vorher manuell schon angelegt hattest oder der Mod schon vorher installiert worden oder installiert gewesen ist. Du kannst die beiden Ordner ja mal aus dem ArmA2 Verzeichnis verschieben und dann den Updater nochmal durchlaufen lassen.

AntraxGF 12.12.2009 14:42

Zitat:

Zitat von INNOCENT&CLUELESS (Beitrag 283960)
Ich habe schon ACE, ACEX und CBA runtergeladen, aber nach durchlesen der "Installationsanleitung" entschieden es sein zu lassen. Ist doch alles ein Witz oder?

Dann hast wohl nicht aufmerksam gelesen denn das ist sowas von simpel... aber naja.

Desert hat recht.

Der Updater patcht zwar beta und CBA aber bei bereits VORinstallierter beta und CBA patcht er sie eben nicht da inkompatibel.

Lösung: Die ORDNER CBA und beta löschen (oder aus dem Armaverzeichnis verschieben), Updater anwerfen und fertig.

Eine vorhandene beta wird NICHT gepatcht. Wenn ihr wollt dass der Updater die beta mitpatcht, einmal Ordner löschen. Der wird vom Updater neu erstellt.

Reno 12.12.2009 15:00

@Inno

War ein weise Entscheidung.:daumen:
So negativ, wie du an die Sache ran gehst, kann das auch nix werden.

Somit ersparst du dir wirklich viele Nerven, nebenbei unsre auch.

Die Finale Version ist ja dann wieder ein ganz normaler Mod und sollte problemlos zu installieren sein.

Goodboy 12.12.2009 15:03

@Desert

du hattest natürlich recht.Super, Dankeschön! Hat jetzt auch die aktuelle Beta 1.04.61062. Allerdings ist jetzt die Modreihenfolge durcheinander. Startet nun wie folgt, -mod=CBA;@ACE;@ACEX;beta.
Sollte doch eigentlich so aussehen, -mod=beta;@ACE;@ACEX;@CBA. Oder irre ich?


Alle Zeitangaben in WEZ +1. Es ist jetzt 02:41 Uhr.

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias


SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117