Armed-Assault.de Twitter
Antwort
 
Themen-Optionen Ansicht
Alt 03.09.2008, 02:37   #1 (permalink)
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von Cyborg11
 
Registriert seit: 26.03.2008
Beiträge: 2.822
Standard Problem beim Addon erstellen

Ich hab ein Problem beim Addon erstellen. Durch das Problem lässt sich ArmA mit diesem Addon nicht merh starten.

Fehlermeldung ist folgende:
Zitat:

Size: 'requiredAddons/' not an array

Was bedeutet das?

Die config schaut so aus (Soll ein Replacementpack der MP5 werden):
Code:
class CfgPatches {

	class MP5_Replacementpack {
		Units = {};
		weapons = {};
		requiredVersion = 1.000000;
		requiredAddons = {"CAWeapons", "CAweapons3", "MP5Special", "MP5SpecialSD"};
	};
};
Wo ist da mein Fehler?

Geändert von Cyborg11 (03.09.2008 um 03:17 Uhr).
Cyborg11 ist offline   Mit Zitat antworten
Alt 03.09.2008, 02:43   #2 (permalink)
10 Jahre hx3
5000 Beiträge10.000 Beiträge15.000 Beiträge
 
Benutzerbild von burns
 
Registriert seit: 13.04.2003
Ort: Monerica
Alter: 41
Beiträge: 32.948
Standard

Versuchs mal so:

Code:
requiredAddons[] = {"CAWeapons", "CAweapons3", "MP5Special", "MP5SpecialSD"};
__________________

burns ist offline   Mit Zitat antworten
Alt 03.09.2008, 02:58   #3 (permalink)
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von Cyborg11
 
Registriert seit: 26.03.2008
Beiträge: 2.822
Standard

Danke, das hat aber nur diese Fehlermeldung ausgemerzt

Hab jetzt aber bei den anderen Befehlen auch noch [] hingesetzt, wo ein Array hinkommen soll und nun funktioniert es =) Jetzt hab ich die Tactical MPs anstatt den lahmen ArmAWaffen

Neues Problem: Wenn ich bei requiredAddons das "MP5SpecialSD" drinnen lasse, dann meldet er mir immer, dass mein Replacementpack das Addon benötigt. Aber ich habe es doch! Und richtig geschrieben ist es auch. Hast du da eine Idee?

Geändert von Cyborg11 (03.09.2008 um 03:01 Uhr).
Cyborg11 ist offline   Mit Zitat antworten
Alt 03.09.2008, 03:02   #4 (permalink)
Trucker Maik 10 Jahre hx3
5000 Beiträge
 
Benutzerbild von Pelzgurké
 
Registriert seit: 06.01.2006
Ort: Deutschland
Alter: 38
Beiträge: 6.568
Standard

*will auch haben*
__________________
Zitat von Jägermeischter: Alkoholspiegel steigt, anzahl der im kasten befindlichen bier sinkt

<- hat jetzt auch Windows 7!!!
<- hat sich jetzt endlich ArmA3 gekooft



Pelzgurké ist offline   Mit Zitat antworten
Alt 03.09.2008, 03:05   #5 (permalink)
10 Jahre hx3
5000 Beiträge10.000 Beiträge15.000 Beiträge
 
Benutzerbild von burns
 
Registriert seit: 13.04.2003
Ort: Monerica
Alter: 41
Beiträge: 32.948
Standard

Zitat von Cyborg11 Beitrag anzeigen

Hab jetzt aber bei den anderen Befehlen auch noch [] hingesetzt, wo ein Array hinkommen soll und nun funktioniert es =)





Zitat von Cyborg11 Beitrag anzeigen

Neues Problem: Wenn ich bei requiredAddons das "MP5SpecialSD" drinnen lasse, dann meldet er mir immer, dass mein Replacementpack das Addon benötigt. Aber ich habe es doch! Und richtig geschrieben ist es auch. Hast du da eine Idee?

Nimms mal aus den requ. Addons raus, ist eh nur schnickschnack.
__________________

burns ist offline   Mit Zitat antworten
Alt 03.09.2008, 03:07   #6 (permalink)
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von Cyborg11
 
Registriert seit: 26.03.2008
Beiträge: 2.822
Standard

Zitat von Pelzgurke Beitrag anzeigen

*will auch haben*

Aye Aye! Config klappt atm, bis auf das Ironsight Muss dem noch ein Test unterziehen ^^

Die benötigten MP5s musst du hier saugen Und hier findest du einen Screen, der MP5


EDIT: @Burns: Hab es gerade rausgenommen. Funktioniert jetzt wieder einwandfrei =)
Cyborg11 ist offline   Mit Zitat antworten
Alt 03.09.2008, 03:10   #7 (permalink)
Trucker Maik 10 Jahre hx3
5000 Beiträge
 
Benutzerbild von Pelzgurké
 
Registriert seit: 06.01.2006
Ort: Deutschland
Alter: 38
Beiträge: 6.568
Standard

gibbet sowas auch original?
__________________
Zitat von Jägermeischter: Alkoholspiegel steigt, anzahl der im kasten befindlichen bier sinkt

<- hat jetzt auch Windows 7!!!
<- hat sich jetzt endlich ArmA3 gekooft



Pelzgurké ist offline   Mit Zitat antworten
Alt 03.09.2008, 03:12   #8 (permalink)
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von Cyborg11
 
Registriert seit: 26.03.2008
Beiträge: 2.822
Standard

Zitat von Pelzgurke Beitrag anzeigen

gibbet sowas auch original?

Was original? ^^ Die MP5? Joa, nur ohne Aimpoint und die schaut nicth so gut aus :P

Also ich hätte jetzt das Replacementaddon fertig. Wer wills zuerst haben? =D
Cyborg11 ist offline   Mit Zitat antworten
Alt 03.09.2008, 03:17   #9 (permalink)
Trucker Maik 10 Jahre hx3
5000 Beiträge
 
Benutzerbild von Pelzgurké
 
Registriert seit: 06.01.2006
Ort: Deutschland
Alter: 38
Beiträge: 6.568
Standard

Zitat von Cyborg11 Beitrag anzeigen

nur ohne Aimpoint

na dann hat sich die sache
__________________
Zitat von Jägermeischter: Alkoholspiegel steigt, anzahl der im kasten befindlichen bier sinkt

<- hat jetzt auch Windows 7!!!
<- hat sich jetzt endlich ArmA3 gekooft



Pelzgurké ist offline   Mit Zitat antworten
Alt 03.09.2008, 03:19   #10 (permalink)
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von Cyborg11
 
Registriert seit: 26.03.2008
Beiträge: 2.822
Standard

Zitat von Pelzgurke Beitrag anzeigen

na dann hat sich die sache

Also willst es haben?


Ich hängs einfach mal an ...
Angehängte Dateien
Dateityp: rar MP5_Replacementpack.rar (1,2 KB, 53x aufgerufen)
Cyborg11 ist offline   Mit Zitat antworten
Alt 03.09.2008, 03:22   #11 (permalink)
Trucker Maik 10 Jahre hx3
5000 Beiträge
 
Benutzerbild von Pelzgurké
 
Registriert seit: 06.01.2006
Ort: Deutschland
Alter: 38
Beiträge: 6.568
Standard

Zitat von Cyborg11 Beitrag anzeigen

Also willst es haben?


Ich hängs einfach mal an ...


naja ich probs. mal aus mal kucken wie es is...
__________________
Zitat von Jägermeischter: Alkoholspiegel steigt, anzahl der im kasten befindlichen bier sinkt

<- hat jetzt auch Windows 7!!!
<- hat sich jetzt endlich ArmA3 gekooft



Pelzgurké ist offline   Mit Zitat antworten
Alt 03.09.2008, 03:23   #12 (permalink)
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von Cyborg11
 
Registriert seit: 26.03.2008
Beiträge: 2.822
Standard

Zitat von Pelzgurke Beitrag anzeigen

naja ich probs. mal aus mal kucken wie es is...

Wenn du noch Käfer oder weiteres finden solltest, dann bitte posten

Missbrauche dich als Betatester


Ne, sollte eigentlich schon alles funktionieren. Schaden is der gleiche wie bei den normalen MPs. Hab nur das Model und die Sounds ausgetauscht
Cyborg11 ist offline   Mit Zitat antworten
Alt 03.09.2008, 09:18   #13 (permalink)
500 Beiträge1000 Beiträge
 
Registriert seit: 12.06.2006
Beiträge: 1.252
Standard

Probier ma die Version Cyborg

Code:
class CfgPatches
{
	class MP5_Replacementpack
	{
		units[] = {};
		weapons[] = {};
		requiredVersion = 1.000000;
		requiredAddons[] = {"CAWeapons", "CAweapons3","mp5special","mp5special_sd"};
	};
};
class Mode_SemiAuto;
class Mode_FullAuto;
class CfgWeapons
{
	class Rifle;
	class MP5SD: Rifle
	{
		model = "\MP5SpecialSD\mp5special_sd.p3d";
		optics = 1;
		opticsZoomMin = 0.2;
		opticsZoomMax = 0.3;
		distanceZoomMax = 60;
		picture = "\MP5SpecialSD\Icons\W_HKM5_SD6_CA.paa";
		displayName = "H&K MP5 SD";
		modes[] = {"Single", "FullAuto"};
		class Single: Mode_SemiAuto
		{
			sound[] = {"\MP5SpecialSD\sounds\MP5_SD_Single", 0.01, 1};
		};
		class FullAuto: Mode_FullAuto
		{
			sound[] = {"\MP5SpecialSD\sounds\MP5_SD_Single", 0.01, 1};
		};
	};
	class MP5A5: MP5SD
	{
		opticsFlare = 1;
		shotFromTurret = 0;
		model = "\MP5Special\mp5special.p3d";
		displayName = "H&K MP5";
		picture = "\MP5Special\Icons\w_hkm5_a5_ca.paa";
		modes[] = {"Single", "FullAuto"};
		class Single: Mode_SemiAuto
		{
			sound[] = {"\MP5Special\sounds\MP5_Single", 0.01, 1};
		};
		class FullAuto: Mode_FullAuto
		{
			sound[] = {"\MP5Special\sounds\MP5_Single", 0.01, 1};
		};
	};
};
Kurze Info.
Man sollte im Replacement nur die Werte definieren, die man
überschreiben will UND die anders als in den BI Config sind.
.kju ist offline   Mit Zitat antworten
Alt 03.09.2008, 10:44   #14 (permalink)
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von Cyborg11
 
Registriert seit: 26.03.2008
Beiträge: 2.822
Standard

Zitat von WGL.Q Beitrag anzeigen

Probier ma die Version Cyborg

Kurze Info.
Man sollte im Replacement nur die Werte definieren, die man
überschreiben will UND die anders als in den BI Config sind.

Ok danke. Das hab ich mir irgendwie schon gedacht, war nur zu faul die "falschen" Werte rauszulöschen

Aber ist das eigentlich im Prinzip nicht egal?

PS: Werde noch einen Releasethread für mein Replacementpack erstellen ^^


EDIT: Ich hab ein neues Problem: Und zwar, ich hab den Burst/Salvenmodus wieder in die Config von WGL.Q eingefügt und hab jetzt das Problem, dass bei der normalen MP5A5 nur der Sound für ein Schuss beim Salvenmodus zu hören ist. Also ich schieß, dann höre ich nur ein Schuss, es kommen aber drei raus :o

Wo ist da mein Fehler? Bei der MP5SD klappt es ja auch!
Code:
	class MP5A5: MP5SD
	{
		opticsFlare = 1;
		shotFromTurret = 0;
		model = "\MP5Special\mp5special.p3d";
		displayName = "H&K MP5";
		picture = "\MP5Special\Icons\w_hkm5_a5_ca.paa";
		modes[] = {"Single", "Burst", "FullAuto"};

		class Single: Mode_SemiAuto
		{
			sound[] = {"\MP5Special\sounds\MP5_Single", 0.01, 1};
		};

		class Burst: Mode_Burst {
			sound[] = {"\MP5Special\sounds\MP5_Single", 0.01, 1};
		};

		class FullAuto: Mode_FullAuto
		{
			sound[] = {"\MP5Special\sounds\MP5_Single", 0.01, 1};
		};
	};

Geändert von Cyborg11 (03.09.2008 um 11:17 Uhr).
Cyborg11 ist offline   Mit Zitat antworten
Alt 03.09.2008, 20:18   #15 (permalink)
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von Cyborg11
 
Registriert seit: 26.03.2008
Beiträge: 2.822
Standard

Keiner eine Idee? =(
Cyborg11 ist offline   Mit Zitat antworten
Alt 04.09.2008, 07:45   #16 (permalink)
500 Beiträge1000 Beiträge
 
Registriert seit: 12.06.2006
Beiträge: 1.252
Standard

teste ma continous = 0; oder = 1;
.kju ist offline   Mit Zitat antworten
Alt 04.09.2008, 11:36   #17 (permalink)
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von Cyborg11
 
Registriert seit: 26.03.2008
Beiträge: 2.822
Standard

Und wo muss ich das hinschreiben?
Cyborg11 ist offline   Mit Zitat antworten
Alt 04.09.2008, 15:51   #18 (permalink)
500 Beiträge1000 Beiträge
 
Registriert seit: 09.01.2008
Beiträge: 1.596
Standard

Zitat von Cyborg11 Beitrag anzeigen

Und wo muss ich das hinschreiben?

Ich bin mir jetzt nicht so ganz sicher, aber ich denke WGL.Q meint das hier: soundCountinuous

Hast Du eigentlich schon mal in den BI-Sample configs geguckt, was da drin steht? In einigen Waffen-Konfigs sollte alles Nötige mit drin stehen.

mike
modEmMaik ist offline   Mit Zitat antworten
Alt 05.09.2008, 14:16   #19 (permalink)
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von Cyborg11
 
Registriert seit: 26.03.2008
Beiträge: 2.822
Standard

Naja .. irgendwie finde ich in den Waffenkonfig nichts. Denn eigentlich müsste es ja gehen, denn bei der MP5SD funzt es und bei den normalen ja auch. Und ich hab nur den Sound ausgetauscht :o
Cyborg11 ist offline   Mit Zitat antworten
Alt 23.09.2008, 17:03   #20 (permalink)
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von Cyborg11
 
Registriert seit: 26.03.2008
Beiträge: 2.822
Standard

So .... neues Problem Leute

Immer wenn ich mit meinem Granatwerfer schießen will, dann kommt die Granate nicht gerade aus dem Gewehr geschossen (also nach vorne), sondern nach links o.O Ist bei jeder M4 mit nem M203. Weiß jemand woran das liegt? Hier mal meine Config:

Code:
	/*extern*/ class Rifle;   

	class M4: Rifle {
		model = "\rh_m4\RH_M4.p3d";
	};

	class M4A1: M4 {
		model = "\SIX_Weap_models_HK\m\SIX_M416_rifle.p3d";
		picture = "\SIX_Weap_pics\p\HK416_rifle_CO.paa";
		displayname = "HK416";
	};

	class M4AIM: M4 {
		model = "\SIX_Weap_models_HK\m\SIX_M416_rifle_M68.p3d";
		picture = "\SIX_Weap_pics\p\HK416_carabine_M68Aimpoint_CO.paa";
		displayname = "HK416 Aimpoint";
	};

	class M4ACOG: M4 {
		model = "\SIX_Weap_models_HK\m\SIX_M416_rifle_ACOG4x.p3d";
		picture = "\SIX_Weap_pics\p\HK416_rifle_ACOG4x_CO.paa";
		displayname = "HK416 ACOG";
	};

	class M4GL: M4 {
		model = "\SIX_Weap_models_HK\m\SIX_M416_rifle_ACOG4x_203.p3d";
		picture = "\SIX_Weap_pics\p\HK416_rifle_ACOG4x_CO.paa";
		displayname = "HK416 ACOG M203";
	};

	class M4A1SD: M4AIM {
		model = "\SIX_Weap_models_HK\m\SIX_M416_Car_SD.p3d";
		picture = "\SIX_Weap_pics\p\HK416_carabine_CO.paa";
		displayname = "HK416 SD"
	};
Cyborg11 ist offline   Mit Zitat antworten
Antwort


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
[Problem] AlphaMap Texturen erstellen zeron[TEAMMotion] Mod und Addon Ecke 6 29.08.2006 17:45
Problem beim Eurofighter!! K4i Hilfe 4 23.06.2006 18:19
brauche hilfe beim addon machen TALLA2xlc Mod und Addon Ecke 6 20.11.2004 16:37
Kann beim setup eine DLL nicht erstellen? Hack-Panther Hilfe 8 10.03.2004 18:25


Kontakt - HX3.de - Archiv - Nach oben

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias



SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119