Armed-Assault.de Twitter


Mods & Addons Behind the Scenes

Antwort
 
Themen-Optionen Ansicht
Alt 01.07.2009, 18:16   #1 (permalink)
Newbie
 
Registriert seit: 01.07.2009
Beiträge: 2
Standard Kollisionsabfrage bei eigenen Modellen

Hallo,

ich habe gesehen, dass dieses Problem schon voriges jahr behandelt wurde - leider ohne Abschlussmeldung und der Link in dem alten Thread funkt auch nicht mehr...
Vielleicht kann mir trotzdem noch jemand weiterhelfen:

Ich habe gerade mit dem Erstellen von Addons angefangen und hänge seit 3 Tagen fest.
Habe in Cinema4D ein Modell erstellt (nichts animiertes, nur eben ein einfaches Objekt) und dieses dann über O2 in ein .p3d konvertiert.
Eigentlich hat alles bestens geklappt, auch das Texturieren und einbinden in das Editor-Auswahlmenü.
Das Problem, welches ich nicht lösen konnte ist, dass man ohne Weiteres durch das Objekt laufen und schießen kann. Wie kann ich das verhindern?


Geändert von quastl (01.07.2009 um 18:31 Uhr). Grund: Bild eingefügt
quastl ist offline   Mit Zitat antworten
Alt 01.07.2009, 19:25   #2 (permalink)
Newbie
 
Registriert seit: 28.08.2008
Beiträge: 45
Standard

Hast du auch ein Geometrie-Lod erstellt?
Dieses muss geschlossen sein, scharfe Kanten haben und aus componenten bestehen, denen du auch eine Masse geben musst.
Bei deinem Objekt reicht wohl ein einziger Quader...

Aber am besten schaust du dir die Sampleobjects von Bis mal an, da kannste sehn wie die das gemacht haben...

viel Erfolg
Beton ist offline   Mit Zitat antworten
Alt 01.07.2009, 23:05   #3 (permalink)
Newbie
 
Registriert seit: 01.07.2009
Beiträge: 2
Standard

Bingo! das war es! Danke!
quastl ist offline   Mit Zitat antworten
Antwort


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Gebannt von meinem eigenen Server? Fin Technische Fragen & Probleme 14 28.04.2009 08:10
Eigenen Server? Verbal Technische Fragen & Probleme 15 23.01.2008 20:46
Von eigenen Leuten beschossen werden SWAT Editing 7 30.09.2005 20:12


Kontakt - HX3.de - Archiv - Nach oben

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias



SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117