HX3 Foren

HX3 Foren (https://hx3.de/)
-   Editing & Scripting (https://hx3.de/editing-scripting-167/)
-   -   Sound beenden (https://hx3.de/editing-scripting-167/sound-beenden-19215/)

Anemia 05.07.2010 21:01

Sound beenden
 
Hi ,
ich mach es einfach mal kurz und knapp ...

ich habe einen Sound gestartet über einen Auslöser. Dieser ist für meinen Alarm, wenn der Spieler in einem bestimmten bereich gesichtet wurde. Über diesen werden dann auch verstärkungstruppen für den Feind angefordert.

Nun habe ich das Problem das dieser alarm nichtmehr aufhört, der sound läuft einfach weiter. Wie bekomme ich es hin das der Sound nach z.b. 60 sekwieder aufhört ?!

Ganze zeit mit alarmgeheule ist echt nervig. :komisch:

Pfandgiraffe 06.07.2010 00:13

playSound "alarm";
sleep 48;
12 fadeSound 0;
playSound "";
0 fadeSound 1;

Anemia 06.07.2010 07:35

Zitat:

Zitat von Psychobastard (Beitrag 320073)
playSound "alarm";
sleep 48;
12 fadeSound 0;
playSound "";
0 fadeSound 1;


Dankö ...

hatte gestern sowas ähnliches gelesen bei dem AMS Camscript tutorial .... da ging es allerdings um musik .... un in der wiki hab ich unter playsound nichts gefunden ... oder nicht richtig gelesen.

Werds heute abend mal testen ...

Anemia 07.07.2010 19:31

Zitat:

Zitat von Psychobastard (Beitrag 320073)
playSound "alarm";
sleep 48;
12 fadeSound 0;
playSound "";
0 fadeSound 1;

Fast gut , problem ist nur das der "Sound" oder uach die music wenn man es entsprechen ändert abruppt endet ... und nicht langsam leiser wird... was ja eigentlich passieren sollte.

EDIT:

Lösung:

playSound "alarm";
sleep 48;
12 fadeSound 0;
sleep 12;
// Oder halt so lange wie ihr das lied "ausblenden" wollt
playSound "";
0 fadeSound 1;

Pfandgiraffe 07.07.2010 19:39

versuch mal an der zeit vom fadeSound etwas zu drehen.


mach ma z.b. 20 fadeSound 0;

ich hab die erfahrung gemacht das wenn ich zu kurze zeiten wähle manchmal garnicht gefadert wird oder eben abrupt. oder erst fadesound, dann noch einen kurzen sleep und dann erst playsound "";




mfg




EDIT: ajo, ok!

Anemia 11.07.2010 14:08

Nochmal eine andere frage.... wo finde ich eine Class list der OA sounds .. suche bestimmt schon eine halbe std. in der wiki und anderen seite.

Jedesmal wenn das script ausgeführt wird sagt er "sound alarm not found "



Habs nun doch gefunden:

http://community.bistudio.com/wiki/A...es#Sound_Class


EDIT EDIT EDIT:

Verdammt auch mit den classnames gehts nicht .. was ist falsche ?!

Code:

hint "Alarm";
playSound "Sound_Alarm";
sleep 15;
48 fadeSound 0;
sleep 48;
playSound "";
0 fadeSound 1;

bekomme immer die fehlermeldung:
"sound xalarmx not found "

alarm ist variabel jeh nach soundnamen den ich ins script einfüge


Alle Zeitangaben in WEZ +1. Es ist jetzt 13:57 Uhr.

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias


SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117