HX3 Foren

HX3 Foren (https://hx3.de/)
-   Editing (https://hx3.de/editing-38/)
-   -   Script funktioniert nicht (https://hx3.de/editing-38/script-funktioniert-10867/)

Lonely 08.06.2005 14:49

Script funktioniert nicht
 
Bis jetzt steht das script...
Code:

tode=3

goto "loop1";

#loop1
if((getdammage u1)<0.8) then {goto "tot1"} else {goto "loop1"};

#tot1
u1 setdammage 0.95;
u1 switchmove "CombatDyingVer2";
u1 setcaptive true;
ID=u1 AddAction ["Respawn","goto "loop2""];

?tode<1 : goto "done"

#loop2
u1 setcaptive false;
u1 setdammage 0;
u1 switchmove "EffectCombatStand";
tode=tode -1;
goto "loop1"

#done
exit

eine selbstreproduktion der idee von jörgF. vielleicht liegts daran dass ich eigentlich in der schule c und nicht delphi lern warum ichs nicht gebacken bekomm.

PS: dass sich der spieler selbst wiederbeleben kann ist dabei beabsichtigt, der "Zusatz" dass das nur andere Spieler können wär ja nicht das problem.

u1 ist der soldat

lg

Kompost 08.06.2005 15:01

AW: Script funktioniert nicht
 
Bitte nächstes mal einen Aussagelkräfitegern Titel wählen, habs mal geändert... :)

Meiner ist zwar auch nicht so doll aber ich check garnich worum es geht :confused:

burns 08.06.2005 15:11

AW: Script funktioniert nicht
 
der vorige war doch auch ok, deiner ist wirklich nciht viel besser :zahn:

Lonely 08.06.2005 15:18

AW: Script funktioniert nicht
 
Grüsse, vielleicht kennt mich jemand ausm HX3 forum.

EDITIERT

Nunja, soweit bin ich bis jetzt gekommen
Code:

tode=3

goto "loop1";

#loop1
if((getdammage u1)<0.8) then {goto "tot1"} else {goto "loop1"};

#tot1
u1 setdammage 0.95;
u1 switchmove "CombatDyingVer2";
u1 setcaptive true;
?tode<1 : goto "done"
ID=u1 AddAction ["Respawn","respawn.sqs"];

#done
exit

respawn.sqs
Code:

u1 setcaptive false;
u1 setdammage 0;
u1 switchmove "EffectCombatStand";
tode=tode -1;
exit

- u1 ist der Soldat
- Dass u1 sich selber wiederbeleben kann ist absicht, wird später noch geändert aber wenn der scriptteil funktioniert dann ist der rest kein problem mehr.

kurzum: ich brauch hilfe (hab glaub zuviel c programmiert, delphi erscheint mir echt recht abstrus von der struktur her)

lg

burns 08.06.2005 15:38

AW: Script funktioniert nicht
 
Zitat:

Zitat von Lonely
Grüsse, vielleicht kennt mich jemand ausm HX3 forum.

ööm, dort bist du noch immer..
sind wir heute ein wenig verwirrt ? :confused: :zahn:

Lonely 08.06.2005 15:48

AW: Script funktioniert nicht
 
war der aktualisierte (kopierte) beitrag ausm mapfact forum... darum

T-X 09.06.2005 14:42

AW: Script funktioniert nicht
 
setdammge 0 funzt bei personen NICHT!
Was tot ist ist tot.
Also musst du wohl oder über dir eine brücke über die Description.ext suchen


Alle Zeitangaben in WEZ +1. Es ist jetzt 18:03 Uhr.

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias


SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118