Einzelnen Beitrag anzeigen
Alt 28.10.2015, 20:21   #22 (permalink)
Duke49th
10 Jahre hx3
5000 Beiträge
 
Benutzerbild von Duke49th
 
Registriert seit: 06.10.2006
Ort: Manila
Alter: 40
Beiträge: 8.108
Standard

Die Funktion des WYSIWYG Editor speichert nicht richtig zwischen. Der ist aufwendiger aufgebaut als der normale Editor. Das liegt an der PHP Version die der Server verwendet. Da die functions/classes anders sind. Siehe Link von Atomic: PHP: Unsupported Branches (Guter Link...muss ich mir speichern, falls bei uns mal ein upgrade ansteht^^)

Wenn ich unsere Seite auf PHP 5.5.x laufen lasse, dann bekomme ich auch einen haufen Script-Fehler vom Forum gemeldet, bei bestimmten Sachen.

Lösung bei uns wäre - Installationsroutine von vBulletin in einer bestimmten Art und Weise drüber laufen lassen, damit er die betreffenden Skripte neu initialisiert und schreibt.

Das Forum kann es prinzipiell handhaben.(denke ich) Ist aber bei der Installation auf die niedrigere PHP Funktionen "geeicht". Es werden dann Funktionen/Klassen genutzt die es so nur in dieser PHP Version gibt. Da die Funktionen/Klassen aber teilweise anders sind, in höheren PHP Versionen, spinnt es hier und da herum. Sehr Laienhaft gesprochen (Bin ja selber kein progger/webadmin)

Man sieht die Fehler nur nicht, weil sie unterdrückt werden. Sonst gäbe es oben im Browser die passenden Fehlermeldungen.

Theoretisch fixt Atomic das händisch oder lässt die Install drüber laufen (sofern das für vBulletin 3.x vorgesehen ist..für die 4.x ist das laut Support Forum so zu lösen...das habe ich mich aber nicht getraut...war auch nicht nötig da alles bei uns mit PHP5.4 klar kommt).


Edit: Einfach den WYSIWYG Editor nicht verwenden...dann geht auch die Vorschau. (Im Benutzerkontrollzentrum den "erweiterten Editor" auswählen)
Oder einfach absenden und dann hinterher editieren^^ (Darum hab ich auch immer so viele "edits" in meinen Postings^^)
__________________
MSI B350 VDH Pro | AMD Ryzen 2400G | AMD Sapphire Nitro RX480 8GB | Kingston Hyper 16GB DDR-4 3200 | TrackIR 5 | Win 10 Pro x64 | Linux Mint x64 | Coolermaster Modular 620W

Geändert von Duke49th (28.10.2015 um 20:25 Uhr).
Duke49th ist offline   Mit Zitat antworten