Armed-Assault.de Twitter
Antwort
 
Themen-Optionen Ansicht
Alt 22.11.2010, 22:20   #1 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 29.05.2008
Ort: BERLIN
Alter: 28
Beiträge: 496
GER_CJ-187 eine Nachricht über ICQ schicken GER_CJ-187 eine Nachricht über Skype™ schicken
Standard Texturprobleme nach veränderter *_nohq.paa

Hallo,

habe ein Problem, bei einem Reskin von mir...

Ich müsste dafür die *_nohq.paa Textur verändern...



Dort sieht man unten rechts kleine Wellen und Falten, die ich bei meiner Textur weg retuschiert habe...

Nachdem ich die PBO wieder gepackt habe, wird die dazugehörende Außen-Textur fast schwarz angezeigt



Liegt es daran, dass meine *_nohq.paa Textur fast 400kb groß ist, und die originale nur 66kb????

Kann mir das einer erklären, bzw auch eine Lösung aufzeigen, wie man das beheben kann?

MfG - Christopher
__________________

CPU: Intel Core i7-3770K ~ 4 x 3.5GHz // Mainboard: Asus P8P67 LE // RAM: 2 x 8GB DDR3-1333 RAM
Grafikkarte: Nvidia GTX 680 ~ 2GB // Soundkarte: Creative Gamer X-Fi


Geändert von GER_CJ-187 (22.11.2010 um 22:31 Uhr).
GER_CJ-187 ist offline   Mit Zitat antworten
Alt 23.11.2010, 10:12   #2 (permalink)
50 Beiträge100 Beiträge
 
Benutzerbild von SmartGun
 
Registriert seit: 04.06.2008
Beiträge: 197
Standard

Hallo!

ich bin auch kein Profi aber ich versuchs mal....

Die _nohq - Dateien sind in Arma immer normalmaps / bumpmaps

hier gibt es ein tutorial, dass mir sehr geholfen hat normalmaps selber zu erstellen

tutorial

Mit was arbeitest du denn? Fotoshop + .paa plugin?

Ich schaff mit gimp und normalmap plugin, speicher immer als .tga ab und wandle per texview2 bzw. bulldozer im .paa um -> keine probleme mit files, die sich nimmer öffnen lassen wie das z. B. mit PS-plugin manchmal vorkommt, wenn man damit direkt als .paa speichert.

Also: immer erst als .tga file speichern und dann mit texview2 in .paa umwandeln

Lies mal dieses Thema durch:

Anfängerfragen zum Erstellen von Skins


Oh!

da schreibt der burns:
Zitat:

Wandel die Textur (.paa) mit Texview 2 in .png um, ist die einfachste Möglichkkeit.
Danach halt den umgekehrten Weg, wieder über Texview 2 von png zu paa

dann kann texview2 also auch in .png umwandeln stell ich grad fest. cool wusst ich noch nicht! hehe man lernt nie aus^^


Also mein erster Versuch an deiner Stelle währe normalmap-plugin holen und dann die "normalisieren" Funktion des normalmap plugins über deine geänderte _nohq Datei laufen lassen.

wenn´s nicht funtzt, dann halt die nohq nochmal von vorn bearbeiten und darauf achten das alles sauber und in die richtigen formate gespeichert / umgewandelt wird.

soweit mal,

Grüße!

€ typos

Geändert von SmartGun (23.11.2010 um 10:15 Uhr).
SmartGun ist offline   Mit Zitat antworten
Alt 23.11.2010, 11:03   #3 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 29.05.2008
Ort: BERLIN
Alter: 28
Beiträge: 496
GER_CJ-187 eine Nachricht über ICQ schicken GER_CJ-187 eine Nachricht über Skype™ schicken
Standard

hm... klappt auch nicht

kann ich dir die Textur zuschicken, und du versuchst es mal für mich?

Bei mir wird die immer wieder 346kb gros und am Modell schwarz angezeigt.
Egal ob Photoshop + paa-plugin, oder Texview2 (tga bzw Png) überall der gleiche Effekt

Kann ich dir die Textur mal schicken?
__________________

CPU: Intel Core i7-3770K ~ 4 x 3.5GHz // Mainboard: Asus P8P67 LE // RAM: 2 x 8GB DDR3-1333 RAM
Grafikkarte: Nvidia GTX 680 ~ 2GB // Soundkarte: Creative Gamer X-Fi

GER_CJ-187 ist offline   Mit Zitat antworten
Alt 23.11.2010, 12:15   #4 (permalink)
50 Beiträge100 Beiträge
 
Benutzerbild von SmartGun
 
Registriert seit: 04.06.2008
Beiträge: 197
Standard

Hm, jetzt auf den zweiten Blick:

hast du auch die detailmap, also die _smdi angepasst?

höchstwahrscheinlich hast du deshalb noch den dunklen Schatten an deinem model.

Also versuchs mal mit ner neuen _smdi:

hier gibts ein tutorial dazu

das gibts auch irgendwo als .pdf und ist zum anfänglichen basteln von der qualli her echt ausreichend

probier mal folgendes:

-backup von deinen aktuellen _smdi files

-deine geänderte BW-textur im texview2

-dann wie im tut beschrieben edit -> filter und dann folgendes in die box pasten:

Code:
sp = 10;
p = src pixel [u,v];
x = 1 - green p;
y = green p *  ((sp * blue p + 1) / (sp + 1));
c = color[x,y,blue p,1];
jetzt sollte der texview losrödeln und deine _co textur in eine detailmap umrechen

währendessen ab besten die finger vom PC lassen und einfach warten bis er fertig ist. Bei mir stürtzt der nämlich manchmal ab, wenn ich den task wechsle und was anderes nebenher machen will.

Im unteren Rand von texview werden die berechneten pixel hochgezählt und wenn das fertig ist sollte da so ein lila-rosa Gebilde rauskommen.

Das speicherst du unter dem namen deiner alten _smdi ab.

.pbo neu packen -> testen
SmartGun ist offline   Mit Zitat antworten
Alt 23.11.2010, 12:18   #5 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 29.05.2008
Ort: BERLIN
Alter: 28
Beiträge: 496
GER_CJ-187 eine Nachricht über ICQ schicken GER_CJ-187 eine Nachricht über Skype™ schicken
Standard

Die Textur, die ich bearbeitet habe, besitzt keine _smdi
Aber das ist mir auch aufgefallen...

Soweit ich weis, ist die _nohq Textur für Prägungen (Nieten-, Falten-, Schattenwurf-Effekte)
und die _smdi für Licht-Reflexionen und Glanz...

__________________

CPU: Intel Core i7-3770K ~ 4 x 3.5GHz // Mainboard: Asus P8P67 LE // RAM: 2 x 8GB DDR3-1333 RAM
Grafikkarte: Nvidia GTX 680 ~ 2GB // Soundkarte: Creative Gamer X-Fi


Geändert von GER_CJ-187 (23.11.2010 um 12:22 Uhr).
GER_CJ-187 ist offline   Mit Zitat antworten
Alt 23.11.2010, 13:27   #6 (permalink)
50 Beiträge100 Beiträge
 
Benutzerbild von SmartGun
 
Registriert seit: 04.06.2008
Beiträge: 197
Standard

Zitat:

Soweit ich weis, ist die _nohq Textur für Prägungen (Nieten-, Falten-, Schattenwurf-Effekte)
und die _smdi für Licht-Reflexionen und Glanz...

jup, so versteh ich das auch.

es gibt dann noch _as die sind wohl speziell für schatten

Zitat:

Die Textur, die ich bearbeitet habe, besitzt keine _smdi

sieht aber verdammt danach aus, soweit ich das beurteilen kann...

Die Falten an dem alten logo waren aber weg nachdem du deine _nohq bearbeitet hast?

irgendwoher muss der schatten ja kommen.
die Datei muss auch nicht gleich benannt sein.

in den .rvmat dateien wird per Pfadangabe festgelegt welcher Bereich vom model welche maps verwendet
SmartGun ist offline   Mit Zitat antworten
Alt 23.11.2010, 19:35   #7 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 24.12.2008
Beiträge: 424
Standard

Das Paa Plugin bitte nicht verwenden!!!

Wenn man eine paa hat, dann mit Texview öffnen und als Tga speichern.

Sie sollte dann so aussehen wie die png im Anhang.

Denn das ist eine Normalmap!!

rot - grün in grau
blau in Schwarz weiß

Rot = xachse
grün =yachse
blau =stärke
Miniaturansicht angehängter Grafiken
texturprobleme-veraenderter-_nohq-paa-m113a3_02_nohq.png  
__________________
Frankyman ist offline   Mit Zitat antworten
Alt 23.11.2010, 20:26   #8 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 29.05.2008
Ort: BERLIN
Alter: 28
Beiträge: 496
GER_CJ-187 eine Nachricht über ICQ schicken GER_CJ-187 eine Nachricht über Skype™ schicken
Standard

ok, danke für den Tip,

Habe mich noch mal rangesetzt, nur leider öffnet TexView2 die _nohq Datei nicht!

Error loading File "D:\blablabla"

Komischer weise ist diese Textur bei mir Grün...
__________________

CPU: Intel Core i7-3770K ~ 4 x 3.5GHz // Mainboard: Asus P8P67 LE // RAM: 2 x 8GB DDR3-1333 RAM
Grafikkarte: Nvidia GTX 680 ~ 2GB // Soundkarte: Creative Gamer X-Fi

GER_CJ-187 ist offline   Mit Zitat antworten
Alt 23.11.2010, 21:27   #9 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 29.05.2008
Ort: BERLIN
Alter: 28
Beiträge: 496
GER_CJ-187 eine Nachricht über ICQ schicken GER_CJ-187 eine Nachricht über Skype™ schicken
Standard

Erstmal vielen Dank Frankyman,

Mit deiner angehängten Textur hats geklappt, sieht schon deutlich besser aus!!!

Jetzt aktuell ein anderes Problem, wäre genial, wenn du mir auch dabei helfen würdest...

Ich möchte Runde San-Symbole auf dem Fahrzeug haben, statt des Tuches mit dem Halbmond...

Ich wollte den Rest auserhalb des Symbols mit Alpha-Layern transparent machen...
Nur leider geht das nicht.


Dummerweise ist die alternative, den Hintergrund mit der Tarnung zu bemalen auch nicht ideal...


Gibt es eine Möglichkeit dort teile einer Textur transparent zu machen???

Bei einem konvertiertem Fahrzeug hab ich es damals (vor OA) geschafft...


Liebe Grüße - Christopher
__________________

CPU: Intel Core i7-3770K ~ 4 x 3.5GHz // Mainboard: Asus P8P67 LE // RAM: 2 x 8GB DDR3-1333 RAM
Grafikkarte: Nvidia GTX 680 ~ 2GB // Soundkarte: Creative Gamer X-Fi

GER_CJ-187 ist offline   Mit Zitat antworten
Alt 24.11.2010, 00:03   #10 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 29.05.2008
Ort: BERLIN
Alter: 28
Beiträge: 496
GER_CJ-187 eine Nachricht über ICQ schicken GER_CJ-187 eine Nachricht über Skype™ schicken
Standard

Schafft es jemand, bei dieser Textur, den Rand um das Rote Kreuz weg zu bekommen???

Habe nun alles mögliche versucht, habe mir einige Tutorials über Alpha-Layer und Transparente Texturen bei PS und TexView durchgelesen und einige Versuche gemacht...

Jedes mal ohne Erfolg!
Immer war der Rand um das San-Symbol schwarz!

Dem, der mir dieses Problem aus dem Wege schafft, bin ich unendlich dankbar
Miniaturansicht angehängter Grafiken
texturprobleme-veraenderter-_nohq-paa-m113a3_02_ca.jpg  
__________________

CPU: Intel Core i7-3770K ~ 4 x 3.5GHz // Mainboard: Asus P8P67 LE // RAM: 2 x 8GB DDR3-1333 RAM
Grafikkarte: Nvidia GTX 680 ~ 2GB // Soundkarte: Creative Gamer X-Fi


Geändert von GER_CJ-187 (24.11.2010 um 00:25 Uhr).
GER_CJ-187 ist offline   Mit Zitat antworten
Alt 24.11.2010, 00:37   #11 (permalink)
Imperator fori nocturni - This sucks more than anything that has ever sucked before 10 Jahre hx3
20.000 Beiträge
 
Benutzerbild von burns
 
Registriert seit: 13.04.2003
Ort: Monerica
Alter: 35
Beiträge: 32.223
Standard

Zitat von GER_CJ-187 Beitrag anzeigen

Dem, der mir dieses Problem aus dem Wege schafft, bin ich unendlich dankbar

Da kann man sich aber nix von kaufen


Hasde die .paa überhaupt als DXT5 gespeichert nachdem du den Krimskrams ums Kreuz entfernst? Bei DXT1 werden Alpha Layer nämlich verworfen, und somit automatisch schwarz unterlegt.
__________________

burns ist offline   Mit Zitat antworten
Alt 24.11.2010, 06:38   #12 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 24.12.2008
Beiträge: 424
Standard

Besorg dir die Arma2 tools BI Tools 2 - Bohemia Interactive Community

Also ich habe da mit texview keine probleme.
Die präfixe _nohq , _co etc sind wichtig. dadurch weiß texview wie damit zu verfahren ist. Deine grünen _nohq sind dann die texturen, die die engine erstellt und verarbeitet.
Es kommt dann natürlich zu fehlern,wenn du so eine Textur noch mal konvertieren läßt.

Arma 2 kann DXT5 (8bit alpha) und dxt1a ( 1bit alpha ).
Textur öffnen, in die kanäle wechseln , in den alpha kanal gehen(bei bedarf erstellen) , das viereck mit 4 pixeln überstand schwarz machen und dann einen buntstift rund mit weiß wählen und das symbol "austanzen". die gasammte datein dann als TGA 32bit speichern.
Buntstift deshalb, um keine Kantenglättung zu haben. So kann man die tex als _co speichern. Wenn du Kantenglättung hast, dann muß man es als _ca speichern.
__________________
Frankyman ist offline   Mit Zitat antworten
Alt 24.11.2010, 10:39   #13 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 29.05.2008
Ort: BERLIN
Alter: 28
Beiträge: 496
GER_CJ-187 eine Nachricht über ICQ schicken GER_CJ-187 eine Nachricht über Skype™ schicken
Icon5

Au-watte,

ich bekomm das einfach nicht hin...

jetzt habe ich alles Nötige, was ihr mir beschrieben habt, gemacht.
Im TexView2 wird die Textur richtig angezeigt, auch unter Alpha wird angezeigt, dass die Fläche um das Symbol transparent ist.

Nur ingame bleibt die Textur schwarz!
Ich weis einfach nicht mehr weiter
Miniaturansicht angehängter Grafiken
texturprobleme-veraenderter-_nohq-paa-texview2.png  
Angehängte Dateien
Dateityp: rar m113a3_02_ca.tga.rar (786,1 KB, 58x aufgerufen)
__________________

CPU: Intel Core i7-3770K ~ 4 x 3.5GHz // Mainboard: Asus P8P67 LE // RAM: 2 x 8GB DDR3-1333 RAM
Grafikkarte: Nvidia GTX 680 ~ 2GB // Soundkarte: Creative Gamer X-Fi

GER_CJ-187 ist offline   Mit Zitat antworten
Alt 24.11.2010, 15:28   #14 (permalink)
500 Beiträge1000 Beiträge
 
Registriert seit: 01.12.2006
Ort: Bergen/Südheide
Alter: 38
Beiträge: 1.863
Standard

Ich kann Dir zwar nicht helfen CJ, aber ich beobachte Dein Project mit äußerstem Interesse!!

Weitermachen

M136.de Blog Archiv Munster 2006 – Teil 2
KidDynamite ist offline   Mit Zitat antworten
Alt 24.11.2010, 16:23   #15 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 29.05.2008
Ort: BERLIN
Alter: 28
Beiträge: 496
GER_CJ-187 eine Nachricht über ICQ schicken GER_CJ-187 eine Nachricht über Skype™ schicken
Standard

Danke,

ist ja schon ein altes Projekt ^^
Aber irgendwie muss ich das Teil haben, desshalb habe ich mich mit viel Hilfe noch mal darangesetzt.
Jetzt ist es das BIS-Modell, mit originaler Innen-Ansicht.
Bei den Konvertierungen war immer das Problem, dass man nicht raus schauen konnte, oder dass sich die Fahrzeuge beim Bremsen überschlagen haben.

Nur würde ich das Teil gerne endlich fertig bekommen...

Es hapert halt nur noch an den kleinen Ecken des San-Symbols!
__________________

CPU: Intel Core i7-3770K ~ 4 x 3.5GHz // Mainboard: Asus P8P67 LE // RAM: 2 x 8GB DDR3-1333 RAM
Grafikkarte: Nvidia GTX 680 ~ 2GB // Soundkarte: Creative Gamer X-Fi

GER_CJ-187 ist offline   Mit Zitat antworten
Alt 24.11.2010, 17:53   #16 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 24.12.2008
Beiträge: 424
Standard

tja , jetzt mal so blöd gefragt.

Vorher war es eine _co textur , nun hast du eine _ca textur, haste denn die _ca auch neu zugewiesen??
__________________
Frankyman ist offline   Mit Zitat antworten
Alt 24.11.2010, 18:47   #17 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 29.05.2008
Ort: BERLIN
Alter: 28
Beiträge: 496
GER_CJ-187 eine Nachricht über ICQ schicken GER_CJ-187 eine Nachricht über Skype™ schicken
Standard

ähm... ja.
in der P3D habe ich alle Pfade der m113a3_02_co in xxx_ca umbenannt...
__________________

CPU: Intel Core i7-3770K ~ 4 x 3.5GHz // Mainboard: Asus P8P67 LE // RAM: 2 x 8GB DDR3-1333 RAM
Grafikkarte: Nvidia GTX 680 ~ 2GB // Soundkarte: Creative Gamer X-Fi

GER_CJ-187 ist offline   Mit Zitat antworten
Alt 24.11.2010, 18:49   #18 (permalink)
Imperator fori nocturni - This sucks more than anything that has ever sucked before 10 Jahre hx3
20.000 Beiträge
 
Benutzerbild von burns
 
Registriert seit: 13.04.2003
Ort: Monerica
Alter: 35
Beiträge: 32.223
Standard

Es geht ums speichern der Textur.

Die letzen beiden Buchstaben vor dem Punkt haben tatsächliche eine magische Wirkung im Texview, wie Frankyman sagte, _co ohne alpha, _ca mit alpha.

Was nicht heisst das ich es nicht auch schon ohne diesen Killefitz bewerkstelligen konnte, abers kost ja nix, und sicher ist sicher.
__________________

burns ist offline   Mit Zitat antworten
Alt 24.11.2010, 19:24   #19 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 29.05.2008
Ort: BERLIN
Alter: 28
Beiträge: 496
GER_CJ-187 eine Nachricht über ICQ schicken GER_CJ-187 eine Nachricht über Skype™ schicken
Standard

ja, soweit hab ich es ja verstanden, deshalb habe ich die Textur mit _ca und Alpha-Channel abgespeichert, was in Texview2 korrekt angezeigt wird.
Zusätzlich habe ich in der P3d die neue Textur angesprochen, damit diese auch geladen wurde, was sie auch wurde, dennoch ohne die transparente Teile aus zuschneiden...
__________________

CPU: Intel Core i7-3770K ~ 4 x 3.5GHz // Mainboard: Asus P8P67 LE // RAM: 2 x 8GB DDR3-1333 RAM
Grafikkarte: Nvidia GTX 680 ~ 2GB // Soundkarte: Creative Gamer X-Fi

GER_CJ-187 ist offline   Mit Zitat antworten
Alt 24.11.2010, 21:11   #20 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 24.12.2008
Beiträge: 424
Standard

Nicht ganz Burns

Seit Arma2 ist es möglich eine 1 bit Alpha in der Co zu haben.
Also sozusagen an/aus ohne halbtransparenz.

Also ich mach es immer so, das ich die tga in die p3d einbinde, hat den vorteil,das man sich die Textur im O2 ohne Bulli ansehen kann (sehr hilfreich bei der Faceorder).

Aber nun zu der textur.
Ich nehme an, das du den M113 von OA in ein Mlod gebracht hast, was du ja eigentlich nicht solltest.
Nun hast du also in der p3d alles auf die neue Textur geändert.
Wie überprüfst du denn das Ergebnis?
Siehst du dir das Ingame an, oder über bulli?
Machst du ein eigenes Modell daraus? weißt schon das das ärger geben kann.
Oder machst du ein reskin mittels config?
Hast du denn bei der config die Textur auch umbenannt?

Du hast doch nicht etwa der normalmap auch einen Alpha kanal verpasst?
Angehängte Dateien
Dateityp: rar m113mitZielscheibe.rar (1,11 MB, 48x aufgerufen)
__________________

Geändert von Frankyman (24.11.2010 um 21:21 Uhr). Grund: nachtrag
Frankyman ist offline   Mit Zitat antworten
Antwort


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Kontakt - HX3.de - Archiv - Nach oben

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias



SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116