Armed-Assault.de Twitter
Antwort
 
Themen-Optionen Ansicht
Alt 22.11.2012, 11:04   #1 (permalink)
Newbie
 
Registriert seit: 01.10.2012
Beiträge: 9
Standard Performance probleme?

Hallo zusammen,

ich weiß langsam nicht mehr weiter.
Ich bin der Meinung, das ich seit einiger Zeit mit Performance Problemen zu kämpfen habe.

Ich spiele A2 seit Release, damals noch mit einem C2D E8400, einer GTX260 und 4GB Speicher.
Wieviele FPS ich damals hatte kann ich nicht mehr genau sagen.

Naja, aktuell läuft A2 bei mir auf folgendem System,
i5 2500k @stock, ATI 6950, 12GB Speicher.

Sowohl das OS als auch A2 sind auf einer Samsung SSD installiert.
Trotzdem habe ich mit folgenden Einstellungen teilweise unter 30Bilder/s



Auch wenn ich die Einstellungen testweise auf High oder noch niedriger stelle, ändert das an den FPS nur wenig.

Evtl. hat von Euch ja noch jemand einen guten Tipp für mich.
Skandal ist offline   Mit Zitat antworten
Alt 22.11.2012, 12:17   #2 (permalink)
User gesperrt
5000 Beiträge
 
Registriert seit: 20.10.2009
Ort: Jetzt auch im BIF
Alter: 33
Beiträge: 9.163
Standard






edit:
Evtl. mal die Sichweite auf ca. 2000 runterschrauben und alles was auf very High ist runter bis medium oder High.

Geändert von AHTNTEPPOP (22.11.2012 um 12:26 Uhr).
AHTNTEPPOP ist offline   Mit Zitat antworten
Alt 22.11.2012, 12:37   #3 (permalink)
10 Jahre hx3
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von Lester
 
Registriert seit: 26.11.2006
Ort: Kiel, S-H
Alter: 51
Beiträge: 3.011
Standard

Korrekterweise sollte man sagen das SSD's bei ArmA (und auch anderen Streamingengines) keinen direkten Einfluß auf die Frames haben.
Sie beschleunigen nur den Datenzugriff und sorgen somit dafür das Obhjekte schneller geladen werden, was wiederum die Problematik das die schiere Masse an Objekte nicht schnell genug im Speicher geladen werden können beseitigt.

Um die Darstellungsgeschwindigkeit (die Frames) zu erhöhen helfen nur ein leistungsfähigere Grakas und/oder CPU, vom vielen Speicher können "normale" 32Bit'tige Spiele ohnehin nicht provitieren, da eine 32 Bit Anwendung nur einen Adressraum von max. 4GB addressieren kann.

Davon ziehe den GrakaRamGröße als Adressraum noch ab (plus ein paar vernachlässigungswerte MB für andere Peripherie extra) und dann ist klar womit ein Spiel auskommen muß.
__________________
Nur ein Beispiel das zeigt wie BI "support" definiert: https://feedback.bistudio.com/T75547
Lester ist offline   Mit Zitat antworten
Alt 22.11.2012, 12:46   #4 (permalink)
Newbie
 
Registriert seit: 01.10.2012
Beiträge: 9
Standard

Worin der Unterschied zwischen einem 32bit und einem 64bit Programm besteht ist mir bewusst
Ich bewege mich lange genug im IT-Bereich das ich darüber bescheid weiß.
Was ich im Startpost auch nicht erwähnt habe, bei mir läuft Win 7 Pro x64.

Vermutlich ist einfach so das Arma, wie schon zu Release, einfach schlecht skaliert.

Zu der potenten Hardware, ich denke das meine CPU durchaus in der Lage ist Spiele wie Arma zu beschleunigen.
Einzig die Graka ist nicht die schnellste, das sehe ich ein.

Aber andere Spiele werden von dieser schnell genug berechnet z.B. Battlefield 3 o.Ä.

Ich denke das es von AHTNTEPPOP ganz gut auf den Punkt gebracht wurde,
das ist halt ARMA.
Skandal ist offline   Mit Zitat antworten
Alt 22.11.2012, 13:48   #5 (permalink)
500 Beiträge
 
Registriert seit: 07.01.2008
Beiträge: 653
[GNC]Lord-MDB eine Nachricht über ICQ schicken
Standard

wieso ist eigentlich vsync angeschaltet ?
__________________


--> -> Rechtschreibfehler sind Gratis <- <--
--> Wer welche findet kann sie behalten <--



German Nato Corps
[GNC]Lord-MDB ist offline   Mit Zitat antworten
Alt 22.11.2012, 14:34   #6 (permalink)
10 Jahre hx3
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von JumpingHubert
 
Registriert seit: 30.05.2006
Alter: 46
Beiträge: 3.091
Standard

das Naheliegendste wäre eigentlich, den 2500k zu übertakten und zu gucken, was die min. fps machen. Auch geht der maximierte Grasradius (terrain-detail) verdammt auf die Grafikkarte. vsync natürlich aus.
__________________
R290 @ 1200mhz/1560mhz ram, 3570k @ 4.8Ghz, Win10-64bit, Asrock-Z77 Ekzem4, 16GB Ram @ 2666mhz, deepoon e2 (dk2-Klon)
JumpingHubert ist offline   Mit Zitat antworten
Alt 22.11.2012, 14:50   #7 (permalink)
Newbie
 
Registriert seit: 01.10.2012
Beiträge: 9
Standard

Vsync hab ich drin, weil ich sonst Tearing habe

CPU werd ich bei Gelegenheit mal takten, mal sehen was das bringt.

Hab eben mal diesen Benchmark laufen lassen, laut diesem sinds 51 Bilder im Schnitt.
Skandal ist offline   Mit Zitat antworten
Alt 22.11.2012, 18:34   #8 (permalink)
10 Jahre hx3
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von JumpingHubert
 
Registriert seit: 30.05.2006
Alter: 46
Beiträge: 3.091
Standard

die ATI-Karten sind ja bei Arma2 vergleichsweise potenter beim antialiasing. Nimm mal Terraindetails etwas zurück und stattdessen AA auf hoch oder sehr hoch. Sollte eigentlich nicht so reinhauen wie Terrain auf veryhigh. 4GHZ sollte deine cpu ja ohne große Stromzieherei bzw Tempanstieg hinbekommen.
__________________
R290 @ 1200mhz/1560mhz ram, 3570k @ 4.8Ghz, Win10-64bit, Asrock-Z77 Ekzem4, 16GB Ram @ 2666mhz, deepoon e2 (dk2-Klon)
JumpingHubert ist offline   Mit Zitat antworten
Alt 22.11.2012, 19:28   #9 (permalink)
Imperator fori nocturni - This sucks more than anything that has ever sucked before 10 Jahre hx3
20.000 Beiträge
 
Benutzerbild von burns
 
Registriert seit: 13.04.2003
Ort: Monerica
Alter: 35
Beiträge: 32.226
Standard

Bei den mega Auflösungen von heutzutage braucht man doch kein Antialiasing mehr
(ausser für geschönte Bilder, aber in Bewegung bekommts eh niemand mit)
__________________

burns ist offline   Mit Zitat antworten
Alt 22.11.2012, 20:05   #10 (permalink)
Armed-Assault.de Team
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von MrCharles
 
Registriert seit: 22.12.2008
Beiträge: 3.641
Standard

Antialiasing raus und Post Process Effekte auf Normal, dann PPAA anschalten. Sieht gut aus und frisst nicht so viele Frames. Das ingame AA ist sowieso unperformant
MrCharles ist offline   Mit Zitat antworten
Alt 22.11.2012, 21:35   #11 (permalink)
10 Jahre hx3
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von JumpingHubert
 
Registriert seit: 30.05.2006
Alter: 46
Beiträge: 3.091
Standard

Zitat von burns Beitrag anzeigen

Bei den mega Auflösungen von heutzutage braucht man doch kein Antialiasing mehr
(ausser für geschönte Bilder, aber in Bewegung bekommts eh niemand mit)

wenn du wüßtest, wie spackenmäßig-nah ich vor dem Ding häng..Mega-FOV is alles
__________________
R290 @ 1200mhz/1560mhz ram, 3570k @ 4.8Ghz, Win10-64bit, Asrock-Z77 Ekzem4, 16GB Ram @ 2666mhz, deepoon e2 (dk2-Klon)
JumpingHubert ist offline   Mit Zitat antworten
Alt 02.02.2013, 09:29   #12 (permalink)
Newbie
 
Registriert seit: 01.10.2012
Beiträge: 9
Standard

Morgen,

ich muss meinen Thread nochmal hochholen.
Und zwar habe ich meine Kiste ein wenig aufgerüstet, die 6950 wurde gegen eine 7950 ausgetauscht (war ein Reparaturaustausch)

Performance passt jetzt soweit.
Allerdings ist mir etwas neues aufgefallen, auch schon mit der 6950.

Wenn ich z.B. auf einem der Türme in Cherno stehe, und dort den Zoom verwende, sieht man wie sich die Texturen der Häuser ringsrum aufbauen und beim rauszoomen wieder verschwinden.
Wenn sich die Texturen aufbauen, sieht man dann schön, wie die Fenster richtig aus der Fassade ploppen.

Ist zwar nur ein Schönheitsfehler aber trotzdem recht nervig.

Geändert von Skandal (02.02.2013 um 09:32 Uhr).
Skandal ist offline   Mit Zitat antworten
Antwort


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Arma OA Arma2 und DayZ Probleme c4al DayZ 19 01.07.2012 20:12
Starke Performance probleme und lags (Arma 2 CO , DayZ) Nabend123 Technische Fragen & Probleme 8 15.06.2012 14:14
ArmA II Probleme im Spiel und Patchen Basti1254 Technische Fragen & Probleme 9 20.10.2011 01:41
Performance Probleme hd5870 Technische Fragen & Probleme 6 02.03.2011 21:16
Performance Probleme Socke89 Technische Fragen & Probleme 47 21.07.2010 14:23


Kontakt - HX3.de - Archiv - Nach oben

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias



SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116