Armed-Assault.de Twitter


Technische Fragen & Probleme Hardware & Software Probleme, Bugs & Performance

Antwort
 
Themen-Optionen Ansicht
Alt 19.08.2008, 04:22   #1 (permalink)
10 Jahre hx3
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von Lester
 
Registriert seit: 26.11.2006
Ort: Kiel, S-H
Alter: 51
Beiträge: 3.011
Standard Fehlendes "Bumpmapping" in ArmA seid Patch 1.xx ?

Aufegefallen ist es meinem Unterbewustsein schon länger, aber irgendwie war mir nie klar was da fehlt ...

... geht es nur mir nebst meinen Freundeskreis so, oder hat keiner mehr "Bumpmapping" seid diversen Versionen mehr gesehen ?!

Im Vanilla ArmA war das drin,
jetzt können wir egal auf welchen Einstellungen nur noch Reflexionen und Enviromentmapping ausmachen,
die "Tiefentexturen" werden in ArmA offensichtlich nicht mehr beachtet, in O2 hingegen allerdings schon !

Ich hab es auch schon mal ganz ohne jeden Mod (auch ohne QG) probiert, keine Besserung !

Ich hoffe die sind nicht aus Waldperformancegründen wegoptimiert worden, aber genau der Verdacht drängt sich mir auf !
__________________
Nur ein Beispiel das zeigt wie BI "support" definiert: https://feedback.bistudio.com/T75547
Lester ist offline   Mit Zitat antworten
Alt 19.08.2008, 04:43   #2 (permalink)
50 Beiträge100 Beiträge
 
Benutzerbild von ViconX
 
Registriert seit: 10.11.2006
Alter: 37
Beiträge: 218
Standard

Mhh also bei mir funktioniert es noch, allerdings komm ich damit ja garnicht so richtig zurecht. Ich raff es einfach nicht das Zeug richtig einzusetzen. Naja Übung macht den Meister oder wie heißt es?


Bei den Orginal Modellen ist das alles viel dezenter auch die SpecMap bekomm ich nich so hin, daß es nach was ausschaut falls da jemand nen Tip oder ein Tutorial hat hat wäre ich dankbar.

Gruß
ViconX ist offline   Mit Zitat antworten
Alt 19.08.2008, 06:21   #3 (permalink)
10 Jahre hx3
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von Lester
 
Registriert seit: 26.11.2006
Ort: Kiel, S-H
Alter: 51
Beiträge: 3.011
Standard

Nen Tip hab ich nicht außer sich ein optisches Vorbild bei den BIS zu schnappen und es zu nutzen bzw damit etwas spielen.
zum erstellen der Texturen kann man zwar meist mit gängigen Tools sich eine Bumpmap berechenn lassen, die passt aber eben nicht immer, dann muß man dort Hand anlegen was deutlich einfacher Klingt als es ist.

So wie das aussieht, sind das auf dem Panzer aber auch eher die Effekte der Specmap als die der Bumpmap,
das konnte ich auch schon bei einigen der BIS Sachen beobachten, vermutlich ist das der springende Punkt das es mir nicht eher in die Augen gehüpft ist.
Aktuell bekommt also wohl nur "nasse" räumliche Texturen zu sehen, die ganzen *_NOHQ.paa scheinen sozusagen keine Verwendung mehr zu haben.


Markant ist für mich jedenfalls die Cobra, die war seinerzeit voller Rillen und Nieten Details und mittlerweile erscheint die am Metall nur noch flach und natürlich etwas glänzend,
abgesehen von der in die Textur eingebrachten Pseudoräumlichkeit.


Möglicherweise tritt der Effekt beim Einsatz bestimmter Shader auch stärker in den Vordergrund, aber irgendwas hat BIS da definitiv gedreht.
__________________
Nur ein Beispiel das zeigt wie BI "support" definiert: https://feedback.bistudio.com/T75547
Lester ist offline   Mit Zitat antworten
Alt 19.08.2008, 06:39   #4 (permalink)
50 Beiträge100 Beiträge
 
Benutzerbild von ViconX
 
Registriert seit: 10.11.2006
Alter: 37
Beiträge: 218
Standard

Ja also es wurde auf jeden Fall was geändert früher war der Effekt viel intensiver als jetzt.
Vielleicht hängt das aber auch mit den Grafiktreibern zusammen wäre jetzt wirklich interessant zu wissen.

Btw. ich hab nochmal etwas rumgetestet also die NormalMap funktioniert auf jeden Fall ich hatte bei der Erstellung was falsch gemacht das jetzige Ergebnis schaut schon viel besser aus. Ich habe nichts geändert nur ne neue Normal erstellt und der Unterschied ist gut sichtbar.



Ist zwar immer noch nicht perfekt aber ich bin jetzt auf dem richtigen Weg, jetzt muß ich och ne gescheite Spec hinbekommen
ViconX ist offline   Mit Zitat antworten
Alt 19.08.2008, 10:58   #5 (permalink)
500 Beiträge1000 Beiträge
 
Registriert seit: 09.01.2008
Beiträge: 1.565
Standard

Oha... ich nutz' das Bumpmapping eigentlich erst seit ein paar Monaten für meine Modelle...

Anscheinend sind die Shader-Einstellungen von ArmA etwas zurückgefahren worden. Vmtl. seit 1.08B bzw. 1.14.

War da nicht so ein "Improvement" in den Releasenotes????

Da ich sowohl Geforce als auch Radeon nutze, fiel mit zwischen beiden kein Unterschied auf, seit dem ich die erste Normalmap auf den M1 Abrams aufgezogen habe. Hatte nur mal einen Schock bekommen, als ich keine Nieten mehr sehen konnte. Habe dann die Shader-Effects von Lowest auf Low gezogen und schon waren die wieder da.

Ich denke mal, dass es neu ist, die Shader auf Lowest komplett auszuschalten...

mike

Geändert von modEmMaik (19.08.2008 um 11:01 Uhr).
modEmMaik ist offline   Mit Zitat antworten
Alt 19.08.2008, 12:28   #6 (permalink)
500 Beiträge1000 Beiträge
 
Registriert seit: 12.06.2006
Beiträge: 1.252
Standard

War es nicht so dass nur Normalmapping durch die Engine unterstützt wird
.kju ist offline   Mit Zitat antworten
Alt 19.08.2008, 12:39   #7 (permalink)
500 Beiträge1000 Beiträge
 
Registriert seit: 09.01.2008
Beiträge: 1.565
Standard

Zitat von WGL.Q Beitrag anzeigen

War es nicht so dass nur Normalmapping durch die Engine unterstützt wird

Ich bin zu alt um dazwischen zu unterscheiden... und Wiki macht auch keinen Unterschied.

Zitat:

In 3D computer graphics, normal mapping is an application of the technique known as bump mapping.

Oder Du meinst Displacement Mapping , das wird erst von ArmA 0815 supportet werden, das ist aber nur ein Gerücht... so wie "Rocky Teil 653"

mike

Geändert von modEmMaik (19.08.2008 um 12:41 Uhr).
modEmMaik ist offline   Mit Zitat antworten
Alt 19.08.2008, 13:23   #8 (permalink)
10 Jahre hx3
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von Lester
 
Registriert seit: 26.11.2006
Ort: Kiel, S-H
Alter: 51
Beiträge: 3.011
Standard

War ja klar das einer den Punkt aufbringen mußte, deswegen hab ich das Bumpmapping auch in "" geschrieben !

Solche Spitzfindigkeiten ändern nur absolut nichts an dem Effekt !



Ich würde echt gerne die Effektstärke von ArmA im Bulldozermodus diesbezüglich haben, bei nichtglänzenden ("nassen") Oberflächen kommt das zwar auch ingame ganz gut raus,
aber bei stumpfen Oberflächen ist es aktuell sozusagen egal ob man eine "Normalmap" mit oder ohne Höheninfos definiert hat.


Ich würde behaupten das ich alle Einstellungen durchprobiert aber keinen positiven Effekt entdecken konnte.
__________________
Nur ein Beispiel das zeigt wie BI "support" definiert: https://feedback.bistudio.com/T75547
Lester ist offline   Mit Zitat antworten
Alt 19.08.2008, 14:16   #9 (permalink)
500 Beiträge1000 Beiträge
 
Registriert seit: 09.01.2008
Beiträge: 1.565
Standard

Zitat von Lester Beitrag anzeigen

Ich würde echt gerne die Effektstärke von ArmA im Bulldozermodus diesbezüglich haben, bei nichtglänzenden ("nassen") Oberflächen kommt das zwar auch ingame ganz gut raus,
aber bei stumpfen Oberflächen ist es aktuell sozusagen egal ob man eine "Normalmap" mit oder ohne Höheninfos definiert hat.


Ich würde behaupten das ich alle Einstellungen durchprobiert aber keinen positiven Effekt entdecken konnte.

Das überrascht mich. Ich hab' erst dieses WE an einem Model gearbeitet und erst die nohq gemoddelt (so eine Art Handgriff) und danach erst die smdi auf nass-nicht-glänzend gestellt, voher hat man sich darin fast spiegeln können (mit dem Standard-Rosa).

Allerdings steht meine Dev-Kiste noch auf 1.08b, nur verifizieren tu' ich es dann auch auf meiner 1.14 Kiste. Hab' ich allerdings seit dem WE noch nicht gemacht. Werde ich heute Abend mal schauen
modEmMaik ist offline   Mit Zitat antworten
Alt 19.08.2008, 14:35   #10 (permalink)
50 Beiträge100 Beiträge
 
Benutzerbild von ViconX
 
Registriert seit: 10.11.2006
Alter: 37
Beiträge: 218
Standard

Ja das Nassglänzende stört mich auch wenn da jemand ne Ahnung hat wie ich das besser machen könnte wäre supi. Liegt das an der SpecMap oder kann man da was im Materialeditor ändern? Hätte eben auch gerne, daß man was von der NormalMap sieht ohne, daß das ganze Modell strahlt wie ein Tannenbaum.

@Mike ich muß dir später noch ne PM zukommen lassen ich hab da 2-3 Frägchen an dich vielleicht kannst du mir dabei weiterhelfen.

Gruß
ViconX ist offline   Mit Zitat antworten
Alt 19.08.2008, 15:52   #11 (permalink)
10 Jahre hx3
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von Lester
 
Registriert seit: 26.11.2006
Ort: Kiel, S-H
Alter: 51
Beiträge: 3.011
Standard

Ich hab mit specmaps noch nicht viel gemacht, der "Wetlook" kommt aber garantiert daher.
Ggf mußte die specmap mal sehr "milde" machen, an den Specularwerten der rvmat drehen oder gezielt nen anderen Shader probieren,
die haben teilweise erhebliche Unterschiede obwohl sie dann identisches Material verwenden !
__________________
Nur ein Beispiel das zeigt wie BI "support" definiert: https://feedback.bistudio.com/T75547
Lester ist offline   Mit Zitat antworten
Alt 19.08.2008, 16:21   #12 (permalink)
500 Beiträge1000 Beiträge
 
Registriert seit: 09.01.2008
Beiträge: 1.565
Standard

Oh, Oh...

Ähm.. ich nehme mir normal die Sachen aus den ausgepackten BI-Addons zu Hilfe und suche mir raus, was passt. Ja, die smdi haben teilweise heftige Auswirkungen bei gleichem Material. Ich hab' mir schon gedacht, mal die smdi schwarz zu hinterlegen und somit evtl die Unterschiede kenntlich zu machen, aber bis jetzt.... copy&paste

Letztendlich stammen die BI-Bump- und Specmaps aus einer automatischen Konvertierung weit hoher auflösender Modelle, wie sie in Blender zu finden ist (meine die Konvertierung). Per Hand Specmaps nachträglich von Grund auf zu generieren... wird schwierig

Aber nix ist unmöglich und wenn man einen Bereich der Map zur Hand nimmt und sich die Helligkeit der Pixel näher anguckt, sollte man eigentlich was passendes machen können.
modEmMaik ist offline   Mit Zitat antworten
Alt 19.08.2008, 16:55   #13 (permalink)
50 Beiträge100 Beiträge
 
Benutzerbild von ViconX
 
Registriert seit: 10.11.2006
Alter: 37
Beiträge: 218
Standard

Das dumme ist halt ich habe das Orginalmodell vom Panzer leider nicht mehr (zumindest finde ich es nicht). Das Modell hatte ich früher mal für OFP gemacht das einzigste was noch übrig war, ist ne alte PBO und die Texturen. Ansonsten hätte ich versucht in Max die Maps zu erstellen, so muss ich aber ShaderMap Pro dafür verwenden was leider nicht zu so tollen Ergebnissen führt.
Ich habe jetzt mal versucht ne .rvmat aus der tracked PBO zu öffnen um mir mal an zu schauen was da so eingestellt ist allerdings spuckt der Materialeditor nur ne Fehlermeldung wenn ich versuche sie zu öffnem. Ist das normal? Für mein Material hab ich dann das Tutorial von Linker Split verwendet da ich kein Plan hatte wie der Müll funktioniert

Naja das wird schon werden irgendwann bekomm ich das noch richtig hin.
ViconX ist offline   Mit Zitat antworten
Alt 19.08.2008, 16:56   #14 (permalink)
Imperator fori nocturni - This sucks more than anything that has ever sucked before 10 Jahre hx3
20.000 Beiträge
 
Benutzerbild von burns
 
Registriert seit: 13.04.2003
Ort: Monerica
Alter: 36
Beiträge: 32.340
Standard

Zitat von ViconX Beitrag anzeigen

Das dumme ist halt ich habe das Orginalmodell vom Panzer leider nicht mehr (zumindest finde ich es nicht). Das Modell hatte ich früher mal für OFP gemacht das einzigste was noch übrig war, ist ne alte PBO und die Texturen. Ansonsten hätte ich versucht in Max die Maps zu erstellen, so muss ich aber ShaderMap Pro dafür verwenden was leider nicht zu so tollen Ergebnissen führt.
Ich habe jetzt mal versucht ne .rvmat aus der tracked PBO zu öffnen um mir mal an zu schauen was da so eingestellt ist allerdings spuckt der Materialeditor nur ne Fehlermeldung wenn ich versuche sie zu öffnem. Ist das normal? Für mein Material hab ich dann das Tutorial von Linker Split verwendet da ich kein Plan hatte wie der Müll funktioniert

Vielleicht kann dir das hier helfen: http://hx3.de/189358-beitrag127.html

Falls nicht: aua aua nit hauen
__________________

burns ist offline   Mit Zitat antworten
Alt 19.08.2008, 17:06   #15 (permalink)
50 Beiträge100 Beiträge
 
Benutzerbild von ViconX
 
Registriert seit: 10.11.2006
Alter: 37
Beiträge: 218
Standard

Zitat von burns Beitrag anzeigen

Vielleicht kann dir das hier helfen: http://hx3.de/189358-beitrag127.html

Falls nicht: aua aua nit hauen

Danke Dir aber an Programmen fehlt es nicht eher an dem Wissen wie ich die Maps richtig an zu wenden habe und die Funktionen vom Materialeditor
Das ist halt der Tribut den man zahlen muß wenn man eine Weile lang nix mehr Modell mäßig gemacht hat. Da ist soviel neuer Scheiß dazu gekommen den man Wissen muß da werden die Haare nur noch schneller Grau
ViconX ist offline   Mit Zitat antworten
Alt 19.08.2008, 17:10   #16 (permalink)
Imperator fori nocturni - This sucks more than anything that has ever sucked before 10 Jahre hx3
20.000 Beiträge
 
Benutzerbild von burns
 
Registriert seit: 13.04.2003
Ort: Monerica
Alter: 36
Beiträge: 32.340
Standard

Das Tut von neph gelesen?


^^ Ist´s selbe wie der work chop shop aus vorigem Post, nur in schön.
__________________

burns ist offline   Mit Zitat antworten
Alt 19.08.2008, 17:16   #17 (permalink)
500 Beiträge1000 Beiträge
 
Registriert seit: 09.01.2008
Beiträge: 1.565
Standard

Die RVMAT's kann man aber de-binärisieren. Ich hab' mir so geholfen, dass ich die Files als config.bin in ein Addon von mir reingepackt und danach mit viewPBO wieder gelesen habe. Fehlen zwar ein paar Klammern, aber ansonsten ist alles erkennbar.
In meinem M1 Abrams steckt auch eine RVMAT, die zumindest in der unbin-Version nutzbar sein sollte. Kannst Dich ja mal damit ein wenig mit dem Materialeditor spielen.

Ansonsten beginne ich imer mit einer typisch blauen nohq und einer standard-rosa smdi und kopiere mit einfach ein paar Teile aus den anderen nohq und smdi's, bzw arbeite mit Linienziehen und Weichzeichner.

Linker Splitt hat auch einiges in das armed-assault.info-Forum reingelegt.
modEmMaik ist offline   Mit Zitat antworten
Alt 19.08.2008, 17:18   #18 (permalink)
Imperator fori nocturni - This sucks more than anything that has ever sucked before 10 Jahre hx3
20.000 Beiträge
 
Benutzerbild von burns
 
Registriert seit: 13.04.2003
Ort: Monerica
Alter: 36
Beiträge: 32.340
Standard

Zitat von modEmMaik Beitrag anzeigen

Die RVMAT's kann man aber de-binärisieren. Ich hab' mir so geholfen, dass ich die Files als config.bin in ein Addon von mir reingepackt und danach mit viewPBO wieder gelesen habe. Fehlen zwar ein paar Klammern, aber ansonsten ist alles erkennbar.

derapify?

*Q imitier*
__________________

burns ist offline   Mit Zitat antworten
Alt 19.08.2008, 18:51   #19 (permalink)
10 Jahre hx3
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von Lester
 
Registriert seit: 26.11.2006
Ort: Kiel, S-H
Alter: 51
Beiträge: 3.011
Standard

Alternativ funzt das Total Commander Plugin hervorragend zum un'rap'en !
__________________
Nur ein Beispiel das zeigt wie BI "support" definiert: https://feedback.bistudio.com/T75547
Lester ist offline   Mit Zitat antworten
Alt 19.08.2008, 21:35   #20 (permalink)
500 Beiträge1000 Beiträge
 
Registriert seit: 09.01.2008
Beiträge: 1.565
Standard

So, ich hab' grad den Gegentest auf Geforce ArmA 1.14 mit dem Smurfc M1Abrams gemacht. Der eignet sich gut zum checken, weil in der Textur (Moos-Man Grün) keine Info über die Seitenplatten drin sind und die Platten nur über Bumpmap abgegrenzt sind.

Sind bei mir klar erkennbar, sobald ich shader-Details mind. "Low" habe, auf "very low" sind die Einzelelemente der Platten nicht mehr zu erkennen.

Bei mir läuft's korrekt..
modEmMaik ist offline   Mit Zitat antworten
Antwort


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Der "Läuft ArmA bei mir?" Thread K-one Technische Fragen & Probleme 462 14.07.2009 16:04
Waypoint "GUARD" oder "BEWACHEN" syn1979 Editing 2 21.12.2006 08:05
"Alte" OFP-Missionen in ArmA einbinden? Cowboy28 Editing 11 06.12.2006 17:08
Der "Ich Packe meinen Koffer kombiniert mit Domino" Thread Keksman Offtopic 34 02.04.2005 13:00
ne ganz andere Frage Firewall "Trend Micro" sushi25 Hilfe 8 10.11.2004 17:04


Kontakt - HX3.de - Archiv - Nach oben

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias



SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116