Armed-Assault.de Twitter


Technische Fragen & Probleme Hardware & Software Probleme, Bugs & Performance

Antwort
 
Themen-Optionen Ansicht
Alt 28.08.2008, 11:08   #1 (permalink)
Newbie
 
Benutzerbild von Hellfreeza
 
Registriert seit: 24.01.2008
Ort: Thalheim bei Wels - Austria
Alter: 35
Beiträge: 44
Hellfreeza eine Nachricht über ICQ schicken
Standard Beim Einschalten von AA totaler Performance Einbruch

folgendes Problem:

habe meine ArmA auf 1680x1050 laufen. Alle grafiksettings auf "Very High". Sichtweite auf 6000Meter.
Ich habe bei diesen Einstellungen zwischen 45 und 62 FPS.
ArmA läuft da perfekt!

AA ist bei mir leider deaktiviert, weil sobald ich es einschalte, bekomme ich massive Performanceeinbrüche.
Ganz arg wird es, wenn ich neben ein paar Büschen oder im Wald stehe und dann versuche AA auf normal zu stellen.
Wenn ich dann aber AA wieder deaktiviere läuft mein Game wieder mit voller perfomance.

Meine Graka: BFG Geforce9800GX2
Meine CPU: Intel Core Duo E8600@3,33Ghz

kennt von euch jemand dieses problem??
Hellfreeza ist offline   Mit Zitat antworten
Alt 28.08.2008, 11:23   #2 (permalink)
Imperator fori nocturni - This sucks more than anything that has ever sucked before 10 Jahre hx3
20.000 Beiträge
 
Benutzerbild von burns
 
Registriert seit: 13.04.2003
Ort: Monerica
Alter: 36
Beiträge: 32.340
Standard

Zitat von Hellfreeza Beitrag anzeigen

kennt von euch jemand dieses problem??

Wieso Problem?
AA zieht eben Leistung!

Nur weil du eine nicht ganz günstige Graka dein Eigen nennst, brauchst du nicht zu glauben das ArmA jetzt mit highest settings und VD 6000 und AA auf 800 FPS läuft...davon abgesehen das AA in solch hohen Auflösungen ziemlich sinnbefreit ist.

Ich lass es immer auf Low, den Unterschied zu high (oder #8) sieht man eh nur auf Standbildern.
__________________

burns ist offline   Mit Zitat antworten
Alt 28.08.2008, 12:19   #3 (permalink)
Newbie
 
Benutzerbild von Hellfreeza
 
Registriert seit: 24.01.2008
Ort: Thalheim bei Wels - Austria
Alter: 35
Beiträge: 44
Hellfreeza eine Nachricht über ICQ schicken
Standard

Zitat von burns Beitrag anzeigen

AA zieht eben Leistung!

ja aber das es gleich so viel ist?

und wie gesagt, es tritt nur auf, wenn ich mich im Wald oder in einer Gebüschzeile befinde.

Ich hab auch probiert, die plants.pbo aus meinem Addon-Ordner rauszunehmen. Hab dann im game AA auf "Very High" gestellt. Von Performanceeinbrüchen merkte ich dabei absolut nichts.

Mir scheint es, als würde die Vegetation in ArmA soviel Performance schlucken, sobald man AA auf "Normal" oder "High" einstellt.
Hellfreeza ist offline   Mit Zitat antworten
Alt 28.08.2008, 12:33   #4 (permalink)
10 Jahre hx3
5000 Beiträge
 
Benutzerbild von Duke49th
 
Registriert seit: 06.10.2006
Ort: Manila
Alter: 38
Beiträge: 7.959
Standard

Zitat von Hellfreeza Beitrag anzeigen

ja aber das es gleich so viel ist?



Zitat von Hellfreeza Beitrag anzeigen

...und wie gesagt, es tritt nur auf, wenn ich mich im Wald oder in einer Gebüschzeile befinde....

Mir scheint es, als würde die Vegetation in ArmA soviel Performance schlucken, sobald man AA auf "Normal" oder "High" einstellt.

Japp. Das liegt definitiv am Gemüse. Ist bei mir ähnlich. Wobei es bei mir egal ist ob ich AA aus oder an(niedrig/mittel) habe. Kann aber auch an der ATI Architektur liegen, glaube bei ATI Karten haut das generell nciht so rein wenn man AA an macht. AF haut da mehr rein.

Aber ist ja auch ganz logisch, daß es im Wald mehr reinhaut. Hast ja auch nen Haufen Objekte die alle "geglättet" werden müssen. Wenn Du dann noch TAA(heisst bei Nvidia anders - macht jedenfalls das die Texturen selbst noch gerendert werden, nicht nur Linien der Objekte)
Dann kann das unter Umständen richtig reinhauen.

Bei mir ruckelts übrigens manchmal ganz heftig, wenn ich ein Fernglas oder G36 bzw. ein Snipergewehr benutze, vor allem in waldigen Gebieten.(Obwohl die fps ansonsten ganz gut sind)
Darum ist eine meiner Lieblingskarten auch Sakakah al Jewf Wüste wo hin das Auge schaut.
__________________

Intel Board | Intel i3 2100 |Dell 8GB DDR-3 1600 | AMD HD7770 1GB | Creative Audigy EX Platinum | TrackIR 5 | Win 10 Pro x64 | Linux Mint x64 | Coolermaster Modular 620W
Duke49th ist offline   Mit Zitat antworten
Alt 28.08.2008, 12:51   #5 (permalink)
Newbie
 
Benutzerbild von Hellfreeza
 
Registriert seit: 24.01.2008
Ort: Thalheim bei Wels - Austria
Alter: 35
Beiträge: 44
Hellfreeza eine Nachricht über ICQ schicken
Standard

gibt es dafür einen trick um die Performance in diesem Bereich ein wenig zu steigern oder ist da nix mehr zu machen?
Hellfreeza ist offline   Mit Zitat antworten
Alt 28.08.2008, 13:12   #6 (permalink)
10 Jahre hx3
5000 Beiträge
 
Benutzerbild von Duke49th
 
Registriert seit: 06.10.2006
Ort: Manila
Alter: 38
Beiträge: 7.959
Standard

Zitat von Hellfreeza Beitrag anzeigen

gibt es dafür einen trick um die Performance in diesem Bereich ein wenig zu steigern oder ist da nix mehr zu machen?

Ich glaub nicht. Mit 1.08 gabs noch die Möglichkeit die LOD's zu ändern, mim Addon. Das hat BIS aber inzwischen schon im Patch gemacht. Der Unterschied ist jetzt, zumindest bei mir, unmerklich.

Du kannst Dir das OFP Gestrüpp draufknallen....aber das währe glaub ich nicht das richtige für Dich

Wenn Du kannst, stell die Auflösung höher. Dann brauchst Du Garantiert kein AA mehr. Wenn ich Deine Karte hätte würde ich auf 2048x1536 stellen...aber ich hab ja auch noch einen (heissgeliebten) Röhrenmonitor
__________________

Intel Board | Intel i3 2100 |Dell 8GB DDR-3 1600 | AMD HD7770 1GB | Creative Audigy EX Platinum | TrackIR 5 | Win 10 Pro x64 | Linux Mint x64 | Coolermaster Modular 620W
Duke49th ist offline   Mit Zitat antworten
Alt 28.08.2008, 14:05   #7 (permalink)
Newbie
 
Benutzerbild von Hellfreeza
 
Registriert seit: 24.01.2008
Ort: Thalheim bei Wels - Austria
Alter: 35
Beiträge: 44
Hellfreeza eine Nachricht über ICQ schicken
Standard

hmm..wie kann ich bitte meine Auflösung höher als 1680x1050 stellen??

ich hab eine 22" TFT Monitor. geht das denn?
Hellfreeza ist offline   Mit Zitat antworten
Alt 28.08.2008, 14:26   #8 (permalink)
10 Jahre hx3
5000 Beiträge
 
Benutzerbild von Duke49th
 
Registriert seit: 06.10.2006
Ort: Manila
Alter: 38
Beiträge: 7.959
Standard



Nein. Denke nicht. Du hast nen TFT. Kenn mich mit TFT's nicht aus, aber ich denke da geht nicht mehr. Aber darum hat man ja noch die guten alten CRT's
__________________

Intel Board | Intel i3 2100 |Dell 8GB DDR-3 1600 | AMD HD7770 1GB | Creative Audigy EX Platinum | TrackIR 5 | Win 10 Pro x64 | Linux Mint x64 | Coolermaster Modular 620W
Duke49th ist offline   Mit Zitat antworten
Alt 28.08.2008, 14:29   #9 (permalink)
Imperator fori nocturni - This sucks more than anything that has ever sucked before 10 Jahre hx3
20.000 Beiträge
 
Benutzerbild von burns
 
Registriert seit: 13.04.2003
Ort: Monerica
Alter: 36
Beiträge: 32.340
Standard

Normalerweise steht in den ArmA Optionen die höchstmögliche Auflösung zur Auswahl.
Bei TFT´s ist aber aus irgendeinem Grund immer sinnvoll Games in der "nativen" Auflösung des TFT zu fahren - in meinem Fall ist das 1280x1024 (kein Widescreen).
__________________

burns ist offline   Mit Zitat antworten
Alt 28.08.2008, 15:02   #10 (permalink)
Newbie
 
Benutzerbild von Hellfreeza
 
Registriert seit: 24.01.2008
Ort: Thalheim bei Wels - Austria
Alter: 35
Beiträge: 44
Hellfreeza eine Nachricht über ICQ schicken
Standard

oder, was mir noch eingefallen ist..kann man es irgendwie machen, dass AA aktiviert ist, ausser für die Vegetation nicht.
Ich meine so wie bei dem lowplants addon. da werden doch auch nur die shader von der ArmAVegetation geändert?

Könnte man da nicht irgendwie die config umschreiben..würde das gehen, oder ist das zu viel Aufwand??
Hellfreeza ist offline   Mit Zitat antworten
Alt 28.08.2008, 15:04   #11 (permalink)
Imperator fori nocturni - This sucks more than anything that has ever sucked before 10 Jahre hx3
20.000 Beiträge
 
Benutzerbild von burns
 
Registriert seit: 13.04.2003
Ort: Monerica
Alter: 36
Beiträge: 32.340
Standard

Ganz oder gar nicht. Hat auch nix mit ArmA an sich zu tun, sondern mit der Graka bzw. dem Treiber.
Da lässt sich nix dran drehen.

edit: Anti-aliasing - Wikipedia, the free encyclopedia
__________________

burns ist offline   Mit Zitat antworten
Alt 28.08.2008, 15:19   #12 (permalink)
Newbie
 
Benutzerbild von Hellfreeza
 
Registriert seit: 24.01.2008
Ort: Thalheim bei Wels - Austria
Alter: 35
Beiträge: 44
Hellfreeza eine Nachricht über ICQ schicken
Standard

ich hab den aktuellsten treiber von nvidia installiert.

Nur was ich nicht verstehe, jetzt habe ich doch eine sehr gute Graka und die packt es dann nicht. Schade.
ArmA ist der Grund, warum ich mir diese Karte zugelegt habe.

andere Frage: welche karte müsste ich mir kaufen, um AA auch mit meinen settings auf "Normal" oder "High" zu stellen ohne das ich Performenceeinbrüche bekomme??
Hellfreeza ist offline   Mit Zitat antworten
Alt 28.08.2008, 15:26   #13 (permalink)
10 Jahre hx3
5000 Beiträge
 
Benutzerbild von Duke49th
 
Registriert seit: 06.10.2006
Ort: Manila
Alter: 38
Beiträge: 7.959
Standard

Ne ATI Sollte mit einer 4870er bestens laufen

Nee, keine Ahnung. Entweder haben die von Nvidia es bei der Karte versaut oder es generell das AA nicht so optimal hinbekommen wie bei ATI.

Aber was Du noch testen kannst ist, die Schattendetails auf mittel zu stellen. Zwischen niedrig/mittel und hoch/sehr hoch ist der Unterschied in der Art der Schattendarstellung, nicht in der Qualität. Vielleicht kommt Deine Graka ja mit der Darstellungsart von mittel besser zurecht.
__________________

Intel Board | Intel i3 2100 |Dell 8GB DDR-3 1600 | AMD HD7770 1GB | Creative Audigy EX Platinum | TrackIR 5 | Win 10 Pro x64 | Linux Mint x64 | Coolermaster Modular 620W
Duke49th ist offline   Mit Zitat antworten
Alt 28.08.2008, 15:45   #14 (permalink)
Imperator fori nocturni - This sucks more than anything that has ever sucked before 10 Jahre hx3
20.000 Beiträge
 
Benutzerbild von burns
 
Registriert seit: 13.04.2003
Ort: Monerica
Alter: 36
Beiträge: 32.340
Standard

Mit Schatten wär ich vorsichtig. Aufgrund der guten Shader Architektur (hoffentlich red ich keinen scheiss..) einiger Karten,
ist es schon vorgekommen das bei einigen die Schatten auf Very High weniger Performance kosten als in niedrigeren Einstellungen. Bei mir z.B.

It´s not a bug
__________________

burns ist offline   Mit Zitat antworten
Alt 28.08.2008, 15:54   #15 (permalink)
500 Beiträge
 
Benutzerbild von Mr.g-c
 
Registriert seit: 18.12.2006
Ort: Frankfurt->Darmstadt->Dieburg
Beiträge: 687
Mr.g-c eine Nachricht über ICQ schicken Mr.g-c eine Nachricht über MSN schicken
Standard

Zitat von burns Beitrag anzeigen

Normalerweise steht in den ArmA Optionen die höchstmögliche Auflösung zur Auswahl.
Bei TFT´s ist aber aus irgendeinem Grund immer sinnvoll Games in der "nativen" Auflösung des TFT zu fahren - in meinem Fall ist das 1280x1024 (kein Widescreen).

Ja, das liegt daran das die möglichkeit der Interpolation bei TFTs ziemlich suckt... das ist bauartbedingt und wird wohl nie gefixt werden. Wenn die Auflösung zu niedrig ist sieht man das daran das das Bild ganz "milchig-trüb" und unscharf wird.
Wobei gute Panels das realtiv glimpflich wegbügeln können. Zb. mein neuer 24" P-MVA (mit 1920x1200 nativ) sieht bei Arma auch noch in 1440x900 ganz gut aus... richtig geil dann auf 1680x1050 (da kann man dann bereits AA ausschalten) und der Knüller aber auf 1920x1200 - wobei da eine grafikkarte mit sehr viel schnellem Speicher benötigt wird (512MB+, bei aktiviertem AA in der Auflösung sogar bereits ~1GB).

Zitat:

...Mit Schatten wär ich vorsichtig. Aufgrund der guten Shader Architektur (hoffentlich red ich keinen scheiss..) einiger Karten,
ist es schon vorgekommen das bei einigen die Schatten auf Very High weniger Performance kosten als in niedrigeren Einstellungen. Bei mir z.B.

Maruk hatte mir die Frage mal beantwortet und gesagt das alle schatten-settings unter "High" von der CPU berechnet werden und alle ab "High" von der grafikkarte. So kann es pasieren (und ist es passiert) das bei heute gar nur "mittleren" Karten (wie meiner GF9600GT) Schatten auf "High" oder "Very-High" meine FPS um 5FPS verbessert hat.

Geändert von Mr.g-c (28.08.2008 um 15:58 Uhr).
Mr.g-c ist offline   Mit Zitat antworten
Alt 28.08.2008, 16:05   #16 (permalink)
10 Jahre hx3
5000 Beiträge
 
Benutzerbild von Duke49th
 
Registriert seit: 06.10.2006
Ort: Manila
Alter: 38
Beiträge: 7.959
Standard

Zitat von Mr.g-c Beitrag anzeigen

Maruk hatte mir die Frage mal beantwortet und gesagt das alle schatten-settings unter "High" von der CPU berechnet werden und alle ab "High" von der grafikkarte. So kann es pasieren (und ist es passiert) das bei heute gar nur "mittleren" Karten (wie meiner GF9600GT) Schatten auf "High" oder "Very-High" meine FPS um 5FPS verbessert hat.

Seeehr Interessant. Bei high/very high fehlen mir Gesichtstesxturen und ein paar andere Und bei low/very low ruckelts zu arg
(Könnte am Treiber liegen...ist fps mäßig aber trotzdem der Beste..darum bleib ich bei ihm)

Konsequenz: Schatten aus.

@Monitor: TFT sucks! CRT rulez! Kanns garnicht oft genug sagen
__________________

Intel Board | Intel i3 2100 |Dell 8GB DDR-3 1600 | AMD HD7770 1GB | Creative Audigy EX Platinum | TrackIR 5 | Win 10 Pro x64 | Linux Mint x64 | Coolermaster Modular 620W
Duke49th ist offline   Mit Zitat antworten
Alt 28.08.2008, 16:08   #17 (permalink)
Imperator fori nocturni - This sucks more than anything that has ever sucked before 10 Jahre hx3
20.000 Beiträge
 
Benutzerbild von burns
 
Registriert seit: 13.04.2003
Ort: Monerica
Alter: 36
Beiträge: 32.340
Standard

Zitat von Alexduke Beitrag anzeigen

Seeehr Interessant. Bei high/very high fehlen mir Gesichtstesxturen und ein paar andere Und bei low/very low ruckelts zu arg
(Könnte am Treiber liegen...ist fps mäßig aber trotzdem der Beste..darum bleib ich bei ihm)

Konsequenz: Schatten aus.


Soviel zur hochgelobten ATI 4870
__________________

burns ist offline   Mit Zitat antworten
Alt 28.08.2008, 16:10   #18 (permalink)
10 Jahre hx3
5000 Beiträge
 
Benutzerbild von Duke49th
 
Registriert seit: 06.10.2006
Ort: Manila
Alter: 38
Beiträge: 7.959
Standard

Zitat von burns Beitrag anzeigen

Soviel zur hochgelobten ATI 4870

Ich hab ne AGP x1950 Und es liegt entweder am Treiber oder die Karte hat nen Hau wech. Mit 1.08 und altem Treiber gings damals noch
__________________

Intel Board | Intel i3 2100 |Dell 8GB DDR-3 1600 | AMD HD7770 1GB | Creative Audigy EX Platinum | TrackIR 5 | Win 10 Pro x64 | Linux Mint x64 | Coolermaster Modular 620W
Duke49th ist offline   Mit Zitat antworten
Alt 28.08.2008, 16:13   #19 (permalink)
Imperator fori nocturni - This sucks more than anything that has ever sucked before 10 Jahre hx3
20.000 Beiträge
 
Benutzerbild von burns
 
Registriert seit: 13.04.2003
Ort: Monerica
Alter: 36
Beiträge: 32.340
Standard

Axo is das, dann sag ich es liegt an AGP
Der Unterschied ist wirklich verblüffend


edit: Hatte mit meiner 7800 AGP auch immer Schatten aus. Armes Ding...
__________________

burns ist offline   Mit Zitat antworten
Antwort


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
[Tipp] mehr Performance Dodger Veteranen Stammtisch 126 25.12.2006 20:36
Extrem schlechte Performance Dawnhunter Hilfe 5 12.12.2006 22:18
dxdll performance bei reflektionen Dr.Pulp Hilfe 6 02.09.2005 08:58
Massive Performance Probleme Lonely Hilfe 7 30.04.2005 18:23


Kontakt - HX3.de - Archiv - Nach oben

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias



SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116