Armed-Assault.de Twitter


Multiplayer Community Clans, Spieleabende, Werbung & Szene

Antwort
 
Themen-Optionen Ansicht
Alt 23.01.2008, 11:06   #1 (permalink)
Newbie
 
Registriert seit: 11.11.2005
Beiträge: 14
Standard Dedicated Server

Hallo zusammen,

wir wollen demnächst eine kleine ArmA Lan machen und ich denke das es sich auf jedenfall lohnt einen dedicated Server dazu zu nehmen. (Mein Notebook mit Turion X2 und 2gb Ram müsste das ja packen)

Meine Frage:

Wo bekomm ich den dedicated Server her?

finde den nirgends zum download
Hotstepper ist offline   Mit Zitat antworten
Alt 23.01.2008, 11:19   #2 (permalink)
10 Jahre hx3
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von Lester
 
Registriert seit: 26.11.2006
Ort: Kiel, S-H
Alter: 51
Beiträge: 3.011
Standard

Die server.exe ist doch immer dabei (zumindest bei den letzten patches)

Ein dedizierter Server ist nichts anderes als ein Rechner auf den keiner spielt, er bruacht sich somit nicht um akustischen oder graphischen Output zu kümmern,
sondern steht voll der Missionsabarbeitung, der KI und dem Datenaustausch zur Verfügung.

Allerdings muß der natürlich auch eine entsprechend guten Datentransfer haben, was aber im LAN nicht so problematisch sein sollte.
Lester ist offline   Mit Zitat antworten
Alt 23.01.2008, 13:28   #3 (permalink)
Newbie
 
Registriert seit: 11.11.2005
Beiträge: 14
Standard

Danke für die Antwort schonmal.

Also ich hab inzischen etwas weiter rumgeschaut, fühle mich aber immernoch ziemlich unwissend.

Arma Versionen haben wir mehr als genug, so denke ich ist das einfachste auf meinen Laptop ArmA zu installieren und das dann als Server zu starten.

Zu testzwecken hab ich das jetzt gerade mal mit der Demo gemacht.

Nach der erweiterung -server startet die auch wunderbar den Server. Wie bring ich dem Mädchen jetzt aber bei welche Mission ich gehostet haben will?

Das Ding ist folgendes. Neben dem üblichen CTF und DM wollen wir auf der Lan (geht drei Tage lang) auch Evolution spielen. Das geht aber nur wenn wir einen dedicated haben, da das zu langwierig ist. So kann man immer wieder joinen und sonst was anderes machen.

Weist du oder ein anderer eine relativ einfache Anleitung wie ich Evolution auf dem Laptop hosten kann?

Wäre super!

Gruß Hotstepper
Hotstepper ist offline   Mit Zitat antworten
Alt 23.01.2008, 14:43   #4 (permalink)
10 Jahre hx3
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von Lester
 
Registriert seit: 26.11.2006
Ort: Kiel, S-H
Alter: 51
Beiträge: 3.011
Standard

Für derart detailierte Informationen steck ich dann doch auch nicht weit genug da drin, ich hab nene eigenen Dedy mit ArmA noch nicht betrieben
Lester ist offline   Mit Zitat antworten
Alt 23.01.2008, 15:23   #5 (permalink)
Newbie
 
Registriert seit: 11.11.2005
Beiträge: 14
Standard

Trotzdem danke. Vieleicht gibts ja noch was von einem anderen Mitglied hier.

Gruß Hotstepper
Hotstepper ist offline   Mit Zitat antworten
Alt 23.01.2008, 17:44   #6 (permalink)
Imperator fori nocturni - This sucks more than anything that has ever sucked before 10 Jahre hx3
20.000 Beiträge
 
Benutzerbild von burns
 
Registriert seit: 13.04.2003
Ort: Monerica
Alter: 36
Beiträge: 32.335
Standard

Wenn ArmA mit Startparameter -server gestartet wird müssen die gewünschten Missionen ganz normal in den Ordner /MpMissions. Darauf sollte der Server dann zurückgreifen.


Beim 'echten' Dedicated Server läufts genauso, bloß das man dort nicht auf die originale ArmA Installation zurückgreifen kann - aber die Ordnerstruktur bleibt dieselbe.
__________________

burns ist offline   Mit Zitat antworten
Alt 24.01.2008, 12:40   #7 (permalink)
50 Beiträge
 
Benutzerbild von jaeger313
 
Registriert seit: 26.11.2006
Beiträge: 55
Standard

Ich kann die Hetzner empfehlen.
jaeger313 ist offline   Mit Zitat antworten
Alt 24.01.2008, 13:58   #8 (permalink)
Newbie
 
Registriert seit: 11.11.2005
Beiträge: 14
Standard

Das ist nett, aber das geht am Problem vorbei.

Das Problem hat sich sowieso inzwischen erledigt. Nach 3 Sunden einlesen läuft der Server unter 1.09 einwandfrei.

Werde den vermutlich nach der Lan Party an unsere 100mbit Leitung am Institut hängen und als public Server laufen lassen. So haben wir alle was davon...

Hat einer von Euch das ArmaTech Tool mal benutzt?

Ist sehr schön, aber am ende will der server nie spieler akzeptieren. Gings da jemandem ähnlich?
Hotstepper ist offline   Mit Zitat antworten
Alt 28.01.2008, 08:45   #9 (permalink)
Newbie
 
Registriert seit: 11.11.2005
Beiträge: 14
Standard

Ärgerlicherweise funktioniert der Server nicht am Instituts-Netz.

Es kommt bei den Clients immer nur "Warten auf Horst".

Weiß einer welche Ports verfügbar sein müssen damit der Server vernünftig läuft?

Am 2302 liegt es nicht, mit 80 gehts auch nicht.
Hotstepper ist offline   Mit Zitat antworten
Alt 30.01.2008, 00:02   #10 (permalink)
Newbie
 
Benutzerbild von C.L.A.N. Martin
 
Registriert seit: 09.01.2008
Beiträge: 4
Standard

Schau mal hier, da steht eigentlich alles was man so wissen muss:
ArmA: Dedicated Server - Bohemia Interactive Community

Und wenn ich schon mal beim schreiben bin: weiss jemand warum die Skripte in vielen Missionen nicht ausgeführt werden, wenn man ´nen Linux Server hat? Und falls es jemand weiss, wärs schön, wenn er mir sagt wie ich das Problem lösen kann.

Geändert von C.L.A.N. Martin (30.01.2008 um 00:05 Uhr).
C.L.A.N. Martin ist offline   Mit Zitat antworten
Alt 15.02.2008, 12:17   #11 (permalink)
Newbie
 
Registriert seit: 28.11.2006
Beiträge: 6
Standard Auch mal ne Frage

Hallo, hab auch mal Fragen zum Dedicated Server. Bei der Version 1.08 hatte ich eine config.cfg Datei und eine Startup.bat Datei. Soweit lief der Server im Lan bei uns. Seit 1.09 läuft es nicht mehr. Auch wenn ich die server.exe aus den beta Ordner starte kommt eine Fehlermeldung so in der Art „ Profiles Pfad Default“.

Wenn ich Arma mit den Startparametern „-server“ starte, läuft es. Aber meine config.cfg ist ja dann nicht mehr enthalten.
Kann mir das mal einer erklären?
Danke stevie
stevie476 ist offline   Mit Zitat antworten
Alt 16.02.2008, 08:22   #12 (permalink)
Newbie
 
Registriert seit: 04.01.2008
Ort: HH
Beiträge: 15
Standard

Wir starten den 1.09 Server u.a. mit diesen Parametern:
Code:
C:\ArmA\beta\arma_server.exe -port=4000 -name=server1 -config=109_privat.cfg -cfg=Profiles\main.cfg -profiles=Profiles -mod=beta
(Das ganze ausgeführt im ArmA-Hauptverz.)
Auf diese Weise legt er Dir das Verzeichnis ...\ArmA\Profiles\ mit der main.cfg, der RPT, den TMPs usw. sowie das Verzeichnis ...\ArmA\Profiles\Users\server1\ mit der server1.ArmaProfile an.
Die 109_privat.cfg liegt dabei ebenfalls im Hauptverz.
Astra ist offline   Mit Zitat antworten
Alt 17.02.2008, 11:32   #13 (permalink)
Newbie
 
Registriert seit: 28.11.2006
Beiträge: 6
Standard

Dank dir, mit den Parametern klappts wieder
stevie476 ist offline   Mit Zitat antworten
Antwort


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Dedicated Server luemmel Multiplayer Community 145 09.06.2010 12:27
FFUR2006 Dedicated LAN SERVER i-mike Multiplayer 1 30.11.2006 23:30


Kontakt - HX3.de - Archiv - Nach oben

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias



SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116