Armed-Assault.de Twitter
Thema geschlossen
 
Themen-Optionen Ansicht
Alt 01.02.2011, 20:35   #1 (permalink)
500 Beiträge
 
Benutzerbild von Clawhammer
 
Registriert seit: 07.01.2008
Alter: 30
Beiträge: 635
Clawhammer eine Nachricht über ICQ schicken
Standard Probleme mit Ubuntu ArmA Linux Dedicated Server und ACE

Moin zusammen,

wir haben ein intressantes Problem mit unserem Ubuntu Dedicated Server.


Daten:
ArmA2 OA 1.57
A2OA Server auf Linux Server Beta 1.57.77737
ACE 1.8 Stable

Das Problem ist folgendes, bei den meisten Maps die wir versuchen stürzt der Server ab seit ACE 1.8.

Es taucht diese Fehlermeldung auf:
Code:
Cannot open file  'MPMissions\wf_64_ace_18_warfarebe_12.chernarus.pbo'<br />  111/01/01, 19:41:05 Critical:Destroying running thread!
deaktivieren wir ACE1.8 oder patchen zurück auf ACE1.7 klapt alles tadelos.

Mission: Link

Das verrückte daran, missionen die gerade funktionierten gehen beim nächsten reboot dann nicht.

Der nächste komische Fehler dabei ist, es werden nicht immer alle missionen angezeigt, auch hier sind es mal die einen dann die anderen.

Was auch zum löschen der Missionen führt ist der Login als Admin. Direkt im anschluss fehlen dann auch eine größere anzahl in der Auswahl.

Ein sehr kurioses problem, vorallem da ohne ACE1.8 oder mit ACE1.7 alles 1A funktioniert.

Wir haben jetzt ACE1.8 über 3 verschiedene Quellen und verschiedenen Methoden hochgeladen, die files sind in Ordnung.


UPDATE:
Unser Admin ist der Meinung das das Problem eventuell an dem relativen Pfaden die in ACE angegeben sind liegen könnte.

Auf Windows ebene wäre dieser Pfad ja richtig:
MPMissions\wf_64_ace_18_warfarebe_12.chernarus.pbo

Unter Linux muss ja der \ anders herum sein:
MPMissions/wf_64_ace_18_warfarebe_12.chernarus.pbo


Hoffe jemand hier kann uns weiterhelfen

Besten dank!

Mfg
Clawhammer
__________________
Clawhammer ist offline  
Alt 02.02.2011, 12:45   #2 (permalink)
His Awesomeness!
10 Jahre hx3
5000 Beiträge
 
Benutzerbild von flickflack
 
Registriert seit: 25.07.2006
Ort: Regnum Borussiae
Beiträge: 9.282
Standard

Dass Missionen mal liefen und mal nicht, und man nach Auswahl, oder dem Spielstart wieder in die Missionauswahl zurückgefallen ist, ist glaub ich ein bemerkenswerter, aber zumindest für mich unerklärbarer Effekt - seit 2001/2.

Nimm Dir doch mal die Win-Server.exe und teste vllt mal mit Wine durch. Die Leistungseinbußen sind zu verschmerzen (gilt für OFP 1.96c und ArmA 1.x). Aber wenn's dann läuft, könnte das Slashproblem, das Problem sein - lol. Oder Du änderst mal die Mod in diesem einen reproduzierbaren Fall, falls das ACE2-Team nicht genau so etwas untersagt hat.

Eine Hilfe war's sicher nicht, aber vllt fühlt sich wer animiert mitzudenken
flickflack ist offline  
Alt 02.02.2011, 13:04   #3 (permalink)
500 Beiträge
 
Benutzerbild von Clawhammer
 
Registriert seit: 07.01.2008
Alter: 30
Beiträge: 635
Clawhammer eine Nachricht über ICQ schicken
Standard

Ja das Problem ist, der Server ist eine minimal Installation. Da wird kein wine laufen Voralpen ohne einem x Server.

Und ac e mal eben umschreiben dürfte auch ziemlich schwer werden.
__________________

Geändert von Clawhammer (02.02.2011 um 13:06 Uhr).
Clawhammer ist offline  
Alt 02.02.2011, 13:43   #4 (permalink)
His Awesomeness!
10 Jahre hx3
5000 Beiträge
 
Benutzerbild von flickflack
 
Registriert seit: 25.07.2006
Ort: Regnum Borussiae
Beiträge: 9.282
Standard

"GraphicsDriver" = "x11drv|ttydrv".

Ging unter OFP und ArmA wunderbar ohne X auf unserem schlanken Debian. Hatte allerdings dann tatsächlich ein oder zwei Mal den Hänger, weil ne Win.DLL explodierte und WINE den error output nicht auf eine TTY lenken konnte. Nagut, Neustart (WINE) half. Output liess sich auch unterdrücken (wegen GUI-Kram) - wenn ich nur noch das Shellskript finden würde...


Edith: Hab mal unseren Admin gefragt ob er das Skript noch rumliegen hat, allerdings ist er sich nicht sicher, ob das alles nicht auch ohne TTY-Treiber und dennoch via Terminal ging.

Zitat:

[...]
wine ${SERVER}/config=${CONFIG} -port=${PORT} -netlog -name=${ADMIN} -mod=${MODS} 2>&1 | tee -a server.log | grep --line-buffered "cannot set text" | sed -u -e 's/.*fixme.*set text "\(.*\)\\r\\n" of other process window (nil)/\1/'>> log.${PORT}.txt
[...]

flickflack ist offline  
Alt 21.02.2011, 08:23   #5 (permalink)
Newbie
 
Benutzerbild von Raptile4ever
 
Registriert seit: 20.03.2008
Ort: Karlsruhe
Alter: 33
Beiträge: 46
Raptile4ever eine Nachricht über ICQ schicken Raptile4ever eine Nachricht über MSN schicken
Standard

Hallo flickflack,

könntest du mir zeigen was Du unter der einstellung (arma2server) -mod={MODS} hast, ich versuch auch seit tagen die Mods wie Vopsound, CBA, HARCP zum laufen zu kriegen.

Danke.

Raptile4ever ist offline  
Alt 21.02.2011, 08:25   #6 (permalink)
500 Beiträge
 
Benutzerbild von Clawhammer
 
Registriert seit: 07.01.2008
Alter: 30
Beiträge: 635
Clawhammer eine Nachricht über ICQ schicken
Standard

Ah gut das du mich erinnerst, das Problem ist gelöst. Wir haben den ACE_SM Mod rausgeworfen nun funktioniert der Server wieder oO.
__________________
Clawhammer ist offline  
Alt 21.02.2011, 09:09   #7 (permalink)
His Awesomeness!
10 Jahre hx3
5000 Beiträge
 
Benutzerbild von flickflack
 
Registriert seit: 25.07.2006
Ort: Regnum Borussiae
Beiträge: 9.282
Standard

Zitat von Raptile4ever Beitrag anzeigen

Hallo flickflack,

könntest du mir zeigen was Du unter der einstellung (arma2server) -mod={MODS} hast, ich versuch auch seit tagen die Mods wie Vopsound, CBA, HARCP zum laufen zu kriegen.

Danke.

Nukular, hier die Variablen-Deklaration:

Zitat:

OFP_DIR=/ofp-win/ofp
CONFIG=${OFP_DIR}/res.cfg
PORT=2302
LOGFILE=${OFP_DIR}/log.${PORT}.txt
SERVER=${OFP_DIR}/OFPR_Server.exe
MODS="@www.winterofp.com;@bw;@bas;@cti"

Aber bitte beachten, dat ging mit OFP:CWC/R und ArmA: Armed-Assault unter WINE + WIN32-Server. Ka ob Arma2 oder OA da jetzt rumzicken. Bei den Mods sollteste vllt auf Effekt- und Soundmods verzichten, kann mir nicht vorstellen, dass die auf dem Server liegen müssen. Bei CBA bspw. sieht's naturgemäss etwas anders aus
flickflack ist offline  
Alt 21.02.2011, 10:26   #8 (permalink)
Newbie
 
Benutzerbild von Raptile4ever
 
Registriert seit: 20.03.2008
Ort: Karlsruhe
Alter: 33
Beiträge: 46
Raptile4ever eine Nachricht über ICQ schicken Raptile4ever eine Nachricht über MSN schicken
Standard

Hi danke für das zeigen habe das nun auch mal unter meine Linux servers eingestellt.

ArmA 2:
Zitat:

ARMA_DIR=/home/****/arma2
CONFIG=a2server.cfg
PORT=4100
MODS="@vopsounda2;@cba;@harcp;"
PIDFILE=$************_DIR}/${PORT}.pid
RUNFILE=$************_DIR}/${PORT}.run
LOGFILE=$************_DIR}/log.${PORT}.txt
SERVER=$************_DIR}/server
OTHERPARAMS=-cpucount=2

ArmA 2 OA:
Zitat:

ARMA_DIR=/home/****/arma2oa
CONFIG=a2oaserver.cfg
PORT=4200
MODS="@vopsounda2oa;"
PIDFILE=$************_DIR}/${PORT}.pid
RUNFILE=$************_DIR}/${PORT}.run
LOGFILE=$************_DIR}/log.${PORT}.txt
SERVER=$************_DIR}/server
OTHERPARAMS=-cpucount=2

ich hoffe das man nun drauf zocken kann, ohne das man ständig vom server fliegt oder der server abschmiert oder so, weil jedes mal nach 1-2 min zocken verbindung weg ist.

ich hatte unter MODS= diese "" nicht drin gehabt nun hab ich sie vorhanden so wie du

so bin mal testen.
Raptile4ever ist offline  
Alt 21.02.2011, 10:35   #9 (permalink)
Newbie
 
Benutzerbild von Raptile4ever
 
Registriert seit: 20.03.2008
Ort: Karlsruhe
Alter: 33
Beiträge: 46
Raptile4ever eine Nachricht über ICQ schicken Raptile4ever eine Nachricht über MSN schicken
Standard

funktioniert auch nicht man fliegt immer wieder vom Linux server AmrA 2 runter...

wäre nett wenn das jemand bestädigen kann ob es am Server liegt:

Filter: KSK <- BattleBase #2 connecten und abwarten ob verbindung weg ist oder nicht...

Werde auch gleich die sachen mal hier rein posten vllt findest Du den fehler der das ständig bei mir verursacht.
Raptile4ever ist offline  
Alt 21.02.2011, 10:40   #10 (permalink)
Newbie
 
Benutzerbild von Raptile4ever
 
Registriert seit: 20.03.2008
Ort: Karlsruhe
Alter: 33
Beiträge: 46
Raptile4ever eine Nachricht über ICQ schicken Raptile4ever eine Nachricht über MSN schicken
Standard

a2server.cfg

Zitat:

//
// server.cfg
//

// Name des Servers, wie er in der Server-Lite angezeigt wird
hostname = "[KSK-D] ArmA2 BattleBase #2 - www.KSK-Delta.de";
// Kennwort, um auf den Server zu connecten
password = "";
// Adminpasswort
passwordAdmin = "***********";

// IP fuer die ServerListe bei Gamespy
//reportingIP = "arma2oapc.master.gamespy.com";
// Das ist die IP fuer ArmA2
reportingIP = "arma2pc.master.gamespy.com";
// Das ist die Standardeinstellung fuer ArmA
//reportingIP = "armedass.master.gamespy.com";

// Log Datei
logFile = "arma2_server.log";

// Zeitintervall zwischen den Nachrichten in Sekunden
modIntervall = 4;

// Willkommensnachricht (Message of the Day)
// Kann mehrere Linien enthalten, die von Kommata getrennt sind
// Leere Nachrichten "" werden nicht angezeigt, aber erhoehen das Intervall der Anzeige

motd[] = {
"Willkommen auf unserem [KSK-D] ArmA2 BattleBase #2 - Server",
"",
"Besuche doch unsere Webseite => www.KSK-Delta.de",
"",
"Besucht uns im Teamspeak3 => ts.gamerzentrum.de:9987",
"",
"Wir suchen noch Mitglieder ab 18 Jahre => Join us",
"",
"Vote a Player to Admin with: #vote admin (nickname)",
"",
"Regel / Rule => Sprache / Language => German / English"
};

// Joining Regeln
// Maximale Anzahl von Spielern
maxPlayers = 32;
// Doppelte IDs werden gekickt
kickduplicate = 1;
// Signaturen werden auf dem Client geprueft
verifySignatures = 0;
// Gleicher MOD 1= ja, 0= nein. Nicht mehr aktuell
//equalModRequired = 1;

//Daten werden auf Veraenderungen geprueft. Nicht mehr aktuell
//checkfiles[] = {
// "dta\bin.pbo",
// "a10\config.bin"
//};

// Voting Einstellungen
// Prozent, die benoetigt werden ein Vote zu bestaetigen. Hier 33%
voteThreshold = 0.33;
// Soviele Spieler muessen gejoint sein, damit ein Vote moeglich ist
voteMissionPlayers = 1;

// InGame Einstellungen
// Voice Over Net wird an- oder abgeschaltet. 1=aus, 0=an.
disableVoN = 1;
// Stimmqualitaet 1-10. 3 ist Standard
vonCodecQuality = 0;
// Dauerhafte Map 1= ja, 0=nein
persistent = 1;

// Script Einstellungen
// Serverseitige Scripting koennen aufgerufen werden.
onUserConnected = "";
onUserDisconnected = "";
doubleIdDetected = "kick (_this select 0)";
regularCheck = "";

// Einige ArmA spezifische Einstellungen
// User mit unsignierten Daten werden gekickt
onUnsignedData = "kick (_this select 0)";
// User mit gehackten Daten werden gebannt
onHackedData = "ban (_this select 0)";
// Daten mit richtiger Signatur, aber mit aelterer Version entdeckt
onDifferentData = "";
// Server mit BattlEye starten 1= ja, 0= nein
battleye = 1;

arma2.cfg
Zitat:

language="English";
adapter=-1;
3D_Performance=1;
Resolution_Bpp=32;

Startscript: arma2server
Zitat:

#!/bin/bash
#
# armaserver: ArmA 2 Linux Dedicated Server Control Script
# (c) 2010 BIStudio
# ArmA 2 binary version must be 1.04 or later
#

#================================================= ======================
#======== CONFIGURATION PARAMETERS ========
#======== MUST BE EDITED MANUALLY TO FIT YOUR SYSTEM PARAMETERS ========
#================================================= ======================
ARMA_DIR=/home/******/arma2
CONFIG=a2server.cfg
PORT=4100
MODS="@vopsounda2;@cba;@harp;"
PIDFILE=$************_DIR}/${PORT}.pid
RUNFILE=$************_DIR}/${PORT}.run
LOGFILE=$************_DIR}/log.${PORT}.txt
SERVER=$************_DIR}/server
OTHERPARAMS=-cpucount=2
#================================================= ======================
ulimit -c 1000000

case "$1" in


start)
if [ -f ${RUNFILE} ]; then
$0 stop
fi
echo "Starting ArmA 2 server..."
# file to mark we want server running...
echo "go" >${RUNFILE}
# launch the background watchdog process to run the server
nohup </dev/null >/dev/null $0 watchdog &
;;

stop)
echo "Stopping ArmA 2 server..."
if [ -f ${RUNFILE} ]; then
# ask watcher process to exit by deleting its runfile...
rm -f ${RUNFILE}
fi
# and terminate ArmA 2 server process
if [ -f ${PIDFILE} ]; then
kill -TERM $(< ${PIDFILE})
if [ -f ${PIDFILE} ]; then
rm -f ${PIDFILE}
fi
fi
;;


status)
if [ -f ${RUNFILE} ]; then
echo "Server should be running..."
else
echo "Server should not be running..."
fi
if [ -f ${PIDFILE} ]; then
PID=$(< ${PIDFILE})
echo "PID file exists (PID=${PID})..."
if [ -f /proc/${PID}/cmdline ]; then
echo "Server process seems to be running..."
fi
fi
;;


check)
echo -n "ArmA 2 directory: $************_DIR} "
if [ -d $************_DIR} ]; then
echo "OK"
else
echo "MISSING!"
fi

echo -n "Server executable: ${SERVER} "
if [ -x ${SERVER} ]; then
echo "OK"
else
echo "ERROR!"
fi

echo "Port number: ${PORT}"

echo -n "Config file: ${CONFIG} "
if [ -f ${CONFIG} ]; then
echo "OK"
else
echo "MISSING!"
fi

echo "PID file: ${PIDFILE}"
echo "RUN file: ${RUNFILE}"

;;

restart)
$0 stop
$0 start
;;

watchdog)
# this is a background watchdog process. Do not start directly
while [ -f ${RUNFILE} ]; do
# launch the server...
cd $************_DIR}
echo >>${LOGFILE} "WATCHDOG ($$): [$(date)] Starting server (port ${PORT})..."
${SERVER} >>${LOGFILE} 2>&1 -server -config=${CONFIG} -port=${PORT} -netlog -mod=${MODS} -pid=${PIDFILE} ${OTHERPARAMS}
if [ -f ${RUNFILE} ]; then
echo >>${LOGFILE} "WATCHDOG ($$): [$(date)] Server died, waiting to restart..."
sleep 5s
else
echo >>${LOGFILE} "WATCHDOG ($$): [$(date)] Server shutdown intentional, watchdog terminating"
fi
done
;;
*)
echo "$0 (start|stop|restart|status|check)"
;;
esac

Raptile4ever ist offline  
Alt 21.02.2011, 10:42   #11 (permalink)
Newbie
 
Benutzerbild von Raptile4ever
 
Registriert seit: 20.03.2008
Ort: Karlsruhe
Alter: 33
Beiträge: 46
Raptile4ever eine Nachricht über ICQ schicken Raptile4ever eine Nachricht über MSN schicken
Standard

Ach sorry, die 2 Server laufen auf Linux Debian 64Bit system.
Wenn Du dir mal alles direkt anschauen möchtest wenn Du zeit zum helfen hast würd ich mich auch freuen, adde mich dann einfach bei intresse im icq. Am sonsten werde ich noch das machen was Du im forum mir sagst und feedback geben.

Geändert von Raptile4ever (21.02.2011 um 10:44 Uhr).
Raptile4ever ist offline  
Alt 21.02.2011, 11:01   #12 (permalink)
His Awesomeness!
10 Jahre hx3
5000 Beiträge
 
Benutzerbild von flickflack
 
Registriert seit: 25.07.2006
Ort: Regnum Borussiae
Beiträge: 9.282
Standard

Sicher das sämtliche Dateinamen kleingeschrieben sind bei dem was du lädst? Was sagen die Logfiles? Und was ist genau das Problem - hab ich vermutlich überlesen? Das der Server nicht startet, oder das er startet und wenn man connected man wieder gekickt wird? Hängt nen IpTables oder sowas davor und filtert vllt fröhlich? Lade mal nur ein Mod, @CBA, und sag mal wie sich die Büxe dann verhält.
flickflack ist offline  
Alt 21.02.2011, 11:21   #13 (permalink)
Newbie
 
Benutzerbild von Raptile4ever
 
Registriert seit: 20.03.2008
Ort: Karlsruhe
Alter: 33
Beiträge: 46
Raptile4ever eine Nachricht über ICQ schicken Raptile4ever eine Nachricht über MSN schicken
Standard

Leider passiert das mit oder ohne Mods, der Server startet also fährt hoch man connectet drauf macht ne Mission rein startet diese. Aber entweder im Briefing oder InGame wenn man grad nen Meter oder so laufen tut (10sec Verbindung unterbrochen) und zählt immer höhr. Danach geht man in die InGame Serverliste wieder Aktuellisiert paar mal dann ist der Server wieder da in der Liste und hat sogar die Mission noch geladen, also der Server ist im Spiel und nicht Erstellen.

log.4100
Zitat:

WATCHDOG (6474): [Mo 21. Feb 12:28:42 CET 2011] Starting server (port 4100)...
Item str_disp_server_control listed twice
12:28:44 Dedicated host created.
12:28:45 BattlEye Server: Initialized (v1.115)
12:28:45 Host identity created.
ArmA 2 Console version 1.08 : port 4100 - Sockets
12:35:52 RaPiD uses modified data file - CA;@vopsounda2;@cba;@harcp;@warfx;
12:35:52 Player RaPiD connecting.
12:35:57 Player RaPiD connected (id=3210370).
"############################# #############################"
[18566,435.378,0,"Executing Dom description.ext"]
[18566,435.428,0,"Dom description.ext processed"]
"############################# #############################"
[18566,435.544,0,"Executing Dom description.ext"]
[18566,435.59,0,"Dom description.ext processed"]
"############################# #############################"
[18566,435.911,0,"Executing Dom description.ext"]
[18566,435.956,0,"Dom description.ext processed"]
"############################# #############################"
[18566,436.266,0,"Executing Dom description.ext"]
[18566,436.299,0,"Dom description.ext processed"]
File description.ext, line 8: '.titleParam1': Missing ';' at the end of line
"############################# #############################"
[18566,436.633,0,"Executing Dom description.ext"]
[18566,436.679,0,"Dom description.ext processed"]
File description.ext, line 9: '.titleParam1': Missing ';' at the end of line
"############################# #############################"
[18566,437.268,0,"Executing Dom description.ext"]
[18566,437.296,0,"Dom description.ext processed"]
"############################# #############################"
[18566,437.779,0,"Executing Dom description.ext"]
[18566,437.805,0,"Dom description.ext processed"]
"############################# #############################"
[18566,438.186,0,"Executing Dom description.ext"]
[18566,438.212,0,"Dom description.ext processed"]
12:36:03 Admin RaPiD logged in.
"############################# #############################"
[18682,441.427,0,"Executing Dom description.ext"]
[18682,441.458,0,"Dom description.ext processed"]
"############################# #############################"
[18682,441.553,0,"Executing Dom description.ext"]
[18682,441.582,0,"Dom description.ext processed"]
"############################# #############################"
[18682,441.829,0,"Executing Dom description.ext"]
[18682,441.857,0,"Dom description.ext processed"]
"############################# #############################"
[18682,442.102,0,"Executing Dom description.ext"]
[18682,442.13,0,"Dom description.ext processed"]
File description.ext, line 8: '.titleParam1': Missing ';' at the end of line
"############################# #############################"
[18682,442.382,0,"Executing Dom description.ext"]
[18682,442.409,0,"Dom description.ext processed"]
File description.ext, line 9: '.titleParam1': Missing ';' at the end of line
"############################# #############################"
[18682,442.931,0,"Executing Dom description.ext"]
[18682,442.983,0,"Dom description.ext processed"]
"############################# #############################"
[18682,443.634,0,"Executing Dom description.ext"]
[18682,443.676,0,"Dom description.ext processed"]
"############################# #############################"
[18682,444.075,0,"Executing Dom description.ext"]
[18682,444.108,0,"Dom description.ext processed"]
12:36:11 Mission DM,AndersunGunship,Airport-C5- read from bank.
12:36:25 Roles assigned.
12:36:25 Reading mission ...
Warning: looped for animation: ca\wheeled\data\anim\uaz_cargo01_v0.rtm differs (looped now 0)! MoveName: kia_uaz_cargo02
Warning: looped for animation: ca\wheeled\data\anim\uaz_cargo01_v0.rtm differs (looped now 1)! MoveName: uaz_cargo02
12:36:32 Mission read.
12:38:00 BattlEye Server: Player #0 RaPiD (78.43.252.8:63163) - GUID: d5e0e34ebb5b005d8cb939ef57a7c717
12:38:00 Game started.
Server: Update of object 2:255 arrived from nonowner
Music intro not found
Error in expression <_camera camsettarget ver>
Error position: <ver>
Error Undefined variable in expression: ver
Music intro not found
Error in expression <_camera camsettarget ver>
Error position: <ver>
Error Undefined variable in expression: ver
Error in expression <_camera camsettarget k0_1>
Error position: <k0_1>
Error Undefined variable in expression: k0_1
Error in expression <_camera camsettarget k>
Error position: <k>
Error Undefined variable in expression: k
Error in expression <_camera camsettarget k0_1>
Error position: <k0_1>
Error Undefined variable in expression: k0_1
Error in expression <_camera camsettarget k>
Error position: <k>
Error Undefined variable in expression: k
Server: Object 3:1 not found (message 121)
12:38:44 Player RaPiD kicked off by BattlEye: Client not responding
12:38:44 Player RaPiD disconnected.
12:38:44 Admin RaPiD logged out.
Client: Remote object 2:254 not found
Client: Remote object 2:255 not found
Client: Remote object 2:256 not found

Also wie gesagt ob mit oder ohne irgend welche Mods oder egal welche Mission man rein macht das passiert immer wieder aufs neue.

Geändert von Raptile4ever (21.02.2011 um 11:25 Uhr).
Raptile4ever ist offline  
Alt 21.02.2011, 11:52   #14 (permalink)
His Awesomeness!
10 Jahre hx3
5000 Beiträge
 
Benutzerbild von flickflack
 
Registriert seit: 25.07.2006
Ort: Regnum Borussiae
Beiträge: 9.282
Standard

Also mal unabhängig von diesen ganzen wüsten Fehlermeldungen aus der Mission oder Addons, oder was weiss ich,

Zitat:

Server: Object 3:1 not found (message 121)
12:38:44 Player RaPiD kicked off by BattlEye: Client not responding
12:38:44 Player RaPiD disconnected.
12:38:44 Admin RaPiD logged out.
Client: Remote object 2:254 not found
Client: Remote object 2:255 not found
Client: Remote object 2:256 not found

Keine Ahnung was "Object not found" zu bedeuten hat, oder ob es im Zusammenhang mit dem Netzwerk steht, aber es beschleicht mich der Verdacht, dass es iwi ein Netzwerkproblem ist (wegen mir auch entfernt). Kann das sein?! Ich komme nur drauf, weil in dem Zusammenhang auch BattlEye meint, du würdest nicht mehr reagieren?! Welches Log ist das jetzt? müsste nen {PORT}.log geben und nen net.log.

Edith: Wenns ein direktes Serverproblem wäre, würde der vermutlich crashen. Nen Test zu zweit wäre interessant:

# fliegt man immer in der selben Situation/ an der selben Stelle
# bleibt der Server tatsächlich online

Ansonsten kann ich leider auch nur raten - von hier aus.
flickflack ist offline  
Alt 21.02.2011, 12:01   #15 (permalink)
Newbie
 
Benutzerbild von Raptile4ever
 
Registriert seit: 20.03.2008
Ort: Karlsruhe
Alter: 33
Beiträge: 46
Raptile4ever eine Nachricht über ICQ schicken Raptile4ever eine Nachricht über MSN schicken
Standard

log.4100

[... GANZ VIELE LOGS ...]

geändert von Flicki
Raptile4ever ist offline  
Alt 21.02.2011, 12:04   #16 (permalink)
His Awesomeness!
10 Jahre hx3
5000 Beiträge
 
Benutzerbild von flickflack
 
Registriert seit: 25.07.2006
Ort: Regnum Borussiae
Beiträge: 9.282
Standard

Auch im Zweiten ist immer BattlEye für die Kicks zuständig. Schalte das mal ab und teste mal die Situation ohne.
flickflack ist offline  
Alt 21.02.2011, 12:17   #17 (permalink)
Newbie
 
Benutzerbild von Raptile4ever
 
Registriert seit: 20.03.2008
Ort: Karlsruhe
Alter: 33
Beiträge: 46
Raptile4ever eine Nachricht über ICQ schicken Raptile4ever eine Nachricht über MSN schicken
Standard

Habs eben getestet ohne BattlEye (BattlEye=0 leider fliegt ich auch wieder oder der Server hier ist mal die log erneut.

log.4100
[...]
338.300: Ch(4):close
338.300: Ch(4):~(0,0,0,0,0)
338.304: 14:19:03 Player RaPiD disconnected.
338.304: 14:19:03 Admin RaPiD logged out.
341.293: Ch(0):st(250,250,0,250,250,0,0,3,0/0,0,-1.00,0/0,0,-1.00,0,0)
341.766: Ch(1):st(250,250,0,250,250,0,0,3,0/0,0,-1.00,0/0,0,-1.00,0,0)
357.382: Ch(0):st(250,250,0,250,250,0,0,3,0/0,0,-1.00,0/0,0,-1.00,0,0)
357.991: Ch(1):st(250,250,0,250,250,0,0,3,0/0,0,-1.00,0/0,0,-1.00,0,0)
373.466: Ch(0):st(250,250,0,250,250,0,0,3,0/0,0,-1.00,0/0,0,-1.00,0,0)
374.140: Ch(1):st(250,250,0,250,250,0,0,3,0/0,0,-1.00,0/0,0,-1.00,0,0)
389.576: Ch(0):st(250,250,0,250,250,0,0,3,0/0,0,-1.00,0/0,0,-1.00,0,0)
390.344: Ch(1):st(250,250,0,250,250,0,0,3,0/0,0,-1.00,0/0,0,-1.00,0,0)
405.753: Ch(0):st(250,250,0,250,250,0,0,3,0/0,0,-1.00,0/0,0,-1.00,0,0)
406.578: Ch(1):st(250,250,0,250,250,0,0,3,0/0,0,-1.00,0/0,0,-1.00,0,0)
421.767: Ch(0):st(250,250,0,250,250,0,0,3,0/0,0,-1.00,0/0,0,-1.00,0,0)
422.630: Ch(1):st(250,250,0,250,250,0,0,3,0/0,0,-1.00,0/0,0,-1.00,0,0)
437.964: Ch(0):st(250,250,0,

ab der ,0, hört die log auf
Raptile4ever ist offline  
Alt 21.02.2011, 12:31   #18 (permalink)
His Awesomeness!
10 Jahre hx3
5000 Beiträge
 
Benutzerbild von flickflack
 
Registriert seit: 25.07.2006
Ort: Regnum Borussiae
Beiträge: 9.282
Standard

Das sieht jetzt schon eher wie'n Crash aus, wenn er nicht mal mehr das Zeilenende erreicht. Hm...schlau werde ich gerade nicht draus.


Das passiert mit jeder Mission, auf jeder Insel, bei jedem Spieler - und das ist 100% sicher? Passiert es immer in der selben Situation? Bist im Briefing und willst Start drücken und dann crasht die Kiste?! Ist die zeitliche Stelle reproduzierbar? Die Rechte sind alle ordentlich gesetzt? Kein IPTables behindert die Ports oder blockiert reinkommende Pakete auf dem Server?
flickflack ist offline  
Alt 21.02.2011, 13:00   #19 (permalink)
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von Cyborg11
 
Registriert seit: 26.03.2008
Beiträge: 2.822
Standard

Zitat von Clawhammer Beitrag anzeigen

Ah gut das du mich erinnerst, das Problem ist gelöst. Wir haben den ACE_SM Mod rausgeworfen nun funktioniert der Server wieder oO.

Sry für OT, aber was macht es denn für einen Sinn eine Soundmod auf dem Server laufen zu lassen?
Cyborg11 ist offline  
Alt 21.02.2011, 13:22   #20 (permalink)
Newbie
 
Benutzerbild von Raptile4ever
 
Registriert seit: 20.03.2008
Ort: Karlsruhe
Alter: 33
Beiträge: 46
Raptile4ever eine Nachricht über ICQ schicken Raptile4ever eine Nachricht über MSN schicken
Standard

@flickflack
Entweder nur bis zum Briefing und da schmiert es schon ab mit der Verbindung, oder man schafft es 1-2 min zu Spielen und schmiert dann dort ab. Ja bei jeder Mission, mit und ohne den Mods, egal bei welchem Spieler.

Die behinderung von IPTables (port probleme) geht nicht da die Firewall testweise auch schon aus ist.

Liegt es vllt am Linux Debian 64Bit, ich könnte ja mal mit dem Linux Debian 32Bit testen, ausser Du hast noch eine Lössung zur Hand oder möchtest direkt mal auf den Root und Dir das ganze anschauen. Dann wie gesagt einfach ICQ anschreiben/adden dann gebe ich Dir die daten.

@Cyborg11
Die Soundmods sind drauf wegen den bikeys, mein Clanleader sagte die müssen drauf sein und die Mods auch mit starten.

Zitat:

Zitat von Clawhammer Beitrag anzeigen

Ah gut das du mich erinnerst, das Problem ist gelöst. Wir haben den ACE_SM Mod rausgeworfen nun funktioniert der Server wieder oO.

Wie ich schon bereits erwähnte ist es egal ob Mods an oder aus sind, sogar wenn der Server standard ist passiert es.

Geändert von Raptile4ever (21.02.2011 um 13:24 Uhr).
Raptile4ever ist offline  
Thema geschlossen


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Arma 2 Server Problem S@ndviper Multiplayer 14 15.11.2010 18:45
arma 2 netzwerk probleme (server) lalilu Technische Fragen & Probleme 1 03.10.2010 17:19
Mods im dedicated Server Einbinden Grütze Multiplayer Community 2 09.07.2010 10:08
Biete ArmA 2 / AO Server + TS3 luemmel Die Litfaßsäule 2 03.07.2010 18:30
[WIN] Dedicated Server Probleme Numrollen Technische Fragen & Probleme 7 02.07.2010 19:26


Kontakt - HX3.de - Archiv - Nach oben

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias



SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116