Armed-Assault.de Twitter
Antwort
 
Themen-Optionen Ansicht
Alt 15.05.2011, 10:47   #1 (permalink)
500 Beiträge1000 Beiträge
 
Benutzerbild von Drunken Officer
 
Registriert seit: 15.05.2011
Beiträge: 1.104
Standard O2 - non closed Box

Hallo
Ich bin hier auf das Tut von Mondkalb gestoßen und habe mich nach Jahren des Zockens direkt mal an die Arbeit gemacht um einen Bankautomaten (ATM) für unseren RP Mod zu entwerfen.

In der 3D Ansicht via Bulozer, ist der ATM komplett geschlossen und die Texturen passen. Mach ich allerdings einen non-closes-check, werden mir mehrere Punkte rot angezeigt.

Ich habe es auf 2 Wegen probiert. Einmal mit manueller Verbindung und einmal mit Boxen und invertieren der Gesichter. Das Ergebnis ist jedesmal das Selbe.
Bulzozer ist alles schicke, Prüfung ergibt Fehler.

Kann mir einer sagen, wo ich mit der Fehlersuche beginnen muß? Ich habe mit irgendwie festgefahren.

Edit: Ah, falsche Sektion. Ziel ist es den Automaten bei Arma 2 einzubinden, nicht bei Arma(1)

Geändert von Drunken Officer (15.05.2011 um 10:57 Uhr).
Drunken Officer ist offline   Mit Zitat antworten
Alt 15.05.2011, 11:13   #2 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 24.12.2008
Beiträge: 424
Standard

mach doch mal ein sreenshot von dem mesh im O2, wenn die Prüfung gelaufen ist, und die Punkte markiert sind.

Aber generell kann man in den Viewlods offenen geometrie einsetzen.
Das kann unter umständen viele polygone sparen.

Geschlossene und Convexe Geometrie sind nur in den GeoLods von nöten.
In diesen Lods dann auch Dreiecke und scharfe kanten einsetzen.
__________________
Frankyman ist offline   Mit Zitat antworten
Alt 15.05.2011, 12:43   #3 (permalink)
500 Beiträge1000 Beiträge
 
Benutzerbild von Drunken Officer
 
Registriert seit: 15.05.2011
Beiträge: 1.104
Standard

Bild
Texturen durch die Farbe "grau" zu besseren Ansicht ersetzt.

Geändert von Drunken Officer (15.05.2011 um 12:48 Uhr).
Drunken Officer ist offline   Mit Zitat antworten
Alt 15.05.2011, 20:18   #4 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 24.12.2008
Beiträge: 424
Standard

hmm, ich hatte es befürchtet.

Du hast viele vertices auf kanten. bei diesen vertices schließen sich keine Polygonen an und somit haste löcher.

du kannst versuchen zu triangulieren, allerdings kann ich dir da nix versprechen.

Ich habe da mal ein paar bilder angehangen.
1 zum verständnis warum das passiert
2 dein Automat mit korrekturen, so in etwa sollte ein triangemesh aussehen.
und das andere ist mal eine beispiel von mir, was ich mal schnell gebastelt habe ( quadmesh).

hoffe ich konnte helfen.
Miniaturansicht angehängter Grafiken
o2-non-closed-box-beispiel_automat3.jpg  o2-non-closed-box-beispiel_automat2.jpg  o2-non-closed-box-beispiel_automat.jpg  
__________________
Frankyman ist offline   Mit Zitat antworten
Alt 15.05.2011, 21:58   #5 (permalink)
500 Beiträge1000 Beiträge
 
Benutzerbild von Drunken Officer
 
Registriert seit: 15.05.2011
Beiträge: 1.104
Standard

Danke für die schnelle Hilfe. Ich werde es mal probieren. Bevor du geantwortet hast, habe ich das hintere Problem gelöst, in dem ich deckel- und boden-face gelöscht und neu erstellt habe.

Die Texturen sind ja einigermaßen schnell wieder drauf.

Das wird aber nicht die letzte Frage bleiben. Wie gesagt, ich bin ein noob und dies ist mein aller erster Projekt!
Drunken Officer ist offline   Mit Zitat antworten
Alt 16.05.2011, 22:28   #6 (permalink)
500 Beiträge1000 Beiträge
 
Benutzerbild von Drunken Officer
 
Registriert seit: 15.05.2011
Beiträge: 1.104
Standard

juhu, es hat funktioniert! Ich habe mit ner Art Schachtelsysten gearbeitet. Hat ganz gut geklappt. Danke für die Hilfe.

Erst hatte ich das Problem, das "no-closed-points" da waren. Mit "doppel-face" waen die zwar weg, aber die Texturen waren innen und es wurde ein "non-liniear-mapping" angzeigt.

Jetzt ist alles schicke und es geht an die Config.cpp. Und ich wette, ich werde euch wieder "nerven"
Drunken Officer ist offline   Mit Zitat antworten
Antwort

Stichworte
nicht geschlossene kiste


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Kontakt - HX3.de - Archiv - Nach oben

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias



SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116