Armed-Assault.de Twitter
Antwort
 
Themen-Optionen Ansicht
Alt 20.06.2010, 17:52   #1 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 29.05.2008
Ort: BERLIN
Alter: 28
Beiträge: 496
GER_CJ-187 eine Nachricht über ICQ schicken GER_CJ-187 eine Nachricht über Skype™ schicken
Standard brauche hilfe bei meiner ersten Config

Ich habe ein Problem, ich wollte gerne den BIS-M113 als Bundeswehr-Reskin in eine eigene Pbo packen...

Ich habe mir mit hilfe einer Basis-Config und Tutorial einen Teil der M113-Config gebastelt und angepasst.
Ich möchte in der Pbo nur die Ambu-Variante des M113 haben.

ArmA2 startet ohne Fehlermeldung, aber wenn ich im Editor per Doppelklick eine Einheit platzieren will erscheint:



Das Fahrzeug ist wie gewollt unter BW-Mod (wird benötigt) Kettenfahrzeuge zu finden, aber sobald ich Vorschau anwähle, erscheint:



Ich kann dennoch die Vorschau starten, doch leider steht das Fahrzeug nicht da

Habe die Pbo und den Ordner Hochgeladen, ich würde sie denjenigen schicken, der mir helfen würde, und sich die Config mal sehen könnte.

Währe sehr dankbar...

MfG - Christopher
GER_CJ-187 ist offline   Mit Zitat antworten
Alt 21.06.2010, 05:16   #2 (permalink)
500 Beiträge1000 Beiträge
 
Registriert seit: 12.06.2006
Beiträge: 1.252
Standard

Bitte die Config posten.

pastebin - collaborative debugging tool
__________________
PvPscene
.kju ist offline   Mit Zitat antworten
Alt 21.06.2010, 16:15   #3 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 29.05.2008
Ort: BERLIN
Alter: 28
Beiträge: 496
GER_CJ-187 eine Nachricht über ICQ schicken GER_CJ-187 eine Nachricht über Skype™ schicken
Standard

Hat sich vorerst erledigt.
Keine Ahnung warum es auf meinem Home-PC nicht klappt...

Habe den BIS_M113 erneut heruntergeladen und eingebunden, selber Fehler... Irgendweie verträgt ArmA2 auf meinem Home-PC dieses Addon nicht mehr ^^

Habe exakt die selbe Pbo und meine eigene auf meinem Notebook gepackt und es funktioniert

Einziger BUG:
Das Model hat immernoch den Fehler, der auch im BIS-Forum steht...
Zitat:

Warning Message: No entry 'model.cfg/CfgModels/Vehicle.sectionsInherit'.
Warning Message: No entry 'model.cfg/CfgModels/Vehicle.sections'.

Leider hat sich der Autor, der die Konvertierung hochgeladen hat zurückgezogen...

Quelle: armedassault.info
Zitat:

¤¤Trauma¤¤
Zuletzt gesehen: 11th September 2009 - 11:19

GER_CJ-187 ist offline   Mit Zitat antworten
Alt 21.06.2010, 21:52   #4 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 29.05.2008
Ort: BERLIN
Alter: 28
Beiträge: 496
GER_CJ-187 eine Nachricht über ICQ schicken GER_CJ-187 eine Nachricht über Skype™ schicken
Standard

Hm, erneutes Problem!!!

Habe es doch irgendwie geschafft, dass ich das Repaint statt des Originalen M113 geladen hatte, deshalb war meine eigene Pbo so, wie ich es wollte.

Nun, wo ich es erneut mit der Originalen M113 (USMC-Version) versuchte, ist mir aufgefallen, dass der Textur-Austausch nicht funktioniert

Hier meine Config:
Zitat:

class CfgPatches
{
class CJ187_M113
{
units[]=
{
"M113Ambul"
};
weapons[]={};
requiredVersion=0.100000;
requiredAddons[]=
{
"BWMod"
};
};
};
class CfgVehicles
{
class M113Ambul;
class M113BAT: M113Ambul
{
scope=2;
side=1;
faction="Bw";
displayName="$STR_CJ187_M113";
vehicleClass="BWMod_vC_Tracked_NATO";
icon="\CJ187_M113\icomap_m113_m_ca";
crew="BWMod_CrewG";
hiddenSelections[]=
{
"Camo1"
};
hiddenSelectionsTextures[]=
{
"\CJ187_M113\m113a3_01_co.paa",
"\CJ187_M113\m113a3_02_co.paa",
"\CJ187_M113\m113a3_02_nohq.paa"
};
};
};

Ist dort ein Fehler drin???

Damit es funktioniert, würde ich die Pbo zur "Reparatur" weitergeben...

(habe mich an der Config vom kpfs_mars Orientiert, einziger Unterschied: 3 Texturen statt eine)

Währe unglaublich dankbar für Hilfe...

Habe die Textur jetzt extrem verbessert und mit sehr vielen Details ausgestattet, ich würde das Ergebnis gerne in ArmA sehen



Liebe Grüße - Christopher

Geändert von GER_CJ-187 (21.06.2010 um 21:59 Uhr).
GER_CJ-187 ist offline   Mit Zitat antworten
Alt 22.06.2010, 08:41   #5 (permalink)
50 Beiträge100 Beiträge
 
Benutzerbild von SmartGun
 
Registriert seit: 04.06.2008
Beiträge: 197
Standard

Hallo,

beim drübergucken hab ich keinen Fehler finden können.

Ich bin auch kein profi aber bitte gewöhn die an das übersichtlicher zu gestalten:

Code:
class CfgPatches {
    class CJ187_M113 {
        units[]={"M113Ambul"};
        weapons[]={};
        requiredVersion=0.100000;
        requiredAddons[]={"BWMod"};
    };
};

class CfgVehicles {
    class M113Ambul;
    class M113BAT: M113Ambul {
        scope=2;
        side=1;
        faction="Bw";
        displayName="$STR_CJ187_M113";
        vehicleClass="BWMod_vC_Tracked_NATO";
        icon="\CJ187_M113\icomap_m113_m_ca";
        crew="BWMod_CrewG";
        hiddenSelections[]={"Camo1"};
        hiddenSelectionsTextures[]={
            "\CJ187_M113\m113a3_01_co.paa",
            "\CJ187_M113\m113a3_02_co.paa",
            "\CJ187_M113\m113a3_02_nohq.paa"
        };
    };
};

möglicher Fehler:

Hast du überprüft, ob die selection in deinem model auch "Camo1" benannt ist?


Grüße!
SmartGun ist offline   Mit Zitat antworten
Alt 22.06.2010, 12:02   #6 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 29.05.2008
Ort: BERLIN
Alter: 28
Beiträge: 496
GER_CJ-187 eine Nachricht über ICQ schicken GER_CJ-187 eine Nachricht über Skype™ schicken
Standard

hm, danke, jetzt wo du es sagst ...

Der original M113 bietet keine "hiddenselection"-Funktion

So ein Mist!!!

Darauf hätte ich achten müssen

Ok, nächster Versuch...

Ist leider schon mal schief gegangen, aber könnt ihr mir helfen, das komplette M113Ambu-Modell als eigenes Addon zu packen?
Also ohne M2 und M163...

Ich habe es mehrmals versucht, doch leider erhalte ich dann die Fehler, die im Post 1 zu sehen sind...

Liebe grüße - Christopher
GER_CJ-187 ist offline   Mit Zitat antworten
Alt 22.06.2010, 12:30   #7 (permalink)
50 Beiträge100 Beiträge
 
Benutzerbild von SmartGun
 
Registriert seit: 04.06.2008
Beiträge: 197
Standard

Hi,

geh ich richtig in der Annahme, dass dein m113Ambul ein samplemodel von ArmA1 ist, den du jetzt in mit BW-reskin in A2 bringen willst?

In dem Fall reicht die gepostete cfg nicht aus, da die vererbungen von A1 und A2 etwas andersd sind.

A1: <klick>
LandVehicle->Tank->M113->M113Ambul

A2: <klick>
LandVehicle ->Tank->Tracked_APC ->deinNeuerM113

Gruß!
SmartGun ist offline   Mit Zitat antworten
Alt 22.06.2010, 13:06   #8 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 29.05.2008
Ort: BERLIN
Alter: 28
Beiträge: 496
GER_CJ-187 eine Nachricht über ICQ schicken GER_CJ-187 eine Nachricht über Skype™ schicken
Standard

Also, der M113 ist ein ArmA1-Modell was vor einer Ewigkeit schon in ArmA2 konvertiert wurde, dieser funktioniert auch (abgesehen von den genannten Macken)

Nur jetzt möchte ich die Ambulance-Version aus der Pbo abkapseln (als komplett eigenes Fahrzeug, ohne dass der Rest vom M113 benötigt wird.

Also M113 mit M2 und M163Vulcan raus und übrig bleibt die BAT-Variante mit meinen neuen Texturen.

Da brauche ich aber Hilfe, ich habe es schon einige male versucht, doch dann gibt es entweder beim Start von ArmA2 einen Fehler oder im Spiel und das Fahrzeug ist nicht da...

@SmartGun
könntest du dir das mal ansehen, wenn ich dir mein M113 packe?

MfG - Christopher

Geändert von GER_CJ-187 (22.06.2010 um 13:09 Uhr).
GER_CJ-187 ist offline   Mit Zitat antworten
Alt 22.06.2010, 14:06   #9 (permalink)
50 Beiträge100 Beiträge
 
Benutzerbild von SmartGun
 
Registriert seit: 04.06.2008
Beiträge: 197
Standard

Kann ich gerne machen.
Nur werd ich heute wenn überhaupt dann erst spät zum testen kommen.

Hau doch einfach mal wie von .kju vorgeschlagen die original cfg aus dem m113-pack und deine aktuelle cfg per pastebin - collaborative debugging tool hier rein.

Dann können mehrere Leute drübergucken.
SmartGun ist offline   Mit Zitat antworten
Alt 22.06.2010, 14:39   #10 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 29.05.2008
Ort: BERLIN
Alter: 28
Beiträge: 496
GER_CJ-187 eine Nachricht über ICQ schicken GER_CJ-187 eine Nachricht über Skype™ schicken
Standard

Ok, hab die Original-Config hochgeladen
>HIER<

Meine angepasste für ein Standalone-Fahrzeug habe ich nicht mehr, nur noch die, die ich oben gepostet habe...

Natürlich währe mir die Standalone-Variante lieber, dann muss man nicht noch den US-M113 mit starten.

@SmartGun
Ich schicke dir gleich eine PN indem die neuen Texturen enthalten sind.
Danke

MfG - Christopher
GER_CJ-187 ist offline   Mit Zitat antworten
Alt 22.06.2010, 15:12   #11 (permalink)
Imperator fori nocturni - This sucks more than anything that has ever sucked before 10 Jahre hx3
20.000 Beiträge
 
Benutzerbild von burns
 
Registriert seit: 13.04.2003
Ort: Monerica
Alter: 35
Beiträge: 32.185
Standard

Zitat von SmartGun Beitrag anzeigen

pastebin - collaborative debugging tool

[offtopic]

Wer links die Recent Posts durchguckt, sieht das die Seite quasi von ArmA lebt

[/offtopic]
__________________

burns ist offline   Mit Zitat antworten
Alt 22.06.2010, 16:37   #12 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 29.05.2008
Ort: BERLIN
Alter: 28
Beiträge: 496
GER_CJ-187 eine Nachricht über ICQ schicken GER_CJ-187 eine Nachricht über Skype™ schicken
Standard

Och menno!!!

Ich dreh hier bald durch!

Jetzt habe ich mich mal an ArmA2-Modellen versucht, da es ja dort anscheint keine Probleme gibt.

Auch hier habe ich um zu lernen einen blick in die VW-Golf-Skins geworfen, und mit Hilfe der Config eine eigene für zwei Fahrzeug-Skins erstellt.

Es ist im grunde genommen fast alles gleich geblieben, nur die Displayname's habe ich angepasst...

Es funzt auch bis zu einem Punkt:
Im Editor erhalte ich die meldung:
Zitat:

Cannot load texture cj187_bwgolf\data\bwgolf_icon.paa.

Dabei ist der Dateipfad und der Name der paa korrekt!
naja, wenn ich erneut auf Vorschau klicke, dann kommt:
Zitat:

Cannot load texture cj187_bwgolf\data\bwgolf_body_si.paa.

Auch hier stimmt alles, im Beispiel vom kpfs_golf ist es ja exakt genau so gemacht!

Und anschließend das Endergebnis:


Ich verstehe das nicht, ich kann den Fehler nicht erkennen!!!

Code:
class CfgPatches
{
    class CJ187_BWGolf
    {
        units[]=
        {
            "CJ187_BWGolf1",
            "CJ187_BWGolf2"
        };
        weapons[]={};
        requiredVersion=0.100000;
        requiredAddons[]=
        {
            "CAWheeled2",
            "CACharacters2",
            "CAWeapons",
            "CAWheeled2_VWGolf"
        };
    };
};
class CfgFactionClasses
{
    class Bundeswehr
    {
        displayName="Bundeswehr";
        priority=2;
        side="1";
    };
};
class cfgVehicleClasses
{
    class Bundeswehr
    {
        displayName="Bundeswehr";
    };
};
class CfgVehicles
{
    class VWGolf;
    class CJ187_BWGolf1: VWGolf
    {
        displayname="$STR_CJ187GOLF1";
        side="1";
        faction="bw";
        vehicleClass="BWMod_vC_Wheeled_NATO";
        icon="\CJ187_BWGolf\data\bwgolf_icon.paa";
        crew="Citizen1";
        rarityUrban=0.900000;
        hiddenSelections[]=
        {
            "Camo1",
            "Camo2",
            "Camo3",
            "Camo4"
        };
        hiddenSelectionsTextures[]=
        {
            "\CJ187_BWGolf\data\bwgolf_body_bl.paa",
            "\CJ187_BWGolf\data\bwgolf_carriage_bl.paa",
            "\CJ187_BWGolf\data\bwgolf_interier_bl.paa",
            "\ca\wheeled2\vwgolf\data\vwgolf_interier2_co.paa"
        };
    };
    class CJ187_BWGolf2: VWGolf
    {
        displayname="$STR_CJ187GOLF2";
        side="1";
        faction="bw";
        vehicleClass="BWMod_vC_Wheeled_NATO";
        icon="\CJ187_BWGolf\data\bwgolf_icon.paa";
        crew="Citizen1";
        rarityUrban=0.700000;
        hiddenSelections[]=
        {
            "Camo1",
            "Camo2",
            "Camo3",
            "Camo4"
        };
        hiddenSelectionsTextures[]=
        {
            "\CJ187_BWGolf\data\bwgolf_body_si.paa",
            "\CJ187_BWGolf\data\bwgolf_carriage_si.paa",
            "\CJ187_BWGolf\data\bwgolf_interier_si.paa",
            "\ca\wheeled2\vwgolf\data\vwgolf_interier2_co.paa"
        };
    };
};

Geändert von GER_CJ-187 (22.06.2010 um 16:40 Uhr).
GER_CJ-187 ist offline   Mit Zitat antworten
Alt 22.06.2010, 17:43   #13 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 29.05.2008
Ort: BERLIN
Alter: 28
Beiträge: 496
GER_CJ-187 eine Nachricht über ICQ schicken GER_CJ-187 eine Nachricht über Skype™ schicken
Standard

Mir ist gerade aufgefallen, dass sich die Größe der Grafik verändert, wenn ich sie verändere...

Ich benutze Adobe Photoshop7 mit dem PAAplugin.
Standartgröße ist so ca. 1800kb und allein nach dem speichern OHNE veränderung in paa beträgt die selbe grafik ca. 2700kb!

Kann das der Grund sein?
Mit was kann man denn am besten ArmA2-Texturen bearbeiten?

MfG - Christopher
GER_CJ-187 ist offline   Mit Zitat antworten
Alt 22.06.2010, 18:38   #14 (permalink)
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von Cyborg11
 
Registriert seit: 26.03.2008
Beiträge: 2.822
Standard

Du kannst schon PS nehmen, aber speicher dann als .bmp.
Danach nimmst du TexView 2 (BITools) und konvertierst die Textur in .paa.
Cyborg11 ist offline   Mit Zitat antworten
Alt 22.06.2010, 20:23   #15 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 29.05.2008
Ort: BERLIN
Alter: 28
Beiträge: 496
GER_CJ-187 eine Nachricht über ICQ schicken GER_CJ-187 eine Nachricht über Skype™ schicken
Standard

hm, kann keine ArmA2 Texturen mit TexView2 laden
Auch wenn ich vorher mit PS in bmp speichere, geht auch nicht

Da bleibe ich doch lieber bei PS, denn mit Texturen kann ich ja mitlerweile umgehen, diese komischen Configs muss ich noch hinkriegen...

So langsam bekomme ich bei der Fehlersuche Kopfschmerzen, das kann doch wohl nicht so kompliziert sein!
GER_CJ-187 ist offline   Mit Zitat antworten
Alt 23.06.2010, 07:42   #16 (permalink)
50 Beiträge100 Beiträge
 
Benutzerbild von SmartGun
 
Registriert seit: 04.06.2008
Beiträge: 197
Standard

Moin Moin!

keine Panik, kriegen wir schon irgendwie hin.
Den geänderten Golf hast du doch schonmal ingame!
Als nächstes ist die Textur fällig.

Man darf bei ArmA nicht zu viel auf einmal wollen.

Zitat:

kann keine ArmA2 Texturen mit TexView2 laden

hast du die aktuellen Bi-Tools für A2 verwendet?:
BI Tools 2 - Bohemia Interactive Community

Da gabs wohl ne kleine Änderung in den .paa´s von A1 zu A2.
Das texView2 kann auf jeden Fall .tga und .paa

Also im PS bearbeiten-> als .tga speichern->im texView2 zu .paa konvertieren.

Bei .tga immer RLE_Kompression abschalten / häkchen rausmachen beim speichern.

Zitat:

das kann doch wohl nicht so kompliziert sein

Anfangs schon, gibt einiges zu beachten aber wenn´s mal "klick" gemacht hat kann man das Gelernte auch bei anderen Projekten anwenden.

so, muss hier mal was Arbeiten,

CU

€:
<- Rechtschreibung

Geändert von SmartGun (23.06.2010 um 09:38 Uhr).
SmartGun ist offline   Mit Zitat antworten
Alt 23.06.2010, 16:06   #17 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 29.05.2008
Ort: BERLIN
Alter: 28
Beiträge: 496
GER_CJ-187 eine Nachricht über ICQ schicken GER_CJ-187 eine Nachricht über Skype™ schicken
Standard

hn, ne, will nicht klappen... kann zwar jetzt die tga laden und in paa speichern, aber dennoch vermehrt sich die Größe um knapp 1000kb

Ich gibs bald auf
GER_CJ-187 ist offline   Mit Zitat antworten
Alt 24.06.2010, 08:27   #18 (permalink)
50 Beiträge100 Beiträge
 
Benutzerbild von SmartGun
 
Registriert seit: 04.06.2008
Beiträge: 197
Standard

Moin,

was stört dich an der Grösse?

Die von dir bearbeitete "m113a3_01_co.paa" hat auch 2.731 kb und scheit OK zu sein, solltest du also verwenden können.

Hab mir die m113 von Trauma mal angeguckt und das Pack ist binarized.
Das heisst man kann die p3d nicht mehr bearbeiten was nötig währe um die Texturpfade zu ändern.

Da es sich wohl einfach nur um A1->A2 Portierungen handelt, währ das einfachste du schnappst dir das A1 samplemodel vom m113 und machst dein eigenes Addon.

Download:
BI Sample Models - Bohemia Interactive Forums

[edit]
in dem Thread gehts um A1->A2 ports -> ArmA Addons in ArmA2
[/edit]

Deine bearbeiteten Texturen können sich sehen lassen so mit den Dreckspritzern und so. Die müssten eigentlich auch auf den sample-m113 passen.

@ Golf cfg:

du erstellst eine neue class "CfgFactionClasses -> Bundeswehr" und steckst dann die 2 Golfs in die "bw"-faction: faction="bw";

Ansonsten is die cfg ok und hat gestern abend bei nem schnellen test funktioniert. Ich lad das heut abend dann als Beispiel hoch.

MFG

Geändert von SmartGun (24.06.2010 um 08:29 Uhr).
SmartGun ist offline   Mit Zitat antworten
Alt 24.06.2010, 20:03   #19 (permalink)
500 Beiträge1000 Beiträge
 
Registriert seit: 09.01.2008
Beiträge: 1.560
Standard

Na ja so ganz wollen die originalen M113 + Derivate in A2 nicht funzen. Zum einen klappt die Fahrersicht nicht, zum anderen braucht das Model in A2 eine andere "Gewichtsverteilung".

Ich hatte mal vor Trauma-Release mit .kju an den M113 für's CAA1-Projekt gewerkelt und ich denke die letzte Version sollte funktionieren. Guckt doch mal bei Dev-Heaven vorbei, da sollte das Model noch drin sein (aber nur für Dev's sichtbar).
modEmMaik ist offline   Mit Zitat antworten
Alt 30.06.2010, 21:47   #20 (permalink)
500 Beiträge1000 Beiträge
 
Registriert seit: 09.01.2008
Beiträge: 1.560
Standard

Also wenn ich Legislator's Post richtig interpretiere, gibt's den M113 in OA wieder und ist anscheinend auch texturen-enabled.
modEmMaik ist offline   Mit Zitat antworten
Antwort


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Rechner aufruesten, haette gern Hilfe aus der Community Moerderhoschi Technische Fragen & Probleme 20 28.06.2010 11:10
Brauche Hilfe beim beamen mehrerer Einheiten zur Zufallsposition... GER_CJ-187 Editing & Scripting 14 19.06.2010 18:04
Brauche ein paar CTI und KI Tipps A.D. Community 4 21.05.2010 11:11
hilfe bei oxygen2 :O dennisjegart Mods & Addons 1 19.05.2010 00:45
model config datei waffe anhängen! dennisjegart Mods & Addons 1 14.05.2010 12:23


Kontakt - HX3.de - Archiv - Nach oben

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias



SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116