Armed-Assault.de Twitter
Antwort
 
Themen-Optionen Ansicht
Alt 07.04.2013, 23:46   #1 (permalink)
Newbie
 
Registriert seit: 07.04.2013
Beiträge: 46
Standard Scripting Probleme

hallo Leute,
bis jetzt habe ich nur gezockt. mochte aber zum Start von arma 3 mit dem Editor was machen.
es klappt soweit auch ganz gut. nur ein paar Probleme haben sich jetzt ergeben, und ich hoffe ihr könnt helfen.

1. ich möchte am boten zur Markierung eine ir flare zünden.

mein Script sieht so aus

flare = "UGL_FlareCIR_F" createVehicle [(getpos Flare_1 select 0),( getpos Flare_1 select 1), 1];
als positon habe ich unsichtbare Marker Gesetz.

das Skript geht aber leider nicht. sowohl Marker als auch die flare gehen nicht.

ändere ich es auf Rauch um und ersetzt meine Marker durch z.b. ein firepit geht es.

flare = "SmokeShellGreen" createVehicle [(getpos Flare_1 select 0),( getpos Flare_1 select 1), 1];

hat wer ne Idee woran das liegt ?


2. möchte ich gerne ein Script schreiben um für einen bestimmten Einseitentyp Waffen festzulegen. in der ini eingegeben klappt auch alles. Speicher ich die Befehlszeilen in ein Script und möchte das mit exec abspielen passiert nicht. nur wenn ich selbst der Player bin removed er meine Waffen, aber ich bekomme nicht die neuen. bei AI passiert gar nichts. also wäre super wenn wer ne Idee hat =)
McLaine ist offline   Mit Zitat antworten
Alt 08.04.2013, 04:07   #2 (permalink)
500 Beiträge1000 Beiträge
 
Benutzerbild von Pfandgiraffe
 
Registriert seit: 16.09.2008
Ort: Berlin
Alter: 32
Beiträge: 1.733
Pfandgiraffe eine Nachricht über ICQ schicken Pfandgiraffe eine Nachricht über Skype™ schicken
Standard

1. Flares sollten höher als einen Meter fliegen.

2. Script her.


Grüße
__________________
Niemand hat die Absicht eine Tüte zu bauen!
​​​​​​​
___<<<A3 Wounding System>>>___
Pfandgiraffe ist offline   Mit Zitat antworten
Alt 08.04.2013, 07:09   #3 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 16.07.2010
Beiträge: 305
Standard

1. getMarkerPos

2. Und wieder einmal ein Fall für die Glaskugel. Wie soll man dir helfen, wenn du uns nicht einmal mitteilst, was du in diesen Script hinein schreibst?

Leute denkt doch erst darüber nach, bevor ihr etwas hinschreibt (damit ist nicht Psychobastard gemeint).
__________________
Rockhount ist offline   Mit Zitat antworten
Alt 08.04.2013, 10:15   #4 (permalink)
Armed-Assault.de Team
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von MrCharles
 
Registriert seit: 22.12.2008
Beiträge: 3.641
Standard

Zu 1.)

Du musst die ammo spawnen, nicht das Magazin:

- SIX Config Browser
MrCharles ist offline   Mit Zitat antworten
Alt 08.04.2013, 18:16   #5 (permalink)
Newbie
 
Registriert seit: 07.04.2013
Beiträge: 46
Standard

hiho danke für die Antworten

also mit den flares habe ich schon in höhe von 150m versucht geht auch nicht. den punkt mit dem magazin und der munition probiere ich gleich sofort

fürs zweite problem hier mein script:

removeallweapons this;
removeallitems this;
removeallmagazines this;
this addweapon "NVGoggles";
this addweapon "V_RebreatherIR";
this addmagazine "20Rnd_556x45_UW_mag";
this addmagazine "20Rnd_556x45_UW_mag";
this addmagazine "20Rnd_556x45_UW_mag";
this addmagazine "20Rnd_556x45_UW_mag";
this addmagazine "30Rnd_556x45_Stanag";
this addweapon "FirstAidKit";
this addweapon "arifle_SDAR_F";
this addmagazine "30Rnd_9x21_Mag";
this addmagazine "30Rnd_9x21_Mag";
this addmagazine "30Rnd_9x21_Mag";
this addweapon "hgun_P07_snds_F";

zur ausführung benutze ich den ini :

[waffen] exec "seal_waffen.sqs"
ich bekomme auch kein fehler angezeigt das der script nicht gefunden wird.
es kommen nur keine waffen.

gehbe ich die sachen direkt beim soldaten ein geht es.

McLaine ist offline   Mit Zitat antworten
Alt 08.04.2013, 18:25   #6 (permalink)
Armed-Assault.de Team
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von MrCharles
 
Registriert seit: 22.12.2008
Beiträge: 3.641
Standard

Das ist ein .sqf script und kein .sqs script. Richtig wäre also:

bla = execVM "seal_waffen.sqf"
MrCharles ist offline   Mit Zitat antworten
Alt 08.04.2013, 21:11   #7 (permalink)
Newbie
 
Registriert seit: 07.04.2013
Beiträge: 46
Standard

danke mr charles für den tip mit der flare munition...jetzt gehts auch auf dem boden.
kann ich die helligkeit der flares dimmen?

leider gibt es keine einzelne IR flare. aber das kommt bestimmt noch.

getmarkerpos geht leider für meine unsichtbaren wegpunkte nicht.

und mein waffen script will auch nicht. mein soldat hat immer gar keine waffe und munition wenn ich das script ausführe.
ich habe es nun in sqf umbenant und führe es so aus wie oben beschrieben
waffen = execvm "seal_waffen.sqf"
McLaine ist offline   Mit Zitat antworten
Alt 09.04.2013, 05:34   #8 (permalink)
500 Beiträge
 
Registriert seit: 07.01.2008
Beiträge: 653
[GNC]Lord-MDB eine Nachricht über ICQ schicken
Standard

ja wie soll das denn auch gehen so.Das Script hat ja Garn keinen Bezug zur Person die es ausführt.


waffen = [namedereinheit] execvm "seal_waffen.sqf"
PHP-Code:
_unit _this select 0;

removeallweapons _unit;
removeallitems _unit;
removeallmagazines _unit;
_unit addweapon "NVGoggles";
_unit addweapon "V_RebreatherIR";
_unit addmagazine "20Rnd_556x45_UW_mag";  
_unit addmagazine "20Rnd_556x45_UW_mag";
_unit addmagazine "20Rnd_556x45_UW_mag";
_unit addmagazine "20Rnd_556x45_UW_mag";
_unit addmagazine "30Rnd_556x45_Stanag"
_unit addweapon "FirstAidKit";
_unit addweapon "arifle_SDAR_F";
_unit addmagazine "30Rnd_9x21_Mag";
_unit addmagazine "30Rnd_9x21_Mag";
_unit addmagazine "30Rnd_9x21_Mag";
_unit addweapon "hgun_P07_snds_F"
__________________


--> -> Rechtschreibfehler sind Gratis <- <--
--> Wer welche findet kann sie behalten <--



German Nato Corps
[GNC]Lord-MDB ist offline   Mit Zitat antworten
Alt 09.04.2013, 16:27   #9 (permalink)
Newbie
 
Registriert seit: 07.04.2013
Beiträge: 46
Standard

Dank dir.
Zu meiner Schande ist scripting noch was neues für micht und ich war froh die sqs einigermassen hinzubekommen
McLaine ist offline   Mit Zitat antworten
Antwort


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Arma OA Arma2 und DayZ Probleme c4al DayZ 19 01.07.2012 19:12
A3, new scripting technology Xeno Community 37 03.03.2012 19:07
ArmA II Probleme im Spiel und Patchen Basti1254 Technische Fragen & Probleme 9 20.10.2011 00:41
Probleme nach Patch 1.55 Jack Unger Technische Fragen & Probleme 8 02.12.2010 18:11
OA-KI Probleme u. Animation c0rtes Technische Fragen & Probleme 11 03.10.2010 20:26


Kontakt - HX3.de - Archiv - Nach oben

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias



SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116