Armed-Assault.de Twitter
Antwort
 
Themen-Optionen Ansicht
Alt 04.07.2013, 18:17   #1 (permalink)
50 Beiträge
 
Benutzerbild von Q_W_E_R
 
Registriert seit: 29.09.2012
Beiträge: 56
Standard Problem mit Script auf Dedicated-Server

Hallo,

hab ein Problem mit diesem Script:

init.sqf:
Code:
runscript = {	
	nul = [] execVM "scripts\start.sqf";
};

if (isServer) then
{
	WaitUntil {!isnull player};
	call runscript;
};
und zwar läuft das script auf einem einfach gehostet Server, doch auf einem Dedicated Server passiert nichts hab gehofft das
Code:
WaitUntil {!isnull player};
etwas bringt aber irgendwie bringt es nichts. hab auch festgestellt das wenn ich player setDamage 1; einfüge das ich zwar tot bin aber der respawndelay schon mindest 30 sekunden lang gelaufen ist. Jemand nee Idee danke.
Q_W_E_R ist offline   Mit Zitat antworten
Alt 04.07.2013, 18:20   #2 (permalink)
500 Beiträge1000 Beiträge
 
Registriert seit: 05.01.2008
Alter: 26
Beiträge: 1.702
Standard

Ich rufe meine Scripts in der Init immer so auf:
Code:
if (isServer) then {

	nul = [] execVM "scripts\public_vars.sqf";
}
JoeJoe87577 ist offline   Mit Zitat antworten
Alt 04.07.2013, 18:31   #3 (permalink)
50 Beiträge
 
Benutzerbild von Q_W_E_R
 
Registriert seit: 29.09.2012
Beiträge: 56
Standard

das macht kein unterschied er erkennt ja das es ein server ist aber auf einem Deciated Server führt er das Script schon glaub ich im briefing oder sogar früher aus.
Q_W_E_R ist offline   Mit Zitat antworten
Alt 04.07.2013, 18:38   #4 (permalink)
500 Beiträge1000 Beiträge
 
Registriert seit: 05.01.2008
Alter: 26
Beiträge: 1.702
Standard

Dann prüf mal auf "alive player" statt auf isNull.
JoeJoe87577 ist offline   Mit Zitat antworten
Alt 04.07.2013, 18:52   #5 (permalink)
50 Beiträge
 
Benutzerbild von Q_W_E_R
 
Registriert seit: 29.09.2012
Beiträge: 56
Standard

ist ne gute Idee funktioniert nur leider nicht .
Ich versuchs mal mit nem Trigger viel. gehts
Q_W_E_R ist offline   Mit Zitat antworten
Alt 04.07.2013, 18:59   #6 (permalink)
50 Beiträge
 
Benutzerbild von Q_W_E_R
 
Registriert seit: 29.09.2012
Beiträge: 56
Standard

ok danke hab mein fehler gefunden .
Ich sollte mich schlagen dafür.

Fehler war im darauf folgendem Script:
Code:
if (Side player == west) then ...
da ich es gehostet hab und natürlich als Host ein Player war hat er das Script ausgeführt :P aber Dedcated Server ist kein Spieler und überspringt das Script ULTRAFAIL
Q_W_E_R ist offline   Mit Zitat antworten
Antwort


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Beta-Patch für OpA erschienen det99 Community 1429 18.07.2014 17:51
-=DayZ PRIVATE loewenherz =- [mit Gebäude-Bau , Custom Skins und Server Events] treiberthedriver DayZ 15 27.11.2013 03:21
Patch 1.59 Buccs Community 83 10.06.2011 06:34
Probleme mit Ubuntu ArmA Linux Dedicated Server und ACE Clawhammer Multiplayer 29 26.02.2011 19:49
Arma 2 Server Problem S@ndviper Multiplayer 14 15.11.2010 19:45


Kontakt - HX3.de - Archiv - Nach oben

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias



SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116