Armed-Assault.de Twitter
Antwort
 
Themen-Optionen Ansicht
Alt 04.07.2014, 15:03   #1 (permalink)
Newbie
 
Registriert seit: 23.05.2014
Beiträge: 6
Standard Mission starten nach Serverneustart

Hey,

ich habe folgendes Problem,

wenn der Server neustartet wird er nicht in der MP Liste angezeigt.

Ich habe in der Server.cfg persistent = 1 drin und bin mir auch gewusst das wenn der Server neustartet, ein Spieler erst rauf connecten muss um die Mission zu starten.

Aber das Problem ist er wird ja nicht angezeigt nach dem Restart wie andere das er in den Status Erstellt geht, erst wenn ich direkt per IP ihn suche steht er da aber halt Mission etc ist leer.

weiß da jemand Rat ?

Danke euch

L33TCH
L33TCH ist offline   Mit Zitat antworten
Alt 04.07.2014, 16:35   #2 (permalink)
10 Jahre hx3
500 Beiträge1000 Beiträge
 
Benutzerbild von Buliwyf
 
Registriert seit: 11.03.2005
Ort: HH
Alter: 47
Beiträge: 1.930
Standard

Also das liegt schonmal definitiv nicht am Eintrag persistent=1;! Der hat nämlich mit Deiner beschriebenen Situation so rein garnichts zu tun. Der sorgt lediglich dafür, das eine angespielte Mission nach dem Disconnecten aller Spieler weiterläuft - nicht mehr und nicht weniger!

Poste er seine server.cfg und dann kann man ihm evtl. weiterhelfen. Und nicht vergessen die Passwörter daraus zu nehmen!
__________________
Buliwyf ist offline   Mit Zitat antworten
Alt 04.07.2014, 19:01   #3 (permalink)
Newbie
 
Registriert seit: 23.05.2014
Beiträge: 6
Standard

//
// server.cfg
//

steamport=2300;
steamqueryport=2303;


// GLOBAL SETTINGS
hostname = "[LOKI]Labor der Geisteskranken[1500$-New Territory][300+ Vehicle|Full Save]"; // The name of the server that shall be displayed in the public server list
password = ""; // Password for joining, eg connecting to the server
passwordAdmin = ""; // Password to become server admin. When you're in Arma MP and connected to the server, type '#login xyz'


logFile = "server_console.log";

motd[] = {
"",
"",
"",
"",
"LOKI's Wasteland Server by ultimate-internet.de",
"Like us on Facebook",
"https://www.facebook.com/UltimateInternet",
""
};
motdInterval = 3;


maxPlayers = 40;
kickduplicate = 1;
verifySignatures = 0;
requiredSecureId = 1;

voteMissionPlayers = 200;
voteThreshold = 200;

disableVoN = 0;
vonCodecQuality = 10;
persistent = 1;
timeStampFormat = "none";
BattlEye = 1;

doubleIdDetected = "";
onUserConnected = "";
onUserDisconnected = "";
onHackedData = "";
onDifferentData = "";
onUnsignedData = "";
regularCheck = "";

class Missions
{
class Mission_1
{
template = "A3Wasteland.Altis";
difficulty = "regular";
};




};

//
// server.cfg
//
L33TCH ist offline   Mit Zitat antworten
Alt 04.07.2014, 19:41   #4 (permalink)
10 Jahre hx3
500 Beiträge1000 Beiträge
 
Benutzerbild von Buliwyf
 
Registriert seit: 11.03.2005
Ort: HH
Alter: 47
Beiträge: 1.930
Standard

Ich nehme mal an, dass ihr mit dem aktuellsten Patch spielt? Es steht im Changelog was über SteamQueryPorts: >> klick <<

Das wäre das erste was ich anpassen und testen würde.

Der Abschnitt "Class Missions" ist der, der dafür verantwortlich ist, dass die Mission bei Serverstart vorausgewählt ist.
Du musst in Deinem MPMissions-Ordner einen Ordner mit dem Namen "A3Wasteland.Altis" haben. Halt so wie Du es in der server.cfg angegeben hast. In ArmA2 sah meine Zeile allerdings so aus:
Code:
template = A3Wasteland.Altis;
...also ohne die Gänsefüsschen. Wenn die Mission als PBO-Datei gepackt ist, dann muss die auch mit "A3Wasteland.Altis.pbo" angegeben werden... das zur Info.



*UPDATE*
Eines fällt mir noch ein. Ich habe einen ArmA3 dedicated Server mal auf dem Port 2300 laufen gehabt. Der wurde nach irgendeinem Patch auch nicht mehr im Ingamebrowser angezeigt. Erst als ich den Standardport 2302 wieder eingestellt habe, sah man in auch wieder im Browser. Ob das nun grundsätzlich so ist oder an der Firewall lag kann ich nicht sagen...
__________________

Geändert von Buliwyf (04.07.2014 um 20:01 Uhr).
Buliwyf ist offline   Mit Zitat antworten
Alt 05.07.2014, 11:37   #5 (permalink)
Newbie
 
Registriert seit: 23.05.2014
Beiträge: 6
Standard

hey danke schon mal für deine Antwort,

laut Arma 3 wiki steht zwecks der Mission das so wie ich das zu stehen habe,

class Mission1
{
template="co_xx_mymission.stratis";
difficulty="Regular";
};

Zum Thema port hab ich das mein Provider machen lassen und der wird ja auch gefunden sobald ich ihn über die IP anspiele.

Aber mich nervt halt wie gesagt nach dem Restart, dass der Typ und Mission leer ist und somit kein Status bekommt das man ihn finden kann.

es muss dann immer einer zu den restart zeiten da sein, ihn über die ip finden und anspielen das die Mission los geht.
L33TCH ist offline   Mit Zitat antworten
Antwort


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
MP Mission Jagdkommando - Ohne Scripte u.Ä. FiesesAlien Usermade Missions 0 18.06.2013 02:49
Missionserstellung Tipps&Tricks Moerderhoschi Editing & Scripting 28 12.01.2013 14:38
Patch 1.60! Xeno Community 69 11.01.2012 12:41
1.60 rc Dieter66 Community 47 22.12.2011 15:49
fehlermeldung bei versuch einer mission auf fallujah zu starten WEGAmeister Technische Fragen & Probleme 4 27.12.2010 18:18


Kontakt - HX3.de - Archiv - Nach oben

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias



SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116