Armed-Assault.de Twitter
Antwort
 
Themen-Optionen Ansicht
Alt 18.03.2013, 16:35   #1 (permalink)
Newbie
 
Registriert seit: 14.03.2013
Beiträge: 11
Standard Missing ;

Hi, bekomme einfach keine Attachments/Munition in einen Wagen oder zu einer Person.
Bekomme immer einen Fehler Missing ;

Hier der einfache code, der bei mir leider nicht klappt :

this addMagazineCargo ["20Rnd_762x45_Mag",5]; oder
this addMagazineCargo "20Rnd_762x45_Mag";

this addmagazines ["20Rnd_762x45_Mag",10]; oder
this addmagazine "20Rnd_762x45_Mag";


Vielleicht ein Bug? Aber wieso denn nur bei mir..
Hoffe jemand hat einen Lösungsvorschlag für mich. DANKE
Kiezbengel ist offline   Mit Zitat antworten
Alt 18.03.2013, 16:55   #2 (permalink)
Beta Tester 10 Jahre hx3
20.000 Beiträge
 
Registriert seit: 13.04.2003
Beiträge: 29.761
Standard

Ist das oder auch im Skript?
Snevsied ist offline   Mit Zitat antworten
Alt 18.03.2013, 17:00   #3 (permalink)
Armed-Assault.de Team
500 Beiträge1000 Beiträge2.500 Beiträge
 
Registriert seit: 16.07.2008
Beiträge: 2.681
Standard

in die init eines Soldaten:

Code:
this addMagazine "20Rnd_762x45_Mag";
in die init einer Kiste:

Code:
this addMagazineCargo ["20Rnd_762x45_Mag",5];
Gruß
__________________
Marscl ist offline   Mit Zitat antworten
Alt 18.03.2013, 17:16   #4 (permalink)
Newbie
 
Registriert seit: 14.03.2013
Beiträge: 11
Standard

nein, das oder war nicht mit im Skript. Hatte nur diese einzelbefehle ausprobiert. Teste nachher, danke erstmal.

Komisch, nun klappt es auf einmal. Vielen Dank.

Nur 10 Magazine nimmt er wieder nicht an :

this addMagazine ["20Rnd_762x45_Mag",10];

und das Attachment will auch nicht so recht. Arrggg :
this addPrimaryWeaponItem "muzzle snds B";

Wenn ich diese Parameter noch richtig genannt bekommen würde, wäre ich um 3 Std. meiner kostbaren Zeit nicht vom Editor gepeinigt worden :-)

Danke im Vorraus Leute

Geändert von Kiezbengel (18.03.2013 um 17:28 Uhr).
Kiezbengel ist offline   Mit Zitat antworten
Alt 18.03.2013, 17:32   #5 (permalink)
500 Beiträge1000 Beiträge
 
Registriert seit: 05.01.2008
Alter: 26
Beiträge: 1.703
Standard

Schau nochmal die Namen der Attachments nach. Da fehlen die _ !
SIX Config Browser - Editing resource - ARMA 3 Alpha available
JoeJoe87577 ist offline   Mit Zitat antworten
Alt 18.03.2013, 17:37   #6 (permalink)
Newbie
 
Registriert seit: 14.03.2013
Beiträge: 11
Standard

Ich noch mal :-) Das mit den 10 Magazinen klappt nun.

Und das hier :

this addSecondaryWeaponItem "muzzle_snds_B"; nimmt er zwar an, aber bekomme keinen Schalldämpfer im Game.

Edit : Sorry, wie dumm von mir.... muss natürlich this addPrimaryWeaponItem "muzzle_snds_B"; heißen.


Vielen vielen Dank

Geändert von Kiezbengel (18.03.2013 um 17:39 Uhr).
Kiezbengel ist offline   Mit Zitat antworten
Alt 18.03.2013, 19:12   #7 (permalink)
500 Beiträge
 
Benutzerbild von Anemia
 
Registriert seit: 20.05.2009
Beiträge: 605
Standard

Ansonten schaust du mal hier

Waffen Module / Schalldämpfer / Visier / Lasermarker / Scope


und hier

Uniformen / Helme / Westen / Rucksäcke

hoffentlich sind alle Antworten die du brauchst enthalten. Sonst melde dich gerne nochmal.
Anemia ist offline   Mit Zitat antworten
Alt 18.03.2013, 19:47   #8 (permalink)
Newbie
 
Registriert seit: 14.03.2013
Beiträge: 11
Standard

Vielen Dank für eure Hilfe, hab heute erst mit dem Editor angefangen "rum zu spielen". Ein riesen Potential hat das Teil. Werd mich so gut es geht weiter einlesen, bei Fragen seit Ihr meine Anlaufstelle Nr. uno.
Werdet dann mit meinem Missionen beglückt, hehe..
Schön Abend euch.

P.s. Werde mal auf die Suche gehen um mein respawn Skript zu verbessern, nach dem reviven haben meine Snipers leider nicht mehr das Equipment wie vor dem Tod.
Kiezbengel ist offline   Mit Zitat antworten
Alt 18.03.2013, 19:52   #9 (permalink)
User gesperrt
5000 Beiträge
 
Registriert seit: 20.10.2009
Ort: Jetzt auch im BIF
Alter: 34
Beiträge: 9.163
Standard

Zitat von Kiezbengel Beitrag anzeigen

...

P.s. Werde mal auf die Suche gehen um mein respawn Skript zu verbessern, nach dem reviven haben meine Snipers leider nicht mehr das Equipment wie vor dem Tod.

Das Problem mit der Bewaffnung und dem erneuten Spawn wird hier schon behandelt: Keine Initialisierung nach Respawn?!
AHTNTEPPOP ist offline   Mit Zitat antworten
Antwort


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
J.S.R.S - Jarhead's Sounds-Redeployment Systems Termi Mods & Addons 508 08.01.2013 14:19
Patch 1.60! Xeno Community 69 11.01.2012 12:41
root hat Probleme mit BWMod boggler Mods & Addons 2 04.10.2010 18:54
Probleme bei Norrin Revive Script 0.49b Jekko Editing & Scripting 24 21.09.2010 19:39
Multiplayer PROBLEM!!! Panzagrenadier Multiplayer 15 18.06.2010 14:12


Kontakt - HX3.de - Archiv - Nach oben

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias



SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116