Armed-Assault.de Twitter
Antwort
 
Themen-Optionen Ansicht
Alt 30.09.2014, 18:01   #1 (permalink)
Newbie
 
Registriert seit: 30.09.2014
Beiträge: 10
Standard HELP - Probleme Skins / Einbindung / Anzeige

Erstmal ein Hallo in die Runde schmeissen, ich bin
neu hier und habe gleich ein großes Problem

Ich mappe und skinne für einen Altis Life server und
das bis dato recht "erfolgreich". Scripten ist leider nicht
wirklich meine stärke, bin eher der "Künstler"

Nun zu meinem Problem:

Zum Testen meiner Skins gab es immer 2 möglichkeiten... Entweder das austauschen der *.paa datei in der PBO oder aber mit den Befehlsparametern "this setObjectTexture [0, "texture.jpg"];" bzw." this setObjectTexture [0, 'texture.paa'];" ... Und Ansehen logischerweise im
Editor

Das austauschen der paa Dateien in der PBO scheint seid dem letzten Patch gar nicht mehr zu funktionieren. Wenn die Befehlsparameter verwende funktioniert es. jedoch nur bei manchen Fahrzeugen.

SUV, Offroader und Hatchback funktionieren einfach nicht. Scheinbar hängt es damit zu tun das mehrere Skins dort möglich sind und anscheinend überschreibt dann diese zufällige Skinauswahl die Befehlsparamter.

Hier brauch ich eure Hilfe. Wie zum Henker kann ich mir Skins von SUV, Offroader & Hatchback im Editor anzeigen lassen um eine Vorschau zu haben?

Weitere Probleme: Beim Zamak kann ich zwar den vorderen Teil ersetzen vom Skin mit dem init Befehl. Aber die Plane hat noch den Original Skin.
Gibt es einen erweiterten Init Befehl um beide Skinteile eines Zamaks
anzeigen zu lassen im Editor?

Noch eine kleine Frage am Rande:

Gibt es einen Init - Parameter, damit Fahrzeuge Blaulichter aufs Dach geklatscht bekommen?
Rougherty ist offline   Mit Zitat antworten
Alt 02.10.2014, 10:51   #2 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Benutzerbild von Tajin
 
Registriert seit: 17.01.2008
Beiträge: 267
Standard

Du kannst mit
PHP-Code:
this setVariable["BIS_enableRandomization",false]; 
die zufällige Skinauswahl deaktivieren. Danach funktioniert setObjectTexture auch wieder ganz normal.

Die Blinklichter bekommst du mit
PHP-Code:
this animate ["HidePolice"0]; 
das geht allerdings nur bei dem Offroad.


Im übrigen haben viele Objekte mehrere austauschbare Texturen. Dafür ist die Zahl bei setObjectTexture.
Hier findest du die komplette asset-liste von BIS.:
https://community.bistudio.com/wiki/...Arma_3:_Assets
Dort steht auch jeweils dabei welche hiddenSelections die Objekte haben. (.z.B. die Plane vom Zamak)
__________________
Tajin ist offline   Mit Zitat antworten
Alt 02.10.2014, 20:44   #3 (permalink)
Newbie
 
Registriert seit: 30.09.2014
Beiträge: 10
Standard

Problem damit wunderbar gelös, Danke!
Rougherty ist offline   Mit Zitat antworten
Antwort


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Kontakt - HX3.de - Archiv - Nach oben

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias



SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116