Armed-Assault.de Twitter
Antwort
 
Themen-Optionen Ansicht
Alt 17.03.2016, 17:54   #1 (permalink)
Newbie
 
Registriert seit: 04.05.2015
Beiträge: 13
Standard Codes funktionieren im Singleplayer plötzlich nichtmehr

Hallo zusammen,

nachdem ich alle meine Projekte nun verloren habe, da meine Festplatte einen defekt hatte, musste ich nochmal von neu starten. Ich wollte mich nun lieber erstmal auf den Singleplayer fokusieren, anstatt direkt auf den Multiplayer.

Ich habe zum Test eine test.sqf erstellt und folgendes reingeschrieben:
Code:
a = 1;
b = 4;
if (a < b) then {
    hint "B is greater than A";
} else {
    hint "A is greater than B";
};
https://community.bistudio.com/wiki/if
https://community.bistudio.com/wiki/else

Wenn ich dieses Scripts nun über die Konsole mit [] exec "test.sqf"; ausführe, wird mir immer ein Error angezeigt, dass ein { fehlt. Auch andere Scipts funktionieren nichtmehr, nachdem ich in den Singleplayer gewechselt bin. Das Kommentieren mit // und /*bla bla*/ auch nicht.

Entweder gibt es eine Option, die ich umstellen muss, bevor ich im Singleplayer scripten starte, CBA verändert das Spiel so, dass ich die oben genannten Sachen nichtmehr machen kann, oder das ist ein anderer Fehler, den ich momentan überhaupt nicht überblicken kann.

Schöne Grüße
Arconymous ist offline   Mit Zitat antworten
Alt 17.03.2016, 19:55   #2 (permalink)
500 Beiträge1000 Beiträge
 
Benutzerbild von Drunken Officer
 
Registriert seit: 15.05.2011
Beiträge: 1.107
Standard

am CBA liegt es bestimmt nicht.
__________________
Bewegende Momente bei ArmA 3
Drunken Officer ist offline   Mit Zitat antworten
Alt 17.03.2016, 21:41   #3 (permalink)
Newbie
 
Registriert seit: 04.05.2015
Beiträge: 13
Standard

Aber woran liegt es dann? Ich kann die Scripts nichtmehr richtig ausführen, wie es im Multiplayer der Fall war.

Code:
//Experience
arco_var_exp = 0;
Da wird mir zum Beispiel angezeigt, dass Experience keine Variable ist.

Geändert von Arconymous (17.03.2016 um 21:43 Uhr).
Arconymous ist offline   Mit Zitat antworten
Alt 18.03.2016, 02:40   #4 (permalink)
Newbie
 
Registriert seit: 04.05.2015
Beiträge: 13
Standard

Das Problem ist gelöst! Ich habe alle Scripts mit [] exec ""; aufgerufen und das ist nur für .sqs, welches an Zeilen gebunden ist. Mit execvm ist das nicht der Fall und somit darf ich auch alles, was ich vorher auch durfte. Keine Ahnung, wieso auf einmal das VM bei mir gefehlt hat.
Arconymous ist offline   Mit Zitat antworten
Antwort


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus


Kontakt - HX3.de - Archiv - Nach oben

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias



SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116