Armed-Assault.de Twitter
Antwort
 
Themen-Optionen Ansicht
Alt 06.11.2013, 20:06   #1 (permalink)
50 Beiträge
 
Benutzerbild von JeeperCreeper
 
Registriert seit: 18.10.2013
Alter: 36
Beiträge: 64
Standard Auslöser Bug? Teleport zum MHQ.

Hi Leute ich hab jetzt die letzten 4Tage damit verbracht und bin Heute durch einen Zufall endlich weiter gekommen. Zumindest glaube ich das, deshalb brauche ich jetzt Hilfe von Euch.

Es geht darum sich durch das Action Menü zum MHQ zu teleportieren. Ich habe dafür 2 Auslöser Platziert, 2 MHQ's und benutze dafür 2 Teleport Scripte, wo halt alles definiert ist und 2 respawn Scripte für die MHQ's.
Alles ist jetzt halt extra doppelt damit ich das Problem gut schildern kann.
Ich habe es die ganze Zeit über mit einem Hunter als MHQ probiert und bin ums Verrecken nicht weiter gekommen, bis ich heute ein anderes Fahrzeug probiert habe und es auf einmal ging.

Problem ist folgendes:
Solange der Hunter lebt funktioniert alles wunderbar. Schieße ich den Hunter kaputt, deaktiviert sich der Auslöser. Kurz gesagt nach respawn funktioniert nix mehr, kein Actionmenü Eintrag mehr vorhanden, selbst nachdem man nochmal in den Auslöser läuft.

Das Problem wird jetzt nochmal größer und interessanter:
Wenn ich jetzt z.B. noch ein HEMTT dazu Platziere und einen extra Auslöser nochmal für den HEMTT setze mit einem eigenen Script usw..., passiert folgendes.
Alles funktioniert super auch nachdem man den HEMTT zerstört hat und der wieder respawnt usw..., aber wenn ich jetzt wieder den Hunter zerstöre, dann deaktivieren sich sogar beide Auslöser.

Nochmal im Klartext -
Zerstöre ich den HEMTT und er respawnt wieder, funktioniert alles weiterhin normal. Ich kann mich zu beiden Fahrzeugen teleportieren sobalt ich in den Trigger laufe und den Actioneintrag ausführe.
Zerstöre ich aber den Hunter, dann deaktivieren sich sogar beide Auslöser. Ich kann mich weder zum HEMTT teleportieren noch zum Hunter. Beide Actionseinträge tauchen nicht mehr auf.

Ich hänge mal die Mission mit an und bitte jemanden es mal selbst zu probieren und zu bestätigen. In der Mission habe ich alles zum testen vorbereitet. Habe ein Hunter und ein anderes Fahrzeug platziert man braucht die Mission nur in den richtigen Ordner packen und auszuprobieren.

Ich habe es mit allen Autos Probiert ausser den Quads und es funktionieren alle ausser
Hunter
Hunter-GMG
Hunter-HMG
Offroader bewaffnet FIA
diese vier Fahrzeuge deaktivieren die Auslöser nachdem Sie zerstört worden sind.

So und nun die Frage aller Fragen. Ist das jetzt irgendwie nur ein Bug, oder mache ich da irgendwas falsch? Aber wenn es falsch ist, wieso funktioniert es mit den anderen Fahrzeugen wunderbar?
Angehängte Dateien
Dateityp: rar Ausloesertest.Stratis.rar (3,0 KB, 23x aufgerufen)

Geändert von JeeperCreeper (06.11.2013 um 20:49 Uhr).
JeeperCreeper ist offline   Mit Zitat antworten
Alt 07.11.2013, 12:47   #2 (permalink)
50 Beiträge
 
Registriert seit: 11.02.2010
Beiträge: 69
Standard

Hab es mal ausprobiert und komme zu selbigem Resultat.
Bei Helikoptern (Ghosthawk und Hummingbird - mehr hab ich nicht getestet) passiert das Gleiche.

Edit:
Das Problem scheint ein ganz anderes zu sein. Zerstöre ich die Fahrzeuge mit Hilfe der Debug Konsole und "MHQ2 setdamage 1", bleiben die Einträge erhalten. Feststellen durfte ich das, nachdem ich einen Mohawk nach nicht einmal fünf Raketen kleinbekommen hatte.

Ist schon klar, ein Hubschrauber schluckt mal eben so ein paar Raketen....

Wir hatten gestern schon ein ähnliches Problem mit Panzerabwehrraketen und feindlichem Flakpanzer.
Trotz Beschuss auf das Heck hielt der Panzer ca. sechs Raketen und zwei Rucksackladungen aus.
Beschädigt war das Ding ja schnell, da auch die Crew ausgestiegen ist, aber zerstören ist ein Unding....

Geändert von romans (07.11.2013 um 13:05 Uhr).
romans ist offline   Mit Zitat antworten
Alt 07.11.2013, 16:18   #3 (permalink)
50 Beiträge
 
Benutzerbild von JeeperCreeper
 
Registriert seit: 18.10.2013
Alter: 36
Beiträge: 64
Standard

Oh ich danke Dir, ich dachte schon ich werd ganz bekloppt von dem langen starren auf die Scripte.

Und mit dem Mohawk haha, genau das selbe hab ich auch gemacht, hab es mit dem auch getestet. Aber nach dem er auch zwei Rucksack Ladungen ausgehalten hat, hab ich es sein lassen und bin über zu den Autos gegangen.

Ok dann wird es wohl erstmal ein Bug sein. Dann kann man es mit den Autos auch nicht so machen wie ich es vor hatte.
Bei Xeno's Domination klappt es mit einem Hunter als MHQ, aber er hat das ganze ja auch anders gemacht nur soweit bin ich noch lange nicht.

Edit:
Habe ebn einfach ein leeren Hunter mit auf die Map platziert der garnichts mit den Scripten zu tun hat. Und es passiert das selbe. Nachdem ich ihn zerstöre deaktivieren sich alle Auslöser. Hmm... das ist dann schon bissl blöd. Das muss ich noch weiter testen, das kann doch so nicht sein.
-------------------------------------------------------------------------------------------
Edit2:
Habe jetzt noch ein bissl rum Probiert und es scheint tatsächlich ein Bug zu sein.
Wenn ich anstatt einen Blufor Soldaten ein Opfor hinstelle. Funzt es mit dem Hunter, dafür aber mit den Ifrit nicht.
Also wenn ich als Blufor den Hunter zerstöre deaktivieren sich die Trigger.
Und wenn ich als Opfor den Ifrit zerstöre deaktivieren sich auch die Trigger.
Hat also auch irgendwas mit den Seiten zu tun, keine Ahnung was das für ne Kacke ist. Da Scheint noch so einiges verbuggt zu sein. Werd das ganze nochmal nach dem nächsten Update testen.
----------------------------------------------------------------------------------------------
Edit3:
Habe die Trigger jetzt weggelassen und mache das nur über das Objekt selber.
Bedingung dafür lautet so:
Code:
this enableSimulation false; this allowDamage false; this addAction ["<t color='#006400'>MHQ</t>", "mhqteleport.sqf",true,0,true,true,"","(_this distance _target) < 2"];
Wird erst im Actionmenü angezeigt wenn man sich bis auf 2m am Objekt befindet.

Und im Script sieht das ganze so aus:
Code:
if (isServer) exitWith {};

private ["_behind","_dir"];

_dir = getDir mhq;
_behind = mhq modelToWorld [0,-10,0];

if (alive mhq) then {player setPos [ _behind select 0, _behind select 1, 0]; player setDir _dir};
man kann sich das natürlich selber anpassen wie man lustig ist. In diesem Fall wird der Spieler nur 10m hinter das MHQ teleportiert ohne hint Meldung oder sonstiges.

Und wie schon gesagt, versuche ich das ganze mit einem Trigger, wird dieser sofort deaktiviert sobalt MHQ zerstört wurde.
-------------------------------------------------------------------------------------------
-------------------------------------------------------------------------------------------
Edit die letzte:
Kann geclosed werden.
Das Problem hat sich gelöst, siehe Thread!

Geändert von JeeperCreeper (09.11.2013 um 13:37 Uhr).
JeeperCreeper ist offline   Mit Zitat antworten
Antwort


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Auslöser per kommando aktivieren McDonalds Editing & Scripting 5 07.09.2013 16:16
Auslöser Missionsende NOfX81 Editing & Scripting 2 28.03.2013 04:06
Auslöser aktiv. durch West und/oder Civilian killshot Editing & Scripting 4 26.09.2012 21:08
2 Auslöser arbeiten zusammen Sol.LrMartyn Editing & Scripting 11 05.11.2011 18:29
Gruppe per Auslöser bewegen Deep Five-9te Editing & Scripting 2 07.01.2011 07:46


Kontakt - HX3.de - Archiv - Nach oben

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias



SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116