Armed-Assault.de Twitter
Antwort
 
Themen-Optionen Ansicht
Alt 02.03.2010, 18:35   #1 (permalink)
50 Beiträge100 Beiträge
 
Registriert seit: 24.08.2005
Alter: 32
Beiträge: 123
Standard String als Paramenter übernehmen funktioniert nicht!

Hallo, wie kann ich einen String als Parameter übergeben?
Bei der Wegmarke wp1 wird das script ausgeführt und der String "Ziel_Jet2" soll übergeben werden:

wp1 setWaypointStatements ["true", "[jet2, "Ziel_Jet2"] execvm ""bombenabwurf.sqf"""];

Im script bombenabwurf.sqf will ich den String dann in eine Variable setzen.

_marker = _this select 1;

Geht das überhaupt?
flashbang ist offline   Mit Zitat antworten
Alt 02.03.2010, 20:49   #2 (permalink)
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von Cyborg11
 
Registriert seit: 26.03.2008
Beiträge: 2.822
Standard

Klar geht das, aber du hast in deinem Code ein [ zu viel

Code:
wp1 setWaypointStatements ["true", "jet2, "Ziel_Jet2"] execVM 'bombenabwurf.sqf'"];
Und anstatt "" "" würde ich ' ' schreiben
Cyborg11 ist offline   Mit Zitat antworten
Alt 02.03.2010, 21:58   #3 (permalink)
10 Jahre hx3
500 Beiträge1000 Beiträge
 
Benutzerbild von Buliwyf
 
Registriert seit: 11.03.2005
Ort: HH
Alter: 47
Beiträge: 1.930
Standard

Code:
wp1 setWaypointStatements ["true", "[jet2, 'Ziel_Jet2'] execvm 'bombenabwurf.sqf';"];
__________________
Buliwyf ist offline   Mit Zitat antworten
Alt 02.03.2010, 22:25   #4 (permalink)
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von Cyborg11
 
Registriert seit: 26.03.2008
Beiträge: 2.822
Standard

Ups ... gar nicht drauf geachtet, dass das ja waypointStatements sind.
Dann passt natürlich Buliwyfs Lösung
Cyborg11 ist offline   Mit Zitat antworten
Alt 03.03.2010, 08:57   #5 (permalink)
50 Beiträge100 Beiträge
 
Registriert seit: 24.08.2005
Alter: 32
Beiträge: 123
Standard

Danke, da war ich ja nah dran.

Muss das dann heute mal testen.

Habe zur Kontrolle immer im neu aufgerufenen script nen Hint mit der Variabel ausgeben lassen. Bis jetzt stand dort dann immer "any" drin.

Mal sehen wie es jetzt ausschaut.
flashbang ist offline   Mit Zitat antworten
Antwort


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Arma 2 funktioniert auf gt 230 nicht Panzerjäger Tiger Technische Fragen & Probleme 16 01.03.2010 14:24
Auslöser funktioniert nicht Jekko Editing & Scripting 1 28.01.2010 00:41
Funktion funktioniert nicht. Aemulus Editing & Scripting 2 14.06.2009 23:11
Autosave funktioniert nicht mehr, Spiel lässt sich nicht beenden puni2412 Technische Fragen & Probleme 1 04.06.2009 21:35
Bauen funktioniert nicht im MP Hotkey Technische Fragen & Probleme 2 01.06.2009 00:50


Kontakt - HX3.de - Archiv - Nach oben

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias



SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116