Armed-Assault.de Twitter
Antwort
 
Themen-Optionen Ansicht
Alt 25.02.2011, 01:19   #1 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Benutzerbild von Big Fan
 
Registriert seit: 04.01.2008
Ort: Internet
Alter: 36
Beiträge: 253
Standard Problem mit Statusübernahme

Hi Leute.

Bastel da gerade ab etwas und will die Leute mittels Save und Loadstatus abfragen lassen ob sie in der nächsten Mission verwundet, noch vorhanden, die Waffe von der Vormission haben, Fahrzeuge etc pp.

Gelöst habe ich das so

Savestatus mittels exit.sqs
Zitat:

aa = P saveStatus "Human";
aa1 = jo saveStatus "KI1";
aa2 = pe savestatus "KI2";
aa3 = mi savestatus "KI3";
aa4 = joe savestatus "KI4";
aa5 = b savestatus "KI5";
aa6 = c savestatus "KI6";
aa7 = c1 savestatus "KI7";

und loadstatus mittels init.sqs
Zitat:

aa = P loadStatus "Human";

aa1 = jo loadStatus "KI1";
?(not alive jo): deletevehicle jo
aa2 = pe loadstatus "KI2";
?(not alive pe): deletevehicle pe
aa3 = mi loadstatus "KI3";
?(not alive mi): deletevehicle mi
aa4 = joe loadstatus "KI4";
?(not alive joe): deletevehicle joe
aa5 = b loadstatus "KI5";
?(not alive b): deletevehicle b
aa6 = c loadstatus "KI6";
?(not alive c): deletevehicle c
aa7 = c1 loadstatus "KI7";
?(not alive c1): deletevehicle c1

Soweit so gut, mein Spielerstatus der Waffenpool und der Status der Fahrzeuge die mit übernommen werden sollen geht soweit.

Jetzt hab ich testweise in der 1. mission einen erschossen, die mission beendet und geschaut ob der in der nächsten mission fehlt. Tatsächlich fehlt in der nächsen mission auch jemand aber den KI mitstreiter den ich erschossen habe ist jedoch erneut da.

Hab ich hier irgendwo nen fehler drin?

Danke euch schon mal

Gruß
__________________
Manche halten OFP und ArmA/2 für verbuggt, ich halte es für eine Herausforderung...

Aktueller preview trailer:
https://vid.me/lFy1
Big Fan ist offline   Mit Zitat antworten
Alt 25.02.2011, 09:12   #2 (permalink)
SQF Zauberer 10 Jahre hx3
500 Beiträge1000 Beiträge
 
Benutzerbild von Vienna
 
Registriert seit: 12.07.2004
Ort: Wien
Beiträge: 1.917
Standard

aa1 = jo loadStatus "KI1";
?(not alive jo): deletevehicle jo

Die Abfrage ?(not alive jo) wird so wahrscheinlich nicht korrekt sein.

Lass dir einmal Anzeigen was jo "enthält":

player groupChat format["%1",jo]
Vienna ist offline   Mit Zitat antworten
Alt 25.02.2011, 14:34   #3 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Benutzerbild von Big Fan
 
Registriert seit: 04.01.2008
Ort: Internet
Alter: 36
Beiträge: 253
Standard

ok danke
__________________
Manche halten OFP und ArmA/2 für verbuggt, ich halte es für eine Herausforderung...

Aktueller preview trailer:
https://vid.me/lFy1
Big Fan ist offline   Mit Zitat antworten
Alt 01.03.2011, 13:14   #4 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Benutzerbild von Big Fan
 
Registriert seit: 04.01.2008
Ort: Internet
Alter: 36
Beiträge: 253
Standard

Sorry das jetzt erst die Rückmeldung kommt.

Hab zwischenzeitlich noch was anderes ausprobiert das nicht so ganz funktioniert hat, jetzt hab ich alles auf diesem Wegen gelöst und hab dabei festgestellt das ich lediglich eine Einheit vertauscht habe was ich aber bei zig überprüfungen nicht gesehen habe.

Also ich dem Fall wars kein ArmA2 fehler sondern ein Menschlicher


Danke nochmal
__________________
Manche halten OFP und ArmA/2 für verbuggt, ich halte es für eine Herausforderung...

Aktueller preview trailer:
https://vid.me/lFy1
Big Fan ist offline   Mit Zitat antworten
Antwort


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Problem mit Maps S@ndviper Technische Fragen & Probleme 4 13.02.2011 19:57
Fenstermodus und Taskleisten Problem MaSch0815 Technische Fragen & Probleme 9 28.12.2010 10:44
Problem mit Scheinwerfer... KidDynamite Editing & Scripting 6 20.09.2010 14:21
SIX Updater Problem Nepharim Technische Fragen & Probleme 5 31.07.2010 16:05
ArmA2 OA Problem Thunderbird Technische Fragen & Probleme 17 10.07.2010 19:15


Kontakt - HX3.de - Archiv - Nach oben

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias



SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126