Armed-Assault.de Twitter
Antwort
 
Themen-Optionen Ansicht
Alt 23.12.2012, 17:16   #1 (permalink)
Newbie
 
Registriert seit: 22.12.2012
Beiträge: 7
Standard Problem mit externem Bewaffnungsscript

Hallo Community. Bin der "Neue" hier und hab zugleich ein "Problem". Mit Editing & Scripting steck ich ziemlich in den Kinderschuhen. Hab zwar Mr. Murrays Guide durchgelesen und bereits so manch pers. Fortschritte erzielen können aber nun steck ich mit einem externen Waffenscript fest!

Trennung

Gruppe: Alpha_1 (Player) hat Kommando über 3 weitere Soldaten -> Alpha_1_2, Alpha_1_3, Alpha_1_4.

Desweiteren der Auslöser für das Script:
Radius: 50 Meter
Aktivierung durch BLUFOR (Wenn vorhanden)
Schalter
Bei Aktivierung: this exec "Bewaffnung.sqf";

Script habe ich mit Notepad+ erstellt.

Zitat:

//===Bewaffnungsscript=======
{removeAllWeapons _x}forEach units Alpha_1;

//===Bewaffnung Alpha_1======
//===Fernmeldespezialist=====
{Alpha_1 addMagazine _x}forEach
[
"30Rnd_556x45_Stanag","30Rnd_556x45_Stanag","30Rnd _556x45_Stanag","30Rnd_556x45_Stanag","30Rnd_556x4 5_Stanag","30Rnd_556x45_Stanag",
"30Rnd_556x45_Stanag","ACE_12Rnd_45ACP_USPSD","ACE _12Rnd_45ACP_USPSD",
"ACE_HuntIR_M203","ACE_HuntIR_M203","1Rnd_40mm_HE_ M203","1Rnd_40mm_HE_M203",
"ACE_IRStrobe","HandGrenade_West","SmokeShell","Sm okeShell","ACE_Earplugs","ACE_Map_Tools","ACE_Batt ery_Rangefinder"
];

{Alpha_1 addWeapon _x}forEach
[
"ACE_SOC_M4A1_GL_EOTECH",
"ACE_USPSD",
"NVGoggles",
"ACE_HuntIR",
"ACE_Rangefinder_OD",
"ACE_FAST_PackEDC"
];

//Ende;

Das is jetzt die verkürzte Version des Scripts, nur mit Bewaffnung von Alpha_1, weil ich das bei den restlichen 3 Soldaten nach dem selben Schema fortgesetzt habe.

Nun funktioniert aber nix und ich starte mit den Standardwaffen der Einheiten. Woran könnte der Fehler liegen? Probiere schon seit Stunden rum.

Geändert von Eagle_and_Sword (23.12.2012 um 17:49 Uhr).
Eagle_and_Sword ist offline   Mit Zitat antworten
Alt 23.12.2012, 17:19   #2 (permalink)
10 Jahre hx3
500 Beiträge1000 Beiträge
 
Benutzerbild von Buliwyf
 
Registriert seit: 11.03.2005
Ort: HH
Alter: 46
Beiträge: 1.927
Standard

Du hast eine Grupe, die Alpha_1 heißt UND einen Soldaten, der ebenfalls Alpha_1 heißt?! Na wenn das mal gut geht... auf so eine Idee bin nichtmal ich gekommen... =)

btw.. SQF startet man mit execVM und SQS wird mit exec gestartet.. steht aber auch im Guide.
__________________
Buliwyf ist offline   Mit Zitat antworten
Alt 23.12.2012, 17:45   #3 (permalink)
Newbie
 
Registriert seit: 22.12.2012
Beiträge: 7
Standard

Naja die Gruppe hab ich nicht speziell definiert in einer Description.ext. Ich meine damit, dass der Soldat Alpha_1 das Kommando über die Gruppe hat.

execVM funktioniert nicht im Auslöser. Es kommt die Meldung:
Zitat:

Typ Script, erwartet Nichts

.
Eagle_and_Sword ist offline   Mit Zitat antworten
Alt 23.12.2012, 17:50   #4 (permalink)
10 Jahre hx3
500 Beiträge1000 Beiträge
 
Benutzerbild von Buliwyf
 
Registriert seit: 11.03.2005
Ort: HH
Alter: 46
Beiträge: 1.927
Standard

Naja, Du musst im Auslöser auch so aurufen:
Code:
nul=[] execVM "Bewaffnung.sqf";
__________________
Buliwyf ist offline   Mit Zitat antworten
Alt 23.12.2012, 18:27   #5 (permalink)
Newbie
 
Registriert seit: 22.12.2012
Beiträge: 7
Standard

Zitat von Buliwyf Beitrag anzeigen

Naja, Du musst im Auslöser auch so aurufen:

Code:
nul=[] execVM "Bewaffnung.sqf";

Wie ungeschickt von mir Danke.

Zu meiner Verteidigung muss ich sagen, dass ich seit einem halben Jahr das erste Mal wieder aktiv bin und wohl zu sehr auf OFP fixiert war (da gings mit nur exec [] Script.sqf, soweit ich mich entsinnen kann).
Eagle_and_Sword ist offline   Mit Zitat antworten
Antwort

Stichworte
bewaffnungsscript


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Installations Problem Arma X Verus Technische Fragen & Probleme 20 29.07.2012 21:47
Connection Problem ArmA -=Spine=- Technische Fragen & Probleme 0 11.03.2011 10:47
Fenstermodus und Taskleisten Problem MaSch0815 Technische Fragen & Probleme 9 28.12.2010 09:44
Problem mit BattleEye und Mauseingabe! GER_CJ-187 Technische Fragen & Probleme 2 29.08.2010 15:48
ArmA2 OA Problem Thunderbird Technische Fragen & Probleme 17 10.07.2010 18:15


Kontakt - HX3.de - Archiv - Nach oben

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias



SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116