Armed-Assault.de Twitter
Antwort
 
Themen-Optionen Ansicht
Alt 10.10.2009, 21:17   #1 (permalink)
Newbie
 
Registriert seit: 31.05.2009
Beiträge: 49
Standard KI zu blöd zum fahren

Ich bin sauer wie sau. Ich hab ja schon einiges bei dem Spiel hingenommen aber jetzt reichts bei mir. Ich kann mir keine normale Mission bauen wo die KI den Weg in einer Kolone folgen soll da sie einfach nicht in der Lage ist normal zu fahren...die dreht ja manchmal schon nach ein paar metern ab und ich hab absolut keine Lust meine Mission hundert mal laden zu müssen bis die das endlich auf die reihe bekommen haben den weg bis zum waypoint hin zu folgen. Ich hab schon achtlos und bei geschwindigkeit voll stehen. ich habs auch mit mehreren waypoints antstatt von nur einem auf der strecke ausprobiert aber es geht einfach nicht. es ist echt zum kotzen von dem anderen fehlern mal ganz zu schweigen. Es ist ja schön das dauernd neue addons und inseln sowie missionen rauskommen wobei manche auch das spiel zum abstürtzen bringen aber das nützt mir nix wenn ich andauernd geil gemacht werde und dann wird mir gezeigt das ich damit nicht ordentlich spielen kann. Was soll ich denn noch machen??? Das DriverFixAddon "Sakudriver" kann man auch voll vergessen da dadurch absolut keine verbesserung einkehrt. Durch sowas kann man Herzprobleme bekommen. Die einzigste Möglichkeit die ich sehe ist zu warten bis die KI Fahreigenschaften gepacht werden oder es noch ein neues Addon rauskommt was das behebt. Vieleicht habt ihr ja eine Lösung gefunden da euch das ja auch nicht gefallen dürfte. Danke

Geändert von GeneticResearch (10.10.2009 um 21:20 Uhr).
GeneticResearch ist offline   Mit Zitat antworten
Alt 10.10.2009, 23:51   #2 (permalink)
50 Beiträge100 Beiträge
 
Registriert seit: 13.08.2009
Ort: Schweiz
Beiträge: 191
Phoenixmaster13 eine Nachricht über Skype™ schicken
Standard

wenn du wüsstest wie lang eich schon darauf warte das das gefixt wird, ist schon extrem nervig. Die Ki schafft nicht mal in einer Kolonne von 3 Fahrzeugen richtig zu fahren. Geschweige denn gerade aus.

Hoffe sehndlichst auf nee lösung
Phoenixmaster13 ist offline   Mit Zitat antworten
Alt 11.10.2009, 00:11   #3 (permalink)
Newbie
 
Registriert seit: 08.02.2008
Beiträge: 27
Standard

Fahren ist das eine, bei mir ist sie sogar zu blöd zum kämpfen, ich habe Patch 1.4 drauf und die KI verhält sich entweder zu passiv reagiert gar nicht auf Angriffe oder besticht mit einer völlig unrealistischen Treffsicherheit.
Weiß jemand ob das ein Fehler meiner Seitz bei der Programmierung von Missionen ist oder ist dies auch ein weiterer Bug ?
revan32 ist offline   Mit Zitat antworten
Alt 11.10.2009, 09:45   #4 (permalink)
10 Jahre hx3
5000 Beiträge10.000 Beiträge15.000 Beiträge
 
Benutzerbild von MarcusErgalla
 
Registriert seit: 01.12.2004
Beiträge: 17.399
Standard

Tipp: Während des fahrens den Skill des Fahrers per Skript auf 1.00 setzen und sobald er aussteigt wieder senken!
MarcusErgalla ist offline   Mit Zitat antworten
Alt 11.10.2009, 13:48   #5 (permalink)
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von Cyborg11
 
Registriert seit: 26.03.2008
Beiträge: 2.822
Standard

Zitat von M-E Beitrag anzeigen

Tipp: Während des fahrens den Skill des Fahrers per Skript auf 1.00 setzen und sobald er aussteigt wieder senken!

Was auch nur bedingt hilft. Das Problem ist, dass die KI einfach kurz anhält, wenn sie zu nah am vorfahrenden Fahrzeug ist. Die müsste nur ein bisschen bremsen, aber sie hält gleich komplett und fährt an den Wegrand. Das ist das einzige Problem der KI in einer Kolonne
Cyborg11 ist offline   Mit Zitat antworten
Alt 11.10.2009, 14:20   #6 (permalink)
10 Jahre hx3
5000 Beiträge10.000 Beiträge15.000 Beiträge
 
Benutzerbild von MarcusErgalla
 
Registriert seit: 01.12.2004
Beiträge: 17.399
Standard

Zitat von Cyborg11 Beitrag anzeigen

Was auch nur bedingt hilft. Das Problem ist, dass die KI einfach kurz anhält, wenn sie zu nah am vorfahrenden Fahrzeug ist. Die müsste nur ein bisschen bremsen, aber sie hält gleich komplett und fährt an den Wegrand. Das ist das einzige Problem der KI in einer Kolonne

Es hilft nur bedingt, aber immerhin etwas!
MarcusErgalla ist offline   Mit Zitat antworten
Alt 11.10.2009, 16:27   #7 (permalink)
Newbie
 
Registriert seit: 31.05.2009
Beiträge: 49
Standard

Ich habe heute die singleplayermission clipher runtergeladen und da funktioniert das gerade aus fahren mit 2 Fahrzeugen und auf der straße bleiben 1 A. Liegt das vieleicht daran das auf der afgahni village map von arma1 die die straße schlechter finden weil die noch nicht für arma 2 konvertiert wurde. Aber wie ich sehe habt ihr auch bei euren versuchen mächtige probleme. Danke erst mal für die vielen Antworten.
GeneticResearch ist offline   Mit Zitat antworten
Alt 11.10.2009, 16:47   #8 (permalink)
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von Cyborg11
 
Registriert seit: 26.03.2008
Beiträge: 2.822
Standard

Eigentlich müsste man von allen Fahrzeugen in der Kolonne die Geschwindigkeit mit forceSpeed oder limitSpeed begrenzen, sodass kein Fahrzeug schneller fährt, als das andere. Dann müsste das gut klappen.
Cyborg11 ist offline   Mit Zitat antworten
Alt 12.10.2009, 12:35   #9 (permalink)
Newbie
 
Benutzerbild von [PNC] SCIONTEK
 
Registriert seit: 25.06.2009
Ort: Düren
Alter: 45
Beiträge: 18
Standard

Ich hatte mir da eine total simple Notlösung gebastelt.
Ich habe die Fahrzeuge nicht per Gruppe fahren lassen sondern einzeln; sprich jedes Fahrzeug hat von mir einen eigenen Wegpunkt bekommen (alle die gleiche Route). Es funktioniert so erst Mal einwandfrei und wie schon gesagt als Notlösung.
__________________
[PNC] SCIONTEK ist offline   Mit Zitat antworten
Alt 13.10.2009, 07:33   #10 (permalink)
500 Beiträge
 
Benutzerbild von Anemia
 
Registriert seit: 20.05.2009
Beiträge: 605
Standard

Achja .... Arma ...

Bei arma I noch ... sind die Fahrzeuge immer in den Graben gefahren sowie sie auch nur jemanden auf der straße vermutet haben ....

Bei arma II fahren sie den typen nun erst über und fahren dann in den graben ....
Ob das nun eine verbesserung ist ?!
Anemia ist offline   Mit Zitat antworten
Antwort


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Panzer der Strasse entlang fahren lassen Blaunarwal Editing & Scripting 1 11.07.2009 11:56
Gleichzeitig fahren und feuern Brausepaul Multiplayer Community 4 17.01.2009 16:58
Vehicle spawnen und zum Zielort fahren lassen b3ck5 Editing 4 29.03.2008 08:57
Einheiten joinen per script und fahren zu best. Ort burns Editing 1 24.12.2006 03:12


Kontakt - HX3.de - Archiv - Nach oben

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias



SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116