Armed-Assault.de Twitter
Antwort
 
Themen-Optionen Ansicht
Alt 10.11.2009, 15:27   #1 (permalink)
50 Beiträge
 
Benutzerbild von Spawn15
 
Registriert seit: 12.07.2009
Beiträge: 57
Spawn15 eine Nachricht über ICQ schicken
Standard Frage zum Intro ?

Ich habe eine kamera erstellt und habe die daten in einer intro.sqs abgespeichert ! Die Frage die ich habe ist,wie kann ich nun das intro vor der mission starten ! Ich hoffe jemand kann mir Helfen!

Danke schon mal im Voraus


Gruss
ex.Spawn
Spawn15 ist offline   Mit Zitat antworten
Alt 11.11.2009, 00:57   #2 (permalink)
500 Beiträge
 
Benutzerbild von Anemia
 
Registriert seit: 20.05.2009
Beiträge: 605
Standard

Zitat von Spawn15 Beitrag anzeigen

Ich habe eine kamera erstellt und habe die daten in einer intro.sqs abgespeichert ! Die Frage die ich habe ist,wie kann ich nun das intro vor der mission starten ! Ich hoffe jemand kann mir Helfen!

Danke schon mal im Voraus


Gruss
ex.Spawn

wenn du ein "Intro" haben möchtest dann musst du das im editor auch als intro bauen.Man kann das oben rechts einstellen, dort wo auch wetter und Uhrzeit eingestellt wird. Das wird dann seperat geladen und nach dem intro kommt dann die mission.

wenn du einfach nur eine Kamera fahrt am anfang der mission haben möchtest oder ein standbild dann binde deine intro.sqs in deine init.sqf ein.

Das sieht dann so aus.

Code:
//Mission parameters

[] exec "intro.sqs";

{
};
Solltest du bisher noch keine init.sqf in deinem missions verzeichniss haben , erstelle dir sie einfach selbst und speichere sie mit oben abgebildeten text ab.
Anemia ist offline   Mit Zitat antworten
Alt 11.11.2009, 14:49   #3 (permalink)
50 Beiträge
 
Benutzerbild von Spawn15
 
Registriert seit: 12.07.2009
Beiträge: 57
Spawn15 eine Nachricht über ICQ schicken
Standard

Danke erstmal für deine Antwort ! Ich habe gelesen wenn man eine multiplayer map baut, dann muss das intro oder Kamerafahrt auf der map erstellt werden , ich weiss nicht ob das richtig ist ! Habe es im editor mit intro versucht , aber dort lies sich keine kamerA erstellen ! Aber ich werde deinen Tip mal probieren !

Danke nochmal !

Gruss
ex.Spawn
Spawn15 ist offline   Mit Zitat antworten
Alt 11.11.2009, 16:05   #4 (permalink)
50 Beiträge
 
Benutzerbild von Spawn15
 
Registriert seit: 12.07.2009
Beiträge: 57
Spawn15 eine Nachricht über ICQ schicken
Standard

Ich hab es so gemacht wie du gesagt hast, aber intro startet nicht! MIST


;Introsequenz



_camera = "camera" camCreate [4081.43,9125.77,26.61]
_camera camPrepareTarget [-75029.85,-45624.62,-26974.88]
_camera camPreparePos [4081.43,9125.77,26.61]
_camera camPrepareFOV 0.700
_camera camCommitPrepared 0
@camCommitted _camera
_camera cameraEffect ["Internal","back"]
6

~6
player cameraEffect ["terminate","back"]
camDestroy _camera
~1

exit


So sieht das skript aus , das ich in der intro.sqs habe .

Vieleicht noch ne idee oder ist da am skript was falsch ?????
Spawn15 ist offline   Mit Zitat antworten
Alt 11.11.2009, 23:48   #5 (permalink)
500 Beiträge
 
Registriert seit: 07.01.2008
Beiträge: 653
[GNC]Lord-MDB eine Nachricht über ICQ schicken
Standard

teste mach ob er das intro.sqs überhaupt anlauft,dazu Hint "test"; in die erste Zeile und sachau mal ob etwas in der arma.RPT steht.
__________________


--> -> Rechtschreibfehler sind Gratis <- <--
--> Wer welche findet kann sie behalten <--



German Nato Corps
[GNC]Lord-MDB ist offline   Mit Zitat antworten
Alt 12.11.2009, 07:04   #6 (permalink)
500 Beiträge
 
Benutzerbild von Anemia
 
Registriert seit: 20.05.2009
Beiträge: 605
Standard

Zitat von Spawn15 Beitrag anzeigen

Ich hab es so gemacht wie du gesagt hast, aber intro startet nicht! MIST


;Introsequenz



_camera = "camera" camCreate [4081.43,9125.77,26.61]
_camera camPrepareTarget [-75029.85,-45624.62,-26974.88]
_camera camPreparePos [4081.43,9125.77,26.61]
_camera camPrepareFOV 0.700
_camera camCommitPrepared 0
@camCommitted _camera
_camera cameraEffect ["Internal","back"]
6

~6
player cameraEffect ["terminate","back"]
camDestroy _camera
~1

exit


So sieht das skript aus , das ich in der intro.sqs habe .

Vieleicht noch ne idee oder ist da am skript was falsch ?????


Hier mal ein stück aus einem video von mir, vielleicht probierst du es mal hiermit.
Erstelle mal eine datei die kamera.sqs heißt und kopiere mein videoausschnitt dort rein.
Die init.sqf solltest du dann auch abändern auf
Code:
//Mission parameters

[] exec "kamera.sqs";

{
};
Code:
_cam = "camera" camcreate [10377.85,9527.35,1.07]

_cam camsettarget man1
_camera camPreparePos [10377.85,9527.35,1.07]
_cam camSetFOV 0.7
_cam cameraeffect ["internal", "back"]
_cam camcommit 5
~2

;== Kameraschwenk Patrol1  ==
_cam camsettarget patrol1
_cam camPrepareFOV 0.6
_cam camcommit 5
@camcommitted _cam
_cam cameraeffect ["terminate", "back"];
_camera camCommitPrepared 3



;== Zoom In ==
_cam camsettarget patrol1
_cam camPreparepos [10377.85,9530.35,1.09]
_cam camSetFOV 0.4
_cam cameraeffect ["internal", "back"]
_cam camcommit 0.8
_cam camCommitPrepared 1
~2

;== Kamera auf LAV1 ==
_cam camsettarget lav1
_cam camPrepareFOV 0.6
_cam camcommit 6
@camcommitted _cam
_cam cameraeffect ["terminate", "back"];
_camera camCommitPrepared 3

camdestroy _cam
Die werte die bei camsettarget stehen müsstest du durch einheiten (Namen)ersetzen die du auch auf deiner karte hast (man1,lav1,patrol1).

Wenn es funktioniert .... solltest du nun zumindest irgendwas sehen.... auch wenn es wahrscheinlicht totales gewusel ist da die kordinaten nicht mit deinen übereinstimmen. Aber vielleicht kannst du sie ja wenns funktioniert abändern.
Mit deiner init.sqf sollte soweit alles ok sein.

Geändert von Anemia (12.11.2009 um 07:13 Uhr).
Anemia ist offline   Mit Zitat antworten
Alt 12.11.2009, 16:13   #7 (permalink)
50 Beiträge
 
Benutzerbild von Spawn15
 
Registriert seit: 12.07.2009
Beiträge: 57
Spawn15 eine Nachricht über ICQ schicken
Standard

Ich habs nun doch hingekriegt ! da ich das revive skript eingebaut habe , hat der titleText in der revive_init , das intro blockiert ! Habe den text gelöscht und dann ging es mit meinem Skript auch ! Danke Euch dafür das ihr mir auf die Sprünge geholfen habt und eurer Skript gepostet habt .Ich werde es mir nochmal als beispiel für etwas aufwendigere Sachen nehmen !


Saugeil von euch das ihr hier die Leute so unterstützt, weiter so!Bin auch noch ziemlich neu beim Editing
Spawn15 ist offline   Mit Zitat antworten
Alt 07.04.2014, 22:18   #8 (permalink)
Newbie
 
Registriert seit: 08.01.2014
Beiträge: 17
Standard

Zitat von Spawn15 Beitrag anzeigen

Ich habe eine kamera erstellt und habe die daten in einer intro.sqs abgespeichert ! Die Frage die ich habe ist,wie kann ich nun das intro vor der mission starten ! Ich hoffe jemand kann mir Helfen!

Danke schon mal im Voraus


Gruss
ex.Spawn

Schau dir mal das Tutorial an. Bin heute durch Zufall drauf gestoßen.
Arma Tutorial zum Kamerascript/ Intros (part 1) German - YouTube
derHeer ist offline   Mit Zitat antworten
Antwort


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Frage zum Intro Flo66 Editing & Scripting 1 27.08.2009 18:24
Intro Frage DirtyHarryTPC Editing 3 23.07.2008 13:30
Kleines Intro Rambow Editing 2 31.10.2003 12:30


Kontakt - HX3.de - Archiv - Nach oben

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias



SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116