Armed-Assault.de Twitter
Antwort
 
Themen-Optionen Ansicht
Alt 19.07.2010, 19:07   #1 (permalink)
50 Beiträge
 
Benutzerbild von miromanu
 
Registriert seit: 18.07.2009
Alter: 29
Beiträge: 90
Standard eigene sounds problem

hallo mal wieder,

also das problem ist das ich, genau wie es in der editing guide steht, versuche einen sound in meine mission einzubinden aber immer wieder mit der selben fehlermeldung. ich erklär mal was ich gemacht habe: als erstes in den missionsordner ein ordner erstellt und diesen sounds benannt. In den ordner ist eine audio ogg datei die sound1 heißt. dann habe ich im missionsordner eine description.ext erstellt und in dieser dieses hier reingeschrieben:
Code:
class CfgSounds
{
sounds[]= {Sound1};
class Sound1
    {
name = "Sound1";
sound[] = {\sounds\sound1.ogg, db+0, 1.0};
     };
};
Im missionseditor habe ich einen wegpunkt erstellt und bei ativierung reingeschrieben: playsound "sound1"
und sobald ich es asuprobiere kriege ich diese fehlermeldung: No entry 'C:\Users\................\description.ext/cfgsounds/sound1.titles'.
hat jemand eine ahnung was flasch sein könnte??
miromanu ist offline   Mit Zitat antworten
Alt 19.07.2010, 19:22   #2 (permalink)
50 Beiträge100 Beiträge
 
Benutzerbild von TraX
 
Registriert seit: 21.06.2009
Alter: 45
Beiträge: 158
Standard

Hallo versuchs mal so

class CfgSounds
{
sounds[] = { };

class Sound1
{
name = "Sound1";
sound[] = {"\SOUND\Sound1.ogg",db-15, 1.0};
titles[] = {0, ""};
};


};
TraX ist offline   Mit Zitat antworten
Alt 19.07.2010, 19:35   #3 (permalink)
50 Beiträge
 
Benutzerbild von miromanu
 
Registriert seit: 18.07.2009
Alter: 29
Beiträge: 90
Standard

nein leider auch nicht wenn ich es so mache dann passiert sogar nichts ich gehe einfach durch den wegpunkt ohne fehlermeldung
miromanu ist offline   Mit Zitat antworten
Alt 20.07.2010, 20:42   #4 (permalink)
Newbie
 
Registriert seit: 04.06.2009
Beiträge: 21
Standard

Vieleicht kann dir dieses Video helfen .

YouTube - ArmA 2 Editor Tutorial - Sounds

Und wenn ich das Video richitg verstanden habe, must du noch einfügen titles[] = {}; .

Aslo müste es so ausschauen:

class CfgSounds
{
sounds[]= {Sound1};
class Sound1
{
name = "Sound1";
sound[] = {\sounds\sound1.ogg, db+0, 1.0};
titles[] = {};
};

};

Geändert von Nieznany (20.07.2010 um 20:55 Uhr).
Nieznany ist offline   Mit Zitat antworten
Alt 21.07.2010, 02:26   #5 (permalink)
50 Beiträge
 
Benutzerbild von miromanu
 
Registriert seit: 18.07.2009
Alter: 29
Beiträge: 90
Standard

Hey danke nieznany das funktioniert aber nur wenn ich .wss datein benutze und nicht .ogg
miromanu ist offline   Mit Zitat antworten
Alt 21.07.2010, 19:15   #6 (permalink)
Newbie
 
Registriert seit: 04.06.2009
Beiträge: 21
Standard

Na hauptsache es geht. ^^
Kenn mich auch nich mit sowas aus. Hatte nur per zufall gestern das Vid gesehen, und dannnnoch dein Thread.

Und bin der meinung das du mit dem Befehl titles[] = {0, ""}; dein Sound zurück setzt (Keine Ahnung wie ich es formulieren soll). Da du mit 0 ansagst er soll Titel 0 spielen der nicht vorhanden ist..... .
Nieznany ist offline   Mit Zitat antworten
Alt 21.07.2010, 21:02   #7 (permalink)
50 Beiträge100 Beiträge
 
Benutzerbild von TraX
 
Registriert seit: 21.06.2009
Alter: 45
Beiträge: 158
Standard

Du könntest auch in die description schreiben


class CfgRadio
{
sounds[] = { };

class Sound1
{
name = "Sound1";
sound[] = {"\SOUND\Sound1.ogg", db-15, 1.0};
title = $STRC_Sound1;
};


};

und wenn du eine stringtable.csv in deinem Missions Ordner hast
schreibst du

LANGUAGE,"English","German"

STRC_sound1,"You know what's ironic?","Weißt du, was echt komisch ist?"


und in einem auslöser oder Script schreibst du dann

player sideRadio "Sound1";
damit wird der Sound mit Text ausgegeben
TraX ist offline   Mit Zitat antworten
Alt 02.08.2010, 14:10   #8 (permalink)
50 Beiträge100 Beiträge
 
Registriert seit: 13.08.2009
Ort: Schweiz
Beiträge: 191
Phoenixmaster13 eine Nachricht über Skype™ schicken
Standard

hab auch ein problem weiss aber nicht an was das liegt¨!! es kommt immer eine fehlermeldung. Könnt ihr es mal überfliegen

// === Musik ================================================>
class CfgMusic
{
tracks[]= { Track1,Track2 };
class Track1
{
name = "Track1";
sound[] = {\music\track1.ogg, db+0, 1.0};
};

// === Radio/Funk ============================================>
class CfgRadio
{
sounds[] = { };
class Sound1
{
name = "radiochatter1";
sound[] = {"\SOUND\radiochatter1.ogg", db-15, 1.0};
title = $STRC_Sound1;
};
Phoenixmaster13 ist offline   Mit Zitat antworten
Alt 02.08.2010, 14:15   #9 (permalink)
Newbie
 
Benutzerbild von SniperWolf
 
Registriert seit: 07.07.2010
Ort: Deutschland
Beiträge: 37
Standard

Zitat:

sound[] = {"\SOUND\radiochatter1.ogg", db-15, 1.0};

bin mir nicht sicher, aber ich glaube die "" dürfen da nicht hin. Versuch es mal so:

Zitat:

sound[] = {\SOUND\radiochatter1.ogg, db-15, 1.0};

__________________



My PC @ SysProfile: AMD Phenom II X4 955 BE | ASUS Crosshair IV Formula 890 FX | nVidia GeForce 8800 GTS | 2x 2GB DDR3 Mushkin Copperhead 1600 MHz | Razer Lycoa | Logitech G9 | beQuiet! Stright Power 600W

WaKü: Aquacomputer Kryos AM3
| Aquacomputer Aquastream XT Ultra | Aquacomputer aquaero | Phobya Balancer 250 Black | MagiCool XTREME TRIPLE 360 | Aquacomputer Flow-Sensor | Thermosensoren im AGB und Durchfluss am Radiator
SniperWolf ist offline   Mit Zitat antworten
Alt 02.08.2010, 19:34   #10 (permalink)
50 Beiträge100 Beiträge
 
Registriert seit: 13.08.2009
Ort: Schweiz
Beiträge: 191
Phoenixmaster13 eine Nachricht über Skype™ schicken
Standard

jetzt bringt er mir keine fehlermeldung mehr aber ich kann den sound nicht abspielen (playsound"sound1"
es kommt immer sound sound1 nicht gefunden warum?

// === Musik ================================================>
class CfgMusic
{
tracks[]= { Track1,Track2 };
class Track1
{
name = "Track1";
sound[] = {\music\track1.ogg, db+0, 1.0};
};
}

// === Radio/Funk ============================================>
class CfgRadio
{
sounds[] = {sound1 };
class Sound1
{
name = "radiochatter1";
sound[] = {\sound\radiochatter1.ogg, db-15, 1.0};
titles[] = {};
};
}}
Phoenixmaster13 ist offline   Mit Zitat antworten
Alt 02.08.2010, 19:37   #11 (permalink)
10 Jahre hx3
500 Beiträge1000 Beiträge
 
Benutzerbild von Buliwyf
 
Registriert seit: 11.03.2005
Ort: HH
Alter: 46
Beiträge: 1.927
Standard

name = "radiochatter1";

...denk mal drüber nach...
__________________
Buliwyf ist offline   Mit Zitat antworten
Alt 02.08.2010, 19:55   #12 (permalink)
50 Beiträge
 
Registriert seit: 04.01.2010
Beiträge: 63
Standard

Code:
class CfgSounds
{
    sounds[] = {};
    class Sound1
    {
       name = "Sound1";
       sound[] = {\Sounds\Sound1.ogg, db+0, 1.0};
       titles[]= {}; 
    };
};
Wenn jetzt was nicht geht liegts an Ordner / Dateinamen.

Ach ja das alles in die describtion.ext

und dann mit

playSound "Sound1";

aufrufen
LurchiDerLurch ist offline   Mit Zitat antworten
Alt 02.08.2010, 19:56   #13 (permalink)
50 Beiträge100 Beiträge
 
Registriert seit: 13.08.2009
Ort: Schweiz
Beiträge: 191
Phoenixmaster13 eine Nachricht über Skype™ schicken
Standard

mit playsound "radiochatter1" geht es aber auch nicht! es heisst er findent die datei nicht warum? ich habe im missionsordner einen order der sound heisst und dadrin ist eine ogg datei mit dem namen radiochatter1
Phoenixmaster13 ist offline   Mit Zitat antworten
Alt 02.08.2010, 20:29   #14 (permalink)
500 Beiträge1000 Beiträge
 
Benutzerbild von Pfandgiraffe
 
Registriert seit: 16.09.2008
Ort: Berlin
Alter: 31
Beiträge: 1.725
Pfandgiraffe eine Nachricht über ICQ schicken Pfandgiraffe eine Nachricht über Skype™ schicken
Standard

die samplerate wird zu hoch sein?! mehr als 44 samples is nich.
__________________
Niemand hat die Absicht eine Tüte zu bauen!
Pfandgiraffe ist offline   Mit Zitat antworten
Alt 02.08.2010, 23:04   #15 (permalink)
User gesperrt
50 Beiträge100 Beiträge
 
Registriert seit: 09.10.2009
Ort: Schweiz
Alter: 23
Beiträge: 242
Standard

wo siehst du die samplerate im script?
HenkerundKoch36 ist offline   Mit Zitat antworten
Alt 03.08.2010, 01:28   #16 (permalink)
50 Beiträge100 Beiträge
 
Registriert seit: 13.08.2009
Ort: Schweiz
Beiträge: 191
Phoenixmaster13 eine Nachricht über Skype™ schicken
Standard

hey danke Psychobastard genau das war das Problem habe sie mit 44100 abgespeichert jetzt geht es Perfekt
Phoenixmaster13 ist offline   Mit Zitat antworten
Alt 03.08.2010, 17:16   #17 (permalink)
50 Beiträge100 Beiträge
 
Benutzerbild von Doorgunner
 
Registriert seit: 15.02.2010
Ort: Niedersachsen/Kreis NI
Alter: 39
Beiträge: 209
Standard

Zitat von LurchiDerLurch Beitrag anzeigen

Code:
class CfgSounds
{
    sounds[] = {};
    class Sound1
    {
       name = "Sound1";
       sound[] = {\Sounds\Sound1.ogg, db+0, 1.0};
       titles[]= {}; 
    };
};
Wenn jetzt was nicht geht liegts an Ordner / Dateinamen.

Ach ja das alles in die describtion.ext

und dann mit

playSound "Sound1";

aufrufen
Das funktioniert perfekt!

Nur wie bekomm ich das in meine Description gebastelt? An den Cfg Sounds hab ich mir schonmal die Zähne ausgebissen.
Code:
//defines
#include "LDL_ac130\uiDefines.hpp"
#include "LDL_ac130\define.hpp"
//Dialog
#include "LDL_ac130\dialog.hpp"
#include "LDL_ac130\dialogUAV.hpp"
// Mission Header
class Header
{
  gameType = Coop;
  minPlayers = 1;
  maxPlayers = 4;
};
onLoadMission = "US Support";
OnLoadMissionTime = FALSE;

respawn = "BASE";
respawndelay = 10;
disabledAI = 0;
showCompass = 1;
showGPS = 1;
showWatch = 1;

//---------------------US SUPPORT SCRIPT--------------------------------
RespawnDialog = false;
#include "lkscripts\Dialogs\Common\DialogColorConstants.hpp"
#include "lkscripts\Dialogs\DialogColorScheme.hpp"
#include "lkscripts\Dialogs\Common\DialogControlClasses.hpp"
#include "lkscripts\Dialogs\Respawn_Dialog.hpp"
// Tomahawk sounds
class CfgSounds
{
 // List of sounds (.ogg files without the .ogg extension)
 sounds[] = {Explo_Large, incoming, Rocket_Away};
 // Definition for each sound
 class Explo_Large
 {
  name = "Explo_Large"; // Name for mission editor
  sound[] = {\lkscripts\sound\Explo_Large.ogg, db + 0, 1.0};
  titles[] = {0, ""};
 };
 class incoming
 {
  name = "incoming"; // Name for mission editor
  sound[] = {\lkscripts\sound\incoming.ogg, db + 0, 1.0};
  titles[] = {0, ""};
 };
 class Rocket_Away
 {
  name = "Rocket_Away"; // Name for mission editor
  sound[] = {\lkscripts\sound\Rocket_Away.ogg, db + 0, 1.0};
  titles[] = {0, ""};
 };
};
//--------------------US SUPPORT SCRIPT--------------------------------
Kann mir jemand dabei helfen?
Doorgunner ist offline   Mit Zitat antworten
Alt 03.08.2010, 18:21   #18 (permalink)
50 Beiträge
 
Registriert seit: 04.01.2010
Beiträge: 63
Standard

Code:
//Sounds
class CfgSounds
{
    sounds[] = {};
    #include "LDL_ac130\CfgSounds.hpp"
};
Dann sind die Sounds vom AC130 script drin (ich denke das willst du auch oder?)

und deine musst du einfach dazu schreiben:

Code:
//Sounds
class CfgSounds
{
    sounds[] = {};
    #include "LDL_ac130\CfgSounds.hpp"

 class Explo_Large
 {
  name = "Explo_Large"; // Name for mission editor
  sound[] = {\lkscripts\sound\Explo_Large.ogg, db + 0, 1.0};
  titles[] = {};
 };

 class incoming
 {
  name = "incoming"; // Name for mission editor
  sound[] = {\lkscripts\sound\incoming.ogg, db + 0, 1.0};
  titles[] = {};
 };

 class Rocket_Away
 {
  name = "Rocket_Away"; // Name for mission editor
  sound[] = {\lkscripts\sound\Rocket_Away.ogg, db + 0, 1.0};
  titles[] = {};
 };



};

Das sollte dannso funktionieren
LurchiDerLurch ist offline   Mit Zitat antworten
Alt 04.08.2010, 02:36   #19 (permalink)
50 Beiträge100 Beiträge
 
Benutzerbild von Doorgunner
 
Registriert seit: 15.02.2010
Ort: Niedersachsen/Kreis NI
Alter: 39
Beiträge: 209
Standard

Zitat:

Das sollte dannso funktionieren

Jaa, das funktioniert, danke schön!
Und ich hab endlich die Funksprüche bei der AC-130, mit der ganzen Klammersetzung komm ich immer ganz durcheinander.


Eine Frage hätt ich aber noch: Wenn ich jetzt 10 Sounds habe muß ich die ja dann auch in der Descrption definieren.
Code:
sound[] = {\Sounds\Sound1,sound2,sound3,usw.ogg, db+0, 1.0};
Muß ich dann so tun?

Und wenn ich dann mehere Sounds in Folge abspielen will, so aufrufen?
Code:
playSound "Sound1,sound2,sound3,usw";
Doorgunner ist offline   Mit Zitat antworten
Alt 04.08.2010, 06:42   #20 (permalink)
10 Jahre hx3
500 Beiträge1000 Beiträge
 
Benutzerbild von Buliwyf
 
Registriert seit: 11.03.2005
Ort: HH
Alter: 46
Beiträge: 1.927
Standard

Alter... du hast doch nun schon im letzten Post von Lurchi ein Beispiel wie es auszusehen hat. Er hat 3 Sounds als Beispiel genommen. Du willst 10 Sounds... was ist also zu tun?

Und HIER steht ohnehin alles drinn...

__________________
Buliwyf ist offline   Mit Zitat antworten
Antwort


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
ArmA2 OA Problem Thunderbird Technische Fragen & Probleme 17 10.07.2010 19:15
description.ext (sound) problem miromanu Editing & Scripting 7 07.07.2010 16:40
Multiplayer Heli problem = Arma 2 OP Mert Multiplayer 1 05.07.2010 15:56
Download Problem NiP Community 2 29.06.2010 11:33
Problem beim entpacken von Pbo's GER_CJ-187 Technische Fragen & Probleme 1 17.05.2010 22:03


Kontakt - HX3.de - Archiv - Nach oben

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias



SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116