Armed-Assault.de Twitter
Antwort
 
Themen-Optionen Ansicht
Alt 19.09.2009, 05:03   #1 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 29.05.2008
Ort: BERLIN
Alter: 28
Beiträge: 496
GER_CJ-187 eine Nachricht über ICQ schicken GER_CJ-187 eine Nachricht über Skype™ schicken
Icon5 Attach probleme...

Einen schönen guten Morgen werte ArmA-Community,

ich habe die ganze Nacht an einer Mission gebastelt, und es funktioniert so ca. 98% (also das was ich bis jetzt gebastelt habe)

Aber leider stimmt was mit den AttachTo befehlen nicht...

Ich habe ein Objekt A an einem Fahrzeug "Attacht" und kann es mit einem Aktionseintrag entfernen und ein anderes B an die alte Stelle von A beamen (also ein Austausch, unterschied: B ist nicht "attacht".
DasObjekt A wird an einem unsichtbaren H im Nirwana "attacht".
Ich kann das auch wieder rückgängig machen, also das B auch an das H im Nirgendwo und das A wieder an das Fahrzeug...

klappt wunderbar!

NUR...

wenn ich es wiederholen möchte, wird das A wieder an das H "attacht", aber das B bleibt beim H!
Ich bin der meinung, dass man ein AttachTo mit detach aufheben kann, also müsste doch das Objekt einfach nur platziert sein und umplatziert werden können...
Das ist aber leider nicht so, das B Objekt blinkt nur ganz kurz auf und ist wieder weg... (also am H)

kann mir da bitte einer Helfen???
Ich würde mich wahnsinnig darüber freuen.

MfG - Chris
__________________

CPU: Intel Core i7-3770K ~ 4 x 3.5GHz // Mainboard: Asus P8P67 LE // RAM: 2 x 8GB DDR3-1333 RAM
Grafikkarte: Nvidia GTX 680 ~ 2GB // Soundkarte: Creative Gamer X-Fi


Geändert von GER_CJ-187 (19.09.2009 um 05:05 Uhr).
GER_CJ-187 ist offline   Mit Zitat antworten
Alt 19.09.2009, 11:42   #2 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Benutzerbild von Hemingway
 
Registriert seit: 31.05.2009
Beiträge: 321
Standard

hm....

hast du das richtige objekt detached?

also detach A/B, nicht detach H?


vielleicht könntest du konkret beschreiben worums geht, also nicth nur A & B^^

ich denk zur not kann man auch mit createvehicle & deletevehicle das H umgehen...
__________________
Kickstart fighter launch
Throttle set to full
Speed king race to win
Afterburners roaring
Ghostlike counterstrike
Takes them by surprise
Hemingway ist offline   Mit Zitat antworten
Alt 19.09.2009, 12:13   #3 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 29.05.2008
Ort: BERLIN
Alter: 28
Beiträge: 496
GER_CJ-187 eine Nachricht über ICQ schicken GER_CJ-187 eine Nachricht über Skype™ schicken
Standard

hm, ich denke ja, dass ich es richtig gemacht habe, ich habe nach dem
B attachto H gleich den befehl B detach H vorgegeben...

Aber ich kann natürlich auch genau beschreiben, was ich will ^^

Es geht um eine Kiste, die auf die Ladefläche soll (gelöst)
Die kiste soll mit aktionsmenüeintrag abgeladen werden (gelöst)
Die kiste soll aber auch durch eine andere ersetzt werden, die bereits existiert (gelöst)
Die 2. kiste soll hinter das Fahrzeug gebeamt werden (ohne attachto, gelöst)
man soll aber auch wieder verladen können, die 2. Kiste wird an das H im Wasser attacht und die 1. wieder an das Fahrzeug (gelöst)
Aber das erneute abladen geht nicht! da die 2. Kiste am H attacht ist, kann ich die nicht beamen, die wird wieder zurück ins Wasser gesetzt, der detach hat nicht funktioniert...

Ich hoffe, es ist jetzt ein wennig besser zu verstehen...

MfG - Chris
__________________

CPU: Intel Core i7-3770K ~ 4 x 3.5GHz // Mainboard: Asus P8P67 LE // RAM: 2 x 8GB DDR3-1333 RAM
Grafikkarte: Nvidia GTX 680 ~ 2GB // Soundkarte: Creative Gamer X-Fi


Geändert von GER_CJ-187 (19.09.2009 um 12:15 Uhr).
GER_CJ-187 ist offline   Mit Zitat antworten
Alt 19.09.2009, 12:51   #4 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Benutzerbild von Hemingway
 
Registriert seit: 31.05.2009
Beiträge: 321
Standard

okay..


wenn du die kiste, die jeweils "weg" sein soll, nicht an ein H attachst, sondern einfach per "setpos" irgendwo an den a.... der karte setzt?
__________________
Kickstart fighter launch
Throttle set to full
Speed king race to win
Afterburners roaring
Ghostlike counterstrike
Takes them by surprise
Hemingway ist offline   Mit Zitat antworten
Alt 19.09.2009, 16:02   #5 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Registriert seit: 29.05.2008
Ort: BERLIN
Alter: 28
Beiträge: 496
GER_CJ-187 eine Nachricht über ICQ schicken GER_CJ-187 eine Nachricht über Skype™ schicken
Standard

jo, stimmt, das habe ich vor knapp einer stunde dann auch probiert, und es funktioniert jetzt alles... vielen dank für deine Hilfe ;-)

jetzt hätte ich vllt noch eine Frage, die hier zwar nicht in dieses Thema gehört, ist aber auch inhalt dieser Mission...

undzwar möchte ich einen respawn, der nur aktiv ist, wenn das besagte objekt vom Fahrzeug abgeladen ist...

Wenn es auf dem Fahrzeug ist, soll der respawn bis zum abladen aufgeschoben werden...

Wenn alle tot sind und kein respawn möglich ist, = Mission gescheitert...

vllt kannst du mir da auch noch einen kleinen Tipp geben, währe dir bzw jeden anderen sehr dankbar

MfG - Chris
__________________

CPU: Intel Core i7-3770K ~ 4 x 3.5GHz // Mainboard: Asus P8P67 LE // RAM: 2 x 8GB DDR3-1333 RAM
Grafikkarte: Nvidia GTX 680 ~ 2GB // Soundkarte: Creative Gamer X-Fi

GER_CJ-187 ist offline   Mit Zitat antworten
Alt 19.09.2009, 20:09   #6 (permalink)
50 Beiträge100 Beiträge250 Beiträge
 
Benutzerbild von Hemingway
 
Registriert seit: 31.05.2009
Beiträge: 321
Standard

mit respawn von irgendwas hab ich mich ganz ehrlich noch nie auseinandergesetzt
__________________
Kickstart fighter launch
Throttle set to full
Speed king race to win
Afterburners roaring
Ghostlike counterstrike
Takes them by surprise
Hemingway ist offline   Mit Zitat antworten
Alt 19.09.2009, 20:36   #7 (permalink)
500 Beiträge1000 Beiträge2.500 Beiträge
 
Benutzerbild von Cyborg11
 
Registriert seit: 26.03.2008
Beiträge: 2.822
Standard

Nochmal zu deinem detach Problem.

Die Syntax von dir
Code:
B detach H
ist ja auch falsch.

Die richtige Syntax ist nichts anderes als:
Code:
detach B
detach - Bohemia Interactive Community
Cyborg11 ist offline   Mit Zitat antworten
Antwort

Stichworte
arma2, attach, problem


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Probleme mit DAC !!! b3ck5 Editing 1 28.04.2008 14:04
Probleme... KanakcAttack Hilfe 5 30.03.2004 21:42


Kontakt - HX3.de - Archiv - Nach oben

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias



SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116