Armed-Assault.de Twitter


Editing The world is a Script - write it!

Antwort
 
Themen-Optionen Ansicht
Alt 03.03.2010, 17:46   #1 (permalink)
Newbie
 
Registriert seit: 03.03.2010
Beiträge: 1
Icon9 Brauche Hilfe bei Bot-Problem

Hallo liebe Community

Also ich wollte gestern ein kleines Interstate 82 (Autokampf Game) Deathmatch basteln. Hatte nämlich ein schickes IS82 Fahrzeug gefunden, was ein netter Modder gemacht hatte.

Die Theorie sah ganz einfach aus:
- 3 Fraktionen
- Pro Fraktion 2 spielbare Figuren
- Nach Tod des Spielers b.z.w. Bots einfacher Respawn; das selbe mit dem Auto

Nach einigem hin und her habe ich es geschafft, das die Bots, die als Gunner dienen (aus dem einfachen Grund, da die manuelles Feuer Funktion bei dem Fahrzeug nich funktioniert) bei Tod respawnen zu lassen. Sah auch alles ganz gut aus und wir spielten ca. zehn Minuten.

Unweigerlich kam die Situation, dass mein Gegner und ich uns gegenseitig zerschrotteten. Nach Respawn des Fahrzeugs wollten die Bots nicht mehr ins Auto. Statt dessen zeigten sie uns eine schöne hinlegen/aufstehen Koreographie.

Anmerkung: Ich habe die Bots mit Hilfe von Auslösern immer im Fahrzeug spawnen lassen d.h. war der Bot tot, wurde der Auslöser aktiv und beförderte ihn nach dem Respawn mit Hilfe des moveingunner Befehls wieder ins Auto. Jedoch ignorierten die Bots, so oft wir sie auch töteten den Befehl moveingunner scheinbar total, denn sie machten lediglich den Respawn am Todesplatz. Die beiden Bots, die logischerweise verfeindet sind waren ca. 30m oder so voneinander entfernt.

Jetzt meine Frage: Wie schaffe ich es, dass die Bots, auch wenn sie etwas näher aneinander sind, den Befehl moveingunner befolgen und nicht sturr neben dem Fahrzeug verweilen.


Hoffe ihr habt mein Problem verstanden XD Falls nicht werde ich euch ein Video machen.

mfg Thalis
Thalis ist offline   Mit Zitat antworten
Antwort

Stichworte
bots, problem


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are aus

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Brauche Hilfe !!! redemption2009 Mods & Addons 2 17.09.2009 12:05
proxy problem? brauche hilfe mit bomben! SerapH]X[Lt. Mods & Addons 3 27.01.2008 00:08
Brauche Hilfe bei VTE Mod killskin Mod und Addon Ecke 10 14.12.2006 16:34


Kontakt - HX3.de - Archiv - Nach oben

Angetrieben durch vBulletin, Entwicklung von Philipp Dörner & Tobias



SEO by vBSEO 3.2.0 ©2008, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116